aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages poedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages rdf)
  #:use-module (gnu packages wxwidgets)
  #:use-module (gnu packages xml))

(define-public poedit
  (package
    (name "poedit")
    (version "2.2.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/vslavik/poedit")
                     (commit (string-append "v" version "-oss"))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (delete-file-recursively "deps")
                 #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
                            "/lib"))))
    (native-inputs
     (list autoconf automake gettext-minimal pkg-config))
    (inputs
     (list boost
           enchant
           gtk+
           gtkspell3
           icu4c
           lucene++
           pugixml
           wxwidgets))
    (home-page "https://poedit.net/")
    (synopsis "Gettext catalog editing tool")
    (description "Poedit is a GUI frontend to the GNU gettext utilities and
a catalog editor/source code parser.  It helps with translating applications
into other languages.")
    (license license:expat)))
gly. [native-inputs]: Remove vim-full. Remove input labels. Change-Id: I20cc1e0772727f8fc7db70b42151432fb6349fc7 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jean-Pierre De Jesus DIAZ 2024-01-01gnu: Add neovim-vader....* gnu/packages/vim.scm (neovim-vader): New variable. Change-Id: Ib507c2086c31a42088f3f433b57ac1e345e27113 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jean-Pierre De Jesus DIAZ 2024-01-01gnu: vim-vader: Allow using neovim for tests....* gnu/packages/vim.scm (vim-vader): Allow using neovim for tests. Change-Id: Id5b4423f24fdd42814b0a0e3fab801ec871611f7 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jean-Pierre De Jesus DIAZ 2023-11-26gnu: Add vim-jedi-vim....* gnu/packages/vim.scm (vim-jedi-vim): New variable. Change-Id: I2656837686866961266b093cd6b4a4d528f5f684 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Nguyễn Gia Phong 2023-11-26gnu: Add vim-srcery-vim....* gnu/packages/vim.scm (vim-srcery-vim): New variable. Change-Id: If53bdae6783af5500f517c4941babb3bdb6522e7 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Nguyễn Gia Phong 2023-11-26gnu: vim-coqtail: Use vim-build-system....* gnu/packages/vim.scm (vim-coqtail)[build-system]: Switch to the vim-build-system. [arguments]: Remove install-plan. Add plugin-name. Adjust custom 'check phase to refer to vim-full. [native-inputs]: Use 'old-style' package references to be able to specify vim-full. Change-Id: Iae3877738032a5583320245f63775f187c40fb6a Efraim Flashner 2023-11-26gnu: vim-vader: Use vim-build-system....* gnu/packages/vim.scm (vim-vader)[build-system]: Switch to the vim-build-system. [arguments]: Remove install-plan. Add plugin-name. (vim-coqtail)[arguments]: Adjust reference to vim-vader. Change-Id: I8210054e062b608706ee37a77f60969948b1c3b5 Efraim Flashner 2023-11-23gnu: Add vim-coqtail....* gnu/packages/vim.scm (vim-coqtail): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I5fa7266227097c724e29be4a133a8dc4bb8bb1af Jean-Pierre De Jesus DIAZ 2023-11-23gnu: Add vim-vader....* gnu/packages/vim.scm (vim-vader): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jean-Pierre De Jesus DIAZ 2023-11-08gnu: Have vim packages use vim-build-system....* gnu/packages/vim.scm (vim-neocomplete, vim-neocomplete-snippets, vim-neosnippet, vim-scheme, vim-luna, vim-fugitive, vim-airline, vim-airline-themes, vim-syntastic, neovim-syntastic, vim-solarized, vim-rainbow, editorconfig-vim, neovim-packer, vim-guix-vim, vim-asyncrun, vim-dispatch, vim-gemini-vim, vim-eunuch, vim-slime, vim-vlime, vim-paredit, vim-surround, vim-gnupg, vim-ctrlp, vim-mucomplete, vim-gitgutter, vim-characterize, vim-tagbar, vim-nerdtree, vim-nerdcommander): [build-system]: Switch to vim-build-system. [arguments]: Adjust accordingly. * gnu/packages/code.scm (global)[arguments]: Move vim files to their new location. * gnu/packages/lisp.scm (txr), * gnu/packages/mail.scm (msmtp), * gnu/packages/rust-apps.scm (skim), * gnu/packages/vim.scm (vifm), * gnu/packages/wm.scm (fluxbox): Same. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I8b3e5d65d76a100c3dbddc1ae562b72966c2b304 Jonathan Scoresby 2023-11-03gnu: neovim: Update to 0.9.4....* gnu/packages/vim.scm (neovim): Update to 0.9.4. Change-Id: I7246390c69875cbc1d7442afe38abd31ce85616b Signed-off-by: Christopher Baines <mail@cbaines.net> Benjamin 2023-10-14gnu: Add vim-rainbow...* gnu/packages/vim.scm (vim-rainbow): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> mason1920 2023-10-08gnu: vim: Update to 9.0.2001....* gnu/packages/vim.scm (vim): Update to 9.0.2001. [arguments]: Skip another test. Efraim Flashner 2023-09-08gnu: Add vim-vlime....* gnu/packages/vim.scm (vim-vlime): New variable. Signed-off-by: jgart <jgart@dismail.de> Charles Jackson