aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages poedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages rdf)
  #:use-module (gnu packages wxwidgets)
  #:use-module (gnu packages xml))

(define-public poedit
  (package
    (name "poedit")
    (version "2.2.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/vslavik/poedit")
                     (commit (string-append "v" version "-oss"))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (delete-file-recursively "deps")
                 #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
                            "/lib"))))
    (native-inputs
     (list autoconf automake gettext-minimal pkg-config))
    (inputs
     (list boost
           enchant
           gtk+
           gtkspell3
           icu4c
           lucene++
           pugixml
           wxwidgets))
    (home-page "https://poedit.net/")
    (synopsis "Gettext catalog editing tool")
    (description "Poedit is a GUI frontend to the GNU gettext utilities and
a catalog editor/source code parser.  It helps with translating applications
into other languages.")
    (license license:expat)))
an class='msg-tooltip'>* gnu/packages/security-token.scm (pcsc-lite): Update to 2.0.0. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Arjan Adriaanse 2024-08-11gnu: eid-mw: Update to 5.1.19....* gnu/packages/security-token.scm (eid-mw): Update to 5.1.19. Change-Id: Ic4a8c67d689acb1d86ca5b477b92d29601dbe1e8 Tobias Geerinckx-Rice 2024-06-24gnu: opensc: Switch to new package style....* gnu/packages/security-token.scm (opensc)[arguments]: Use g-exps. Change-Id: I3e59323deb804ba98669d51771ccfa05a92723e3 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Timotej Lazar 2024-06-24gnu: opensc: Update to 0.25.1....* gnu/packages/security-token.scm (opensc): Update to 0.25.1. Change-Id: I16dbf047671115274a25c3b1fba0285952f9f41d Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Timotej Lazar 2024-05-23gnu: Add pkcs11-helper....* gnu/packages/security-token.scm (pkcs11-helper): New variable. Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Andy Tai 2024-05-06Revert "gnu: pcsc-lite: Update to 2.1.0."...This reverts commit a8f0e8a31dd9b74a4f9950b3e2efe8dfeed5789a. It leads to 3799 dependent packages being rebuilt, so it's not suitable for the master branch. Ricardo Wurmus 2024-05-06gnu: pcsc-lite: Update to 2.1.0....* gnu/packages/security-token.scm (pcsc-lite): Update to 2.1.0. Reviewed-by: Christina O'Donnell <cdo@mutix.org> Change-Id: I133fd056afb84259cf5cb1f3e9c664ac336e50b9 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Arjan Adriaanse 2024-04-26gnu: opensc: Update to 0.25.0....* gnu/packages/security-token.scm (opensc): Update to 0.25.0. Change-Id: I811b997de40ae6fbbf2bb8256884be74683dbf4b Signed-off-by: Christopher Baines <mail@cbaines.net> Andy Tai 2024-04-02gnu: ccid: Fix cross-compilation....* gnu/packages/security-token.scm (ccid): Fix cross-compilation. Change-Id: I15c96a57e155742f5a2a8394402ae0fb0563f663 Signed-off-by: Efraim Flashner <efraim@flashner.co.il> dan 2024-03-19gnu: ausweisapp: Update to 2.1.0....* gnu/packages/security-token.scm (ausweisapp2): Deprecate and rename to... (ausweisapp): ... this. Update to 2.1.0. [build-system]: Switch to qt-build-system. [inputs]: Update dependencies to Qt6. [native-inputs]: Replace qttools-5 with qttools. Sergey Trofimov