aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages poedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages rdf)
  #:use-module (gnu packages wxwidgets)
  #:use-module (gnu packages xml))

(define-public poedit
  (package
    (name "poedit")
    (version "2.2.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/vslavik/poedit")
                     (commit (string-append "v" version "-oss"))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (delete-file-recursively "deps")
                 #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
                            "/lib"))))
    (native-inputs
     (list autoconf automake gettext-minimal pkg-config))
    (inputs
     (list boost
           enchant
           gtk+
           gtkspell3
           icu4c
           lucene++
           pugixml
           wxwidgets))
    (home-page "https://poedit.net/")
    (synopsis "Gettext catalog editing tool")
    (description "Poedit is a GUI frontend to the GNU gettext utilities and
a catalog editor/source code parser.  It helps with translating applications
into other languages.")
    (license license:expat)))
skell.scm?id=7df09ee0ab3e7962ef27859ce87e06a323059284'>Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-28gnu: ghc-9.2: Increase max-silent-time....Times out on i686 CI, but not locally. * gnu/packages/haskell.scm (ghc-9.2)[properties]: Add max-silent-time. Lars-Dominik Braun 2023-02-27gnu: ghc: Disable failing test on i686...Conditionally, so we don’t rebuild GHC on amd64. * gnu/packages/haskell.scm (ghc-9.2)[arguments]: Conditionally add phase 'skip-T21694-i686. Lars-Dominik Braun 2023-02-26gnu: ghc-9.2: Support static linking with glibc < 2.34....* gnu/packages/patches/ghc-9.2-glibc-2.33-link-order.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/haskell.scm (ghc-9.2)[origin]: Use it. Lars-Dominik Braun 2023-02-26gnu: ghc-9.2: Increase make verbosity....Tests time out on ci.guix.gnu.org. * gnu/packages/haskell.scm (ghc-9.2)[arguments]: Modify #:make-flags. Lars-Dominik Braun 2023-02-26gnu: Switch default to GHC 9.2....* gnu/packages/haskell.scm (ghc-9.0): Rename to just “ghc”. (ghc-9.2): Ditto. (ghc): Use ghc-9.2. Lars-Dominik Braun 2023-02-05gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'....* gnu/packages/version-control.scm: Rename variable 'git-minimal/fixed' to 'git-minimal/pinned', add depreciation. * gnu/packages/erlang.scm (erlang-erlware-commons)[native-inputs]: Replace 'git-minimal/fixed' with 'git-minimal/pinned'. (rebar3-git-vsn)[inputs]: Likewise. * gnu/packages/gnome.scm (gnome-photos)[native-inputs]: Likewise. * gnu/packages/gtk.scm (graphene)[native-inputs]: Likewise. * gnu/packages/haskell.scm (ghc-8.8, ghc-8.10)[native-inputs]: Likewise. * gnu/packages/julia-xyz.scm (julia-documenter)[native-inputs]: Likewise. * gnu/packages/ocaml.scm (opam, ocamlformat)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-check-manifest)[native-inputs]: Likewise. (python-scikit-build)[native-inputs]: Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Simon Tournier 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-12-31gnu: Add ghc-9.4....* gnu/packages/haskell.scm (ghc-9.4): New variable. (ghc-bootstrap-for-9.4): New variable. (ghc-alex-bootstrap-for-9.4): New variable. (ghc-happy-bootstrap-for-9.4): New variable. Lars-Dominik Braun 2022-12-31gnu: Add ghc-9.2....* gnu/packages/haskell.scm (ghc-9.2): New variable. Lars-Dominik Braun 2022-10-31gnu: Add ghc-6.10....* gnu/packages/haskell.scm (ghc-6.10): New variable. Ricardo Wurmus 2022-10-31gnu: ghc-6.6: Patch more references to /bin/sh....* gnu/packages/haskell.scm (ghc-6.6)[arguments]: Patch references to /bin/sh in Cabal and process internals. Ricardo Wurmus 2022-10-28gnu: Add ghc-6.6....* gnu/packages/haskell.scm (ghc-6.6): New variable. Ricardo Wurmus 2022-10-28gnu: ghc-6.0: Adjust configuration....* gnu/packages/haskell.scm (ghc-6.0)[arguments]: Pass --enable-src-tree-happy option; remove --with-hc option because we use the same GHC for everything; add --with-gcc option to embed absolute file name of GCC. [native-inputs]: Remove unused python-2. Ricardo Wurmus 2022-10-28gnu: ghc-4: Embed absolute file name of GCC in GHC....* gnu/packages/haskell.scm (ghc-4)[arguments]: Pass "--with-gcc" option to configure script. Ricardo Wurmus 2022-10-27gnu: Add ghc-6.0....* gnu/packages/haskell.scm (ghc-6.0): New variable. Ricardo Wurmus 2022-10-27gnu: ghc-4: Build full compiler using provided *.hc files....* gnu/packages/haskell.scm (ghc-4)[source]: Remove patch. [arguments]: Change to build full compiler. [native-inputs]: Remove default binutils and gcc; add tarball for hc files. * gnu/packages/patches/ghc-4.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Remove it. Ricardo Wurmus 2022-10-16gnu: ghc-4: Use Perl 5.6...* gnu/packages/haskell.scm (ghc-4)[native-inputs]: Replace perl-5.14 with perl-5.6. Ricardo Wurmus 2022-10-12Merge remote-tracking branch 'origin/master' into staging...Conflicts: gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/kde-frameworks.scm gnu/packages/video.scm Efraim Flashner 2022-10-02gnu: Add ghc-9.0....* gnu/packages/haskell.scm (ghc-9.0): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> itd 2022-09-18gnu: ghc@8.4: Adjust test suite for Python 3.10....This applies the substitution added in 48718135e74994e671eaf6dc6b74ac90e1e8a939 also for GHC@8.4. Somehow this problem is not fatal there and went unnoticed. * gnu/packages/haskell.scm (ghc-8.4)[native-inputs]: Patch the test driver for Python 3.10 compatibility. Marius Bakke 2022-09-10gnu: GHC: Adjust tests for grep 3.8....This fixes a test failure introduced in commit c527b0ce23c5d9228d29c5f90892aa5f05e77347. * gnu/packages/patches/ghc-testsuite-grep-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10)[native-inputs]: Patch the 'ghc-testsuite' input. Marius Bakke 2022-09-01gnu: GHC: Adjust for Python 3.10....* gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10)[native-inputs]: Patch the test suite for Python 3.10 compatibility. Marius Bakke 2022-08-27Merge branch 'staging' into core-updatesMarius Bakke 2022-08-23gnu: ghc-8.10: Build using ghc-8.6....* gnu/packages/haskell.scm (ghc-8.10)[native-inputs]: Replace ghc-8.8 with ghc-8.6. Efraim Flashner 2022-08-23gnu: ghc-8.10: Rewrite using G-exps....* gnu/packages/haskell.scm (ghc-8.10)[arguments]: Rewrite using g-exps. Efraim Flashner 2022-08-23gnu: ghc-8.10: Add phase unconditionally....* gnu/packages/haskell.scm (ghc-8.10)[arguments]: Apply custom 'skip-failing-tests-i686 phase for all architectures. Efraim Flashner 2022-08-23gnu: ghc-8.8: Rewrite using G-exps....* gnu/packages/haskell.scm (ghc-8.8)[arguments]: Rewrite using g-exps. Remove trailing #t from phases. Efraim Flashner 2022-08-23gnu: ghc-8.6: Rewrite using G-exps....* gnu/packages/haskell.scm (ghc-8.6)[arguments]: Rewrite using g-exps. Remove trailing #t from phases. Efraim Flashner 2022-08-23gnu: ghc-8.4: Modernize package....* gnu/packages/haskell.scm (ghc-8.4)[inputs]: Use inherited inputs. [arguments]: Rewrite using g-exps. Adjust to use inherited package arguments. Use inherited 'unpack-testsuite, 'fix environment phases. Remove redundant 'fix-references phase. (ghc-8.8)[arguments]: Adjust phases based on changed inherited phases. Efraim Flashner 2022-08-23gnu: ghc-8.0: Modernize package....* gnu/packages/haskell.scm (ghc-8.0)[arguments]: Rewrite using g-exps. Unpack testsuite tarball from the store. Remove trailing #t from phases. [inputs]: Remove input labels. Move ghc-testsuite ... [native-inputs]: ... to here. Efraim Flashner 2022-08-23gnu: ghc-7: Update to 7.10.3....* gnu/packages/haskell.scm (ghc-7): Update to 7.10.3. Efraim Flashner 2022-08-21gnu: ghc-7: Unpack tarballs from the store....* gnu/packages/haskell.scm (ghc-7)[arguments]: Adjust custom 'unpack-bin and 'unpack-testsuite-and-fix-bins phases to unpack tarballs directly from the store. Efraim Flashner 2022-08-21gnu: ghc-7: Rewrite arguments using G-expressions....* gnu/packages/haskell.scm (ghc-7)[arguments]: Rewrite using G-expressions. Remove trailing #t from phases. Efraim Flashner 2022-08-11gnu: ghc: Use a LibFFI variant without static trampolines....* gnu/packages/haskell.scm (ghc-7, ghc-8.0, ghc-8.4)[inputs]: Change from LIBFFI to LIBFFI-SANS-STATIC-TRAMPOLINES. * gnu/packages/libffi.scm (libffi-sans-static-trampolines): New variable. Marius Bakke