aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages poedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages rdf)
  #:use-module (gnu packages wxwidgets)
  #:use-module (gnu packages xml))

(define-public poedit
  (package
    (name "poedit")
    (version "2.2.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/vslavik/poedit")
                     (commit (string-append "v" version "-oss"))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (delete-file-recursively "deps")
                 #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
                            "/lib"))))
    (native-inputs
     (list autoconf automake gettext-minimal pkg-config))
    (inputs
     (list boost
           enchant
           gtk+
           gtkspell3
           icu4c
           lucene++
           pugixml
           wxwidgets))
    (home-page "https://poedit.net/")
    (synopsis "Gettext catalog editing tool")
    (description "Poedit is a GUI frontend to the GNU gettext utilities and
a catalog editor/source code parser.  It helps with translating applications
into other languages.")
    (license license:expat)))
p-integrity-next.el: New file. * Makefile.am (AUX_FILES): Register it here. * gnu/packages/emacs.scm (emacs-next-minimal): Update to 30.0.60-1.4e22ef8. (emacs->emacs-next)[arguments]: Swap out ‘validate-comp-integrity’ phase, so as to refer to the new integrity check. Liliana Marie Prikler 2024-06-23Revert "gnu: emacs: Update to 29.4. (security fixes)"...This reverts commit 7e15704613b67ec54df8f1269916bc72b76bb785. It causes rebuilds to all of emacs-*, whereas a graft has already been applied in 868a022cdca164941a6fe8dcf205aefc693781cb. Liliana Marie Prikler 2024-06-23gnu: emacs: Update to 29.4. (security fixes)...This fixes an issue where org-mode would run arbitrary shell code on startup. See <https://lists.gnu.org/archive/html/emacs-devel/2024-06/msg00695.html> for the release announcement. * gnu/packages/emacs.scm (emacs-minimal): Update to 29.4. Liliana Marie Prikler 2024-06-23gnu: emacs-minimal: Graft with 29.4 [security fixes]....Arbitrary shell commands are no longer run when turning on Org mode. This is for security reasons, to avoid running malicious commands. * gnu/packages/emacs.scm (emacs-minimal/fixed): New variable. (emacs-minimal)[replacement]: Graft. Change-Id: Idb74ee0a05486bfe5052c4dd804fbdaec8921774 Zheng Junjie 2024-03-30gnu: emacs: Also skip integrity check for i686-linux....The same cases fail as with armhf-linux. * gnu/packages/emacs.scm (emacs-no-x)[#:phases]<validate-comp-integrity>: Also skip check on i686-linux. Liliana Marie Prikler 2024-03-28gnu: emacs-no-x: Skip integrity test on armhf-linux....* gnu/packages/emacs.scm (emacs-no-x)[#:phases]<validate-runpath>: Move checks to GExpression expansion. Add check against armhf-linux. Liliana Marie Prikler 2024-03-26gnu: emacs: Update to 29.3....* gnu/packages/emacs.scm (emacs-minimal): Update to 29.3. Liliana Marie Prikler 2024-03-02gnu: emacs-next-minimal: Update to 30.0.50-2.170c655....* gnu/packages/emacs.scm (emacs-next-minimal): Update to 30.0.50-2.170c655. * gnu/packages/aux-files/emacs/comp-integrity.el: Adjust accordingly. Liliana Marie Prikler 2024-02-24gnu: emacs: Disable jit compilation....* gnu/packages/patches/emacs-disable-jit-compilation.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/emacs.scm (emacs-minimal)[patches]: Use it here. Liliana Marie Prikler 2024-02-24gnu: emacs: Check integrity of native-compiled files....In the previous commit, we've added a patch that potentially messes with how built-in (especially preloaded) Lisp libraries are loaded. Thus, we might want to assert that these files still load fine, as reported when querying the builtin documentation of functions provided by them. * gnu/packages/aux-files/emacs/comp-integrity.el: New file. * gnu/Makefile.am (dist_noinst_DATA): Register it here. * gnu/packages/emacs.scm (emacs-no-x)[#:phases]: Add ‘validate-comp-integrity’. Liliana Marie Prikler 2024-02-24gnu: emacs: Don't hash file names in native compilation....* gnu/packages/patches/emacs-native-comp-fix-filenames.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/emacs.scm (emacs-minimal)[source]: Use it here. Change-Id: I2b7f6b45742a985760f0097bb53910f068e3d8e5 Liliana Marie Prikler 2024-02-24gnu: emacs: Build trampolines....* gnu/packages/emacs.scm (emacs-no-x)[#:phases]: Add ‘build-trampolines’. Change-Id: I33303bcbaf6cbda15867a5546e793c05d1f0e67b Liliana Marie Prikler 2024-01-21gnu: emacs-minimal: Update to 29.2....* gnu/packages/emacs.scm (emacs-minimal): Update to 29.2. Liliana Marie Prikler 2024-01-21gnu: emacs-minimal: Set upstream-name to “emacs”....* gnu/packages/emacs.scm (emacs-minimal)[properties]: Add ‘upstream-name’. Liliana Marie Prikler 2024-01-18gnu: emacs: Patch awk, find, sed and sh commands....Before this change, using Emacs in a pure environment, e.g. 'guix shell --pure emacs', would cause problems such as: jka-compr-insert-file-contents: Uncompression program ‘sh’ not found And other problems were found requiring the other tools. * gnu/packages/emacs.scm (emacs-minimal) [arguments]: Extend the patch-program-file-names phase. [inputs]: Add findutils, gawk and sed. Series-changes: 2 - Patch references in place instead of wrapping via PATH Change-Id: Ifb4fe2fc12ddc9eae387adb3da3f7821fab78e65 Maxim Cournoyer