aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages poedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages rdf)
  #:use-module (gnu packages wxwidgets)
  #:use-module (gnu packages xml))

(define-public poedit
  (package
    (name "poedit")
    (version "2.2.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/vslavik/poedit")
                     (commit (string-append "v" version "-oss"))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (delete-file-recursively "deps")
                 #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
                            "/lib"))))
    (native-inputs
     (list autoconf automake gettext-minimal pkg-config))
    (inputs
     (list boost
           enchant
           gtk+
           gtkspell3
           icu4c
           lucene++
           pugixml
           wxwidgets))
    (home-page "https://poedit.net/")
    (synopsis "Gettext catalog editing tool")
    (description "Poedit is a GUI frontend to the GNU gettext utilities and
a catalog editor/source code parser.  It helps with translating applications
into other languages.")
    (license license:expat)))
>Tobias Geerinckx-Rice 2019-11-03gnu: makefile2graph: Don't use unstable tarball....* gnu/packages/code.scm (makefile2graph)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-11-03gnu: withershins: Don't use unstable tarball....* gnu/packages/code.scm (withershins)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-11-03gnu: withershins: Build....* gnu/packages/code.scm (withershins)[arguments]: Don't treat compiler warnings as errors. Tobias Geerinckx-Rice 2019-10-20gnu: Remove more GCC < 7 workarounds....* gnu/packages/abiword.scm (abiword)[arguments]: Do not pass "-std=c++11" to the GCC command line. * gnu/packages/aidc.scm (zbar)[arguments]: Likewise. * gnu/packages/android.scm (android-libbase, android-libcutils, android-libziparchive, fastboot)[arguments]: Likewise. * gnu/packages/audio.scm (azr3, guitarix, suil)[arguments]: Likewise. * gnu/packages/bioinformatics.scm (bless)[arguments]: Likewise. * gnu/packages/bittorrent.scm (libtorrent-rasterbar)[arguments]: Likewise. * gnu/packages/code.scm (rtags)[arguments]: Likewise. * gnu/packages/coq.scm (coq-gappa)[arguments]: Likewise. * gnu/packages/emulators.scm (dolphin-emu)[arguments]: Likewise. * gnu/packages/engineering.scm (xyce-serial, xyce-parallel)[arguments]: Likewise. * gnu/packages/gnupg.scm (pinentry-qt)[arguments]: Likewise. * gnu/packages/gobby.scm (libnet6, obby)[arguments]: Likewise. * gnu/packages/graph.scm (python-faiss)[arguments]: Likewise. * gnu/packages/graphics.scm (povray)[arguments]: Likewise. * gnu/packages/image-processing.scm (opencv, itk-snap)[arguments]: Likewise. * gnu/packages/image.scm (freeimage)[arguments]: Likewise. * gnu/packages/kodi.scm (crossguid)[arguments]: Likewise. * gnu/packages/music.scm (amsynth, qmidiarp, qmidiroute, seq24)[arguments]: Likewise. * gnu/packages/pdf.scm (python-poppler-qt5)[arguments]: Likewise. * gnu/packages/sagemath.scm (lcalc)[arguments]: Likewise. * gnu/packages/video.scm (vlc, mlt, v4l-utils)[arguments]: Likewise. Marius Bakke 2019-07-09gnu: Remove indent@2.2.10....* gnu/packages/code.scm (indent): Update to 2.2.12. [native-inputs]: Add TEXINFO. (indent-2.2.12): Remove variable. Marius Bakke 2019-05-14gnu: uncrustify: Update to 0.69.0....* gnu/packages/code.scm (uncrustify): Update to 0.69.0. Pierre Neidhardt 2019-05-09gnu: cloc: Update to 1.82....* gnu/packages/code.scm (cloc): Update to 1.82. [source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2019-03-06gnu: lcov: Update to 1.14....* gnu/packages/code.scm (lcov): Update to 1.14. Tobias Geerinckx-Rice 2019-02-27gnu: cflow: Update to 1.6....* gnu/packages/code.scm (cflow): Update to 1.6. Efraim Flashner 2019-01-24gnu: sloccount: Use INVOKE....* gnu/packages/code.scm (sloccount)[arguments]: Use INVOKE and unconditionally return #T from build phases. Ricardo Wurmus 2019-01-16gnu: Move sqlite to separate module....* gnu/packages/databases.scm (sqlite, sqlite-3.26.0, sqlite-with-fts5, sqlite-with-column-metadata): Move variables from here... * gnu/packages/sqlite.scm: ...to this new module. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/apl.scm, gnu/packages/bittorrent.scm, gnu/packages/calendar.scm, gnu/packages/code.scm, gnu/packages/crypto.scm, gnu/packages/databases.scm, gnu/packages/dc.scm, gnu/packages/disk.scm, gnu/packages/ebook.scm, gnu/packages/education.scm, gnu/packages/emacs.scm, gnu/packages/emulators.scm, gnu/packages/file-systems.scm, gnu/packages/freedesktop.scm, gnu/packages/ftp.scm, gnu/packages/games.scm, gnu/packages/geo.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/gps.scm, gnu/packages/guile.scm, gnu/packages/ibus.scm, gnu/packages/kerberos.scm, gnu/packages/kodi.scm, gnu/packages/lisp.scm, gnu/packages/mail.scm, gnu/packages/messaging.scm, gnu/packages/mpd.scm, gnu/packages/music.scm, gnu/packages/networking.scm, gnu/packages/nfs.scm, gnu/packages/ocaml.scm, gnu/packages/package-management.scm, gnu/packages/pdf.scm, gnu/packages/photo.scm, gnu/packages/php.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/scheme.scm, gnu/packages/sync.scm, gnu/packages/syndication.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/web-browsers.scm, gnu/packages/webkit.scm: Adjust module references. Ricardo Wurmus 2019-01-06gnu: global: Update to 6.6.3....* gnu/packages/code.scm (global): Update to 6.6.3. Efraim Flashner 2018-11-30gnu: uncrustify: Use git reference instead of GitHub archive....* gnu/packages/code.scm (uncrustify): Use git reference instead of GitHub archive. Pierre Neidhardt 2018-11-25gnu: uncrustify: Update to 0.68.1....* gnu/packages/code.scm (uncrustify): Update to 0.68.1. Pierre Neidhardt 2018-10-30gnu: cloc: Update to 1.80....* gnu/packages/code.scm (cloc): Update to 1.80. Tobias Geerinckx-Rice 2018-10-04gnu: rtags: Don't use unstable tarball....* gnu/packages/code.scm (rtags)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2018-09-10gnu: cloc: Update source hash....The upstream tarball was modified in place. The only changes are: --- /gnu/store/5v39h6zjs33hj5dm2yggz5qk0mva00bs-cloc-1.78.tar.gz +++ /gnu/store/pm5ghks76vv6awv3969yvi7qxqfnfs1l-cloc-1.78.tar.gz ├── filetype from file(1) │ @@ -1 +1 @@ │ -gzip compressed data, last modified: Fri Sep 7 18:22:49 2018, from Unix │ +gzip compressed data, last modified: Sat Sep 8 14:09:43 2018, from Unix │ --- 5v39h6zjs33hj5dm2yggz5qk0mva00bs-cloc-1.78.tar ├── +++ pm5ghks76vv6awv3969yvi7qxqfnfs1l-cloc-1.78.tar │ ├── file list │ │ @@ -1,13 +1,13 @@ │ │ -rwxrwxr-x 0 al (1000) al (1000) 545021 2018-09-07 18:21:22 cloc-1.78/cloc │ │ -rwxrwxr-x 0 al (1000) al (1000) 1818 2018-09-07 18:21:22 cloc-1.78/sqlite_formatter │ │ -drwxrwxr-x 0 al (1000) al (1000) 0 2018-09-07 18:21:22 cloc-1.78/Unix/ │ │ --rwxrwxr-x 0 al (1000) al (1000) 498571 2018-09-07 18:21:22 cloc-1.78/Unix/cloc │ │ +drwxrwxr-x 0 al (1000) al (1000) 0 2018-09-08 14:09:23 cloc-1.78/Unix/ │ │ +-rwxrwxr-x 0 al (1000) al (1000) 498537 2018-09-08 14:09:22 cloc-1.78/Unix/cloc │ │ -rwxrwxr-x 0 al (1000) al (1000) 32382 2018-09-07 18:21:22 cloc-1.78/Unix/t/00_C.t │ │ -rwxrwxr-x 0 al (1000) al (1000) 12614 2018-09-07 18:21:22 cloc-1.78/Unix/t/01_opts.t │ │ -rw-rw-r-- 0 al (1000) al (1000) 862 2018-09-07 18:21:22 cloc-1.78/Unix/README │ ├── cloc-1.78/Unix/cloc │ │ @@ -1,8 +1,7 @@ │ │ -#!/usr/local/perl/5.28.0/bin/perl │ │ #!/usr/bin/env perl * gnu/packages/code.scm (cloc)[source]: Update sha256 hash. Tobias Geerinckx-Rice 2018-09-09gnu: cloc: Update to 1.78....* gnu/packages/code.scm (cloc): Update to 1.78. [source]: Update URI. Tobias Geerinckx-Rice 2018-09-07gnu: indent: Add version 2.2.12....* gnu/packages/code.scm (indent-2.2.12): New variable. Ludovic Courtès