aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages poedit)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages icu4c)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages rdf)
  #:use-module (gnu packages wxwidgets)
  #:use-module (gnu packages xml))

(define-public poedit
  (package
    (name "poedit")
    (version "2.2.4")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/vslavik/poedit")
                     (commit (string-append "v" version "-oss"))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 (delete-file-recursively "deps")
                 #t))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
                            "/lib"))))
    (native-inputs
     (list autoconf automake gettext-minimal pkg-config))
    (inputs
     (list boost
           enchant
           gtk+
           gtkspell3
           icu4c
           lucene++
           pugixml
           wxwidgets))
    (home-page "https://poedit.net/")
    (synopsis "Gettext catalog editing tool")
    (description "Poedit is a GUI frontend to the GNU gettext utilities and
a catalog editor/source code parser.  It helps with translating applications
into other languages.")
    (license license:expat)))
use the right Webkit. * gnu/packages/gnome.scm (yelp)[inputs]: Replace webkitgtk with webkitgtk-for-gtk3. Liliana Marie Prikler 2023-12-12gnu: epiphany: Build with webkitgtk-for-gtk3....This replacement was omitted in f3da903b0169edc19e07be5a91c80488332abe09: Epiphany 42 still builds with GTK+ 3, so let's use the right Webkit. * gnu/packages/gnome.scm (epiphany)[inputs]: Replace webkitgtk with webkitgtk-for-gtk3. Liliana Marie Prikler 2023-12-15gnu: Add libxml++-3....* gnu/packages/gnome.scm (libxml++-3): New variable. Change-Id: I2250766126f433b3f5dcc50cd7eaadec3acadad3 Ricardo Wurmus 2023-12-08gnu: Make webkitgtk-next the new webkitgtk....As of version 2.42.0, the WebKit 6.0 typelib is considered stable. With GNOME itself moving to GTK4 as time marches on, we should reflect the fact that this is the preferred Webkit for future applications. * gnu/packages/webkit.scm (webkitgtk-next): Remove variable. Inline logic… (webkitgtk): … here. Move old value … (webkitgtk-for-gtk3): … here. (webkitgtk-with-libsoup2): Inherit from webkitgtk-for-gtk3. * gnu/packages/geo.scm (gnome-maps): Adjust accordingly. * gnu/packages/gnome.scm (gnome-initial-setup, sushi) (cambalache, devhelp, devhelp-with-libsoup2, gnome-online-accounts) (gnome-online-accounts-3.44, evolution-data-server, evolution-data-server-3.44) (lollypop, evolution, gnome-boxes, geary, komikku): Likewise. * gnu/packages/guile-xyz.scm (guile-gi, nomad): Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-webkit): Likewise. * gnu/packages/mail.scm (balsa): Likewise. * gnu/packages/mate.scm (atril): Likewise. * gnu/packages/music.scm (ctrlr): Likewise. * gnu/packages/rednotebook.scm (rednotebook): Likewise. * gnu/packages/syndication.scm (gfeeds): Likewise. * gnu/packages/telegram.scm (telegram-desktop): Likewise. * gnu/packages/vnc.scm (remmina): Likewise. * gnu/packages/web-browsers.scm (nyxt): Likewise. Liliana Marie Prikler 2023-12-05gnu: gnome-commander: Update to 1.16.1....* gnu/packages/gnome.scm (gnome-commander): Update to 1.16.1. [build-system]: Switch to meson-build-system. [arguments]: Add #:glib-or-gtk?. [native-inputs]: Add gtk+-2:bin. Change-Id: I4badc000d0c2d8525fd3f8f1748d8fabe610c8a9 Vinicius Monego 2023-12-10Merge remote-tracking branch 'origin/master' into rust-team...Change-Id: Ic45f7071abd6a02c2ccad411500e5103c8272ffb Efraim Flashner 2023-11-28gnu: librsvg: Enable cross compiling....* gnu/packages/gnome.scm (librsvg)[arguments]: Use this-package-input to find gdk-pixbuf in 'patch-gdk-pixbuf-thumbnailer phase. Adjust 'prepare-for-build phase to set PKG_CONFIG and RUST_TARGET when needed. Adjust configure-flags when cross-compiling. [native-inputs]: Add gdk-pixbuf. [inputs]: Add gobject-introspection. Change-Id: I977c48957a6f50a777b52ea59c0d1f8bd6edcc1b Efraim Flashner 2023-11-28gnu: librsvg: Remove htmldir configure flag....* gnu/packages/gnome.scm (librsvg)[arguments]: Update configure-flags to remove the htmldir directory option. Change-Id: Ia8a0d73d00edf899eac8c9e12071b92c0eef5258 Efraim Flashner 2023-11-28gnu: librsvg: Honor the #:tests flag....* gnu/packages/gnome.scm (librsvg)[arguments]: Adjust the custom 'check phase to honor the #:tests? flag. Change-Id: I53c2fac1c5625d9b73adf5929e148eb4ecf18b89 Efraim Flashner 2023-12-02gnu: Use ‘libc-utf8-locales-for-target’....* guix/packages.scm (%standard-patch-inputs): Use ‘libc-utf8-locales-for-target’ instead of ‘glibc-utf8-locales’. * guix/self.scm (%packages): Likewise. * gnu/home/services/ssh.scm (file-join): Likewise * gnu/installer.scm (build-compiled-file): Likewise. * gnu/packages/chromium.scm (ungoogled-chromium/wayland): Likewise. * gnu/packages/gnome.scm (libgweather4, tracker): Likewise. * gnu/packages/javascript.scm (js-mathjax): Likewise. * gnu/packages/package-management.scm (guix, flatpak): Likewise. * gnu/packages/raspberry-pi.scm (raspi-arm64-chainloader): Likewise. * gnu/packages/suckless.scm (svkbd): Likewise. * gnu/services.scm (cleanup-gexp): Likewise. * gnu/services/base.scm (guix-publish-shepherd-service): Likewise. * gnu/services/guix.scm (guix-build-coordinator-shepherd-services) (guix-build-coordinator-agent-shepherd-services): Likewise. * gnu/services/guix.scm (guix-build-coordinator-queue-builds-shepherd-services): (guix-data-service-shepherd-services) (nar-herder-shepherd-services) (bffe-shepherd-services): Likewise. * gnu/services/web.scm (anonip-shepherd-service) (mumi-shepherd-services): Likewise. * gnu/system/image.scm (system-disk-image, system-iso9660-image) (system-docker-image, system-tarball-image): Likewise. * gnu/system/install.scm (%installation-services): Likewise. * guix/profiles.scm (info-dir-file): Likewise. (ca-certificate-bundle, profile-derivation): Likewise. * guix/scripts/pack.scm (store-database, set-utf8-locale): Likewise. * tests/pack.scm: Likewise. * tests/profiles.scm ("profile-derivation, cross-compilation"): Likewise. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Co-authored-by: Christopher Baines <mail@cbaines.net> Change-Id: I24239f427bcc930c29d2ba5d00dc615960a6c374 Janneke Nieuwenhuizen 2023-11-25gnu: network-manager-fortisslvpn: Depend on ppp 2.4.9....* gnu/packages/gnome.scm (network-manager-fortisslvpn): Update to 1.4.0. [inputs]: Remove ppp; add ppp-2.4.9. Change-Id: I5ef055e3fc5fc855aca8d2fa95ff995a229db89d Signed-off-by: Ludovic Courtès <ludo@gnu.org> Benjamin 2023-11-25gnu: network-manager-applet: Update to 1.34.0....* gnu/packages/gnome.scm (network-manager-applet): Update to 1.34.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Vasile Dumitrascu 2023-10-23gnu: mutter: Remove dependency on (guix build syscalls)....* gnu/packages/gnome.scm (mutter)[arguments]: Remove #:imported-modules. Remove (guix build syscalls) from #:modules. Rewrite ‘check’ phase to reap processes from the build process. [native-inputs]: Remove TINI. Ludovic Courtès 2023-10-21Merge remote-tracking branch 'origin/rust-team'Efraim Flashner 2023-10-18Revert "build: cargo-build-system: Disable tests by default."...This reverts commit 37667443074a6de29f7665868f102111d62f0af9. This change needs more discussion. Efraim Flashner 2023-10-18build: cargo-build-system: Disable tests by default....* guix/build-system/cargo.scm (cargo-build): Disable tests by default. * gnu/packages/admin.scm (greetd, wlgreet, du-dust), * gnu/packages/bioinformatics.scm (circtools, python-gseapy), * gnu/packages/crypto.scm (rust-minisign, b3sum), * gnu/packages/gnome.scm (librsvg), * gnu/packages/python-crypto.scm (python-blake3, python-cryptography-rust), * gnu/packages/python-xyz.scm (python-orjson), * gnu/packages/rust-apps.scm (agate, alfis, bat, diffr, drill, dutree, exa, fd, hexyl, hyperfine, i3status-rust, just, maturin, ripgrep, rot8, rust-swc, rust-cargo-edit, git-interactive-rebase-tool, rust-cbindgen, rust-cbindgen-0.24, rust-cbindgen-0.19, sniffglue, tectonic, treefmt, hex, tokei, vivid, watchexec, rbw, rust-analyzer, rust-cargo-c, rtss, skim, skim-0.7, svd2rust, swayhide, tealdeer, git-absorb, zoxide, htmlq), * gnu/packages/sequoia.scm (sequoia-sqv), * gnu/packages/syndication.scm (newsboat), * gnu/packages/terminals.scm (alacritty), * gnu/packages/text-editors.scm (kak-lsp, parinfer-rust), * gnu/packages/tree-sitter.scm (tree-sitter-cli), * gnu/packages/video.scm (rav1e), * gnu/packages/web.scm (monolith, castor) [arguments]: Enable tests. Efraim Flashner 2023-10-18gnu: librsvg: Update to 2.56.4....* gnu/packages/gnome.scm (librsvg): Update to 2.56.4. [source]: Remove snippet. [cargo-inputs]: Add rust-anyhow-1, rust-clap-complete-4, rust-encoding-rs-0.8, rust-system-deps-6, rust-thiserror-1. Replace rust-cairo-rs-0.15 with 0.17, rust-clap-2 with 4, rust-cssparser-0.28 with 0.29, rust-data-url-0.1 with 0.2, rust-gdk-gdkixbuf-0.15 with 0.17, rust-gio-0.15 with 0.17, rust-glib-0.15 with 0.17, rust-markup5ever-0.10 with 0.11, rust-nalgebra-0.29 with 0.32, rust-pango-0.15 with 0.17, rust-pangocairo-0.15 with 0.17, rust-rctree-0.4 with 0.5, rust-selectors-0.23 with 0.24, rust-xml5ever-0.16 with 0.17. Remove rust-encoding-0.2. [cargo-development-inputs]: Add rust-cast-0.3, rust-pango-0.17, rust-pangocairo-0.17. Replace rust-cairo-rs-0.15 with 0.17, rust-criterion-0.3 with 0.4, rust-glib-0.15 with 0.17, rust-lopdf-0.26 with 0.29, rust-yeslogic-fontconfig-sys-3 with 4. Remove rust-test-generator-0.3. [arguments]: Adjust custom phase 'loosen-test-boundaries to changes in the test suite. Efraim Flashner 2023-10-15gnu: tracker-miners: Update to 3.3.2....* gnu/packages/gnome.scm (tracker-miners): Update to 3.3.2. Liliana Marie Prikler 2023-10-15gnu: network-manager: Use Meson option for modprobe....* gnu/packages/gnome.scm (arguments): Replace the 'patch-modprobe-path phase with a ‘-Dmodprobe=’ configure flag. Tobias Geerinckx-Rice 2023-10-15gnu: network-manager: Update to 1.44.0....* gnu/packages/gnome.scm (network-manager): Update to 1.44.0. [arguments]: Disable the (new) nm-cloud-setup option. Tobias Geerinckx-Rice 2023-09-16gnu: gnome-dictionary: Fix build....* gnu/packages/patches/gnome-dictionary-meson-i18n.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/gnome.scm (gnome-dictionary): Use it here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Fixes: gnome-dictionary-40.0: fails configure <https://bugs.gnu.org/63687> raingloom 2023-09-11gnu: yelp: Provide dependencies to display "man:" URIs....Previously a command like the following one would fail to display the expected man page: guix shell yelp coreutils -C \ --expose=/tmp/.X11-unix --expose=/run/user \ --expose=/var/run/dbus --expose=/etc/machine-id -E ^DISPLAY -- \ /bin/sh -c \ 'export MANPATH=$GUIX_ENVIRONMENT/share/man; echo $MANPATH; yelp man:ls' * gnu/packages/gnome.scm (yelp)[arguments]: New field. [inputs]: Add ‘man-db’ and ‘groff-minimal’. Reported-by: Luis Felipe <sirgazil@zoho.com> Ludovic Courtès 2023-09-01gnu: sound-juicer: Update to 3.40.0....* gnu/packages/gnome.scm (sound-juicer): Update to 3.40.0. [arguments]<phases>: Adjust 'disable-gtk-update-icon-cache'. Add 'wrap-program' for GST_PLUGIN_SYSTEM_PATH. [inputs]: Add bash-minimal, for wrapper. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 宋文武 2023-08-18gnu: gnome-themes-extra: Build with librsvg-for-system....* gnu/packages/gnome.scm (gnome-themes-extra)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-18gnu: totem: Build with librsvg-for-system....* gnu/packages/gnome.scm (totem)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-18gnu: aisleriot: Build with librsvg-for-system....* gnu/packages/gnome.scm (aisleriot)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-18gnu: gnome-sudoku: Build with librsvg-for-system....* gnu/packages/gnome.scm (gnome-sudoku)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-18gnu: gtg: Build with librsvg-for-system....* gnu/packages/gnome.scm (gtg)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-18gnu: gtg: Add missing input....* gnu/packages/gnome.scm (gtg)[native-inputs]: Add itstool. Efraim Flashner 2023-08-15gnu: glabels: Build with librsvg-for-system....* gnu/packages/gnome.scm (glabels)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: gthumb: Build with librsvg-for-system....* gnu/packages/gnome.scm (gthumb)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: gnome-system-monitor: Build with librsvg-for-system....* gnu/packages/gnome.scm (gnome-system-monitor)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: gnome-control-center: Build with librsvg-for-system....* gnu/packages/gnome.scm (gnome-control-center)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: drawing: Build with librsvg-for-system....* gnu/packages/gnome.scm (drawing)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: gnome-photos: Build with librsvg-for-system....* gnu/packages/gnome.scm (gnome-photos)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-15gnu: libdmapsharing: Build with librsvg-for-system....* gnu/packages/gnome.scm (libdmapsharing)[inputs]: Replace librsvg with librsvg-for-system. Efraim Flashner 2023-08-06gnu: libcloudproviders: Remove redundant version field....* gnu/packages/gnome.scm (libcloudproviders)[version]: Remove field. Tobias Geerinckx-Rice