aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 宋文武 <iyzsong@member.fsf.org>
;;; Copyright © 2023 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages plan9)
  #:use-module (guix build-system gnu)
  #:use-module (guix git-download)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages base)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages freedesktop)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xdisorg)
  #:use-module (gnu packages xorg))

(define-public drawterm
  (let ((revision "1")
        (commit "f11139d4c918802a87730bc14d094670ee4ce572"))
    (package
      (name "drawterm")
      (version (git-version "20240703" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "git://git.9front.org/plan9front/drawterm")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32 "0ggh5g19899iq9bb5r03bvhamndyai4ylr3ajkbd02xkhz65fh5y"))))
      (build-system gnu-build-system)
      (arguments
       `(#:make-flags (list "CONF=unix"
                            (string-append "CC=" ,(cc-for-target)))
         #:tests? #f                    ; no tests
         #:phases
         (modify-phases %standard-phases
           (delete 'configure)          ; no configure script
           (replace 'install            ; no install target
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
                      (bin (string-append out "/bin/"))
                      (man (string-append out "/share/man/man1/")))
                 (install-file "drawterm" bin)
                 (install-file "drawterm.1" man)))))))
      (inputs
       (list libx11 libxt))
      (synopsis "Connect to Plan 9 systems")
      (home-page "https://drawterm.9front.org")
      (description
       "@command{drawterm} is a client for connecting venerable systems to
Plan 9 systems.  It behaves like a Plan 9 kernel and will attempt to
reconstruct a Plan 9 terminal-like experience from a non-Plan 9 system.")
      (license license:expat))))

(define-public drawterm-wayland
  (package
    (inherit drawterm)
    (name "drawterm-wayland")
    (arguments
     (substitute-keyword-arguments (package-arguments drawterm)
       ((#:make-flags _)
        `(list "CONF=linux"
               ,(string-append "CC=" (cc-for-target))))))
    (native-inputs
     (list pkg-config))
    (inputs
     (list libxkbcommon pipewire wayland wayland-protocols wlr-protocols))))

(define-public plan9port
  ;; no releases
  (let ((commit "f8681acb374fa0d5ed1568dbedb00a4abe1ca6f1")
        (revision "1"))
    (package
      (name "plan9port")
      (version (git-version "0.1.0" revision commit))
      (source (origin
                (method git-fetch)
                (uri (git-reference
                      (url "https://github.com/9fans/plan9port")
                      (commit commit)))
                (file-name (git-file-name name version))
                (sha256
                 (base32
                  "01343jvn8kr63i78h8xlgscn6wihdsr44xzh1cylvhigjbqw8n2x"))
                (modules '((guix build utils)))
                (snippet #~(for-each delete-file-recursively
                                     '("font/luc" ;nonfree
                                       "font/lucm" "font/lucsans" "font/pelm")))))
      (build-system gnu-build-system)
      (arguments
       (list #:tests? #f ;no tests
             #:strip-directories #~'("plan9/bin")
             #:phases
             #~(modify-phases %standard-phases
                 (add-after 'unpack 'setup
                   (lambda _
                     (let ((dest (string-append #$output "/plan9")))
                       (delete-file "src/cmd/mk/mk.pdf")
                       (substitute* "src/cmd/acme/acme.c"
                         (("/lib/font/bit/lucsans/euro.8.font")
                          (string-append dest
                                         "/font/fixed/unicode.5x8.font"))
                         (("/lib/font/bit/lucm/unicode.9.font")
                          (string-append dest
                                         "/font/fixed/unicode.6x9.font")))
                       (substitute* (find-files "src")
                         (("/lib/font/bit")
                          (string-append dest "/font")))
                       (substitute* "bin/9c"
                         (("which")
                          (which "which")))
                       (substitute* "src/cmd/fontsrv/freetyperules.sh"
                         (("'\\$i'/freetype2")
                          (string-append "-I"
                                         #$freetype
                                         "/include/freetype2")))
                       (with-output-to-file "LOCAL.config"
                         (lambda _
                           (format #t "CC9=~a~%" #$(cc-for-target))
                           (format #t "FONTSRV=fontsrv~%")))
                       (setenv "X11" #$libx11)
                       (setenv "PLAN9" (getcwd))
                       (setenv "PLAN9_TARGET" dest))))
                 (delete 'configure)    ;no configure
                 (replace 'build
                   (lambda _
                     (invoke "./INSTALL" "-b")))
                 (replace 'install
                   (lambda _
                     (invoke "./INSTALL" "-c")
                     (let ((dest (getenv "PLAN9_TARGET")))
                       (for-each (lambda (x)
                                   (let ((out (string-append dest "/" x)))
                                     (mkdir-p out)
                                     (copy-recursively x out)))
                                 ;; TODO: use external sky and dict packages
                                 '("bin" "face"
                                   "font"
                                   "include"
                                   "lib"
                                   "lp"
                                   "mail"
                                   "man"
                                   "ndb"
                                   "plumb"
                                   "tmac"
                                   "troff"
                                   "postscript"))
                       (install-file "rcmain" dest)
                       (mkdir-p (string-append #$output "/bin"))
                       (symlink (string-append dest "/bin/9")
                                (string-append #$output "/bin/9")))))
                 ;; Plan9 doesn't compress man pages
                 (delete 'compress-documentation))))
      (native-inputs (list perl which))
      (inputs (list bash-minimal                  ;for 'wrap-program'
                    fontconfig libx11 libxext libxt))
      ;; Propagate gcc-toolchain because some programs, like the 9c compiler,
      ;; are just aliased scripts to gcc equivalents.
      (propagated-inputs (list (module-ref (resolve-interface
                                          '(gnu packages commencement))
                                         'gcc-toolchain)))
      (home-page "https://9fans.github.io/plan9port/")
      (synopsis "Port of many Plan 9 libraries and programs")
      (description
       "Plan 9 from User Space (aka plan9port) is a port of many Plan 9
programs from their native Plan 9 environment to Unix-like operating
systems.")
      (license (list license:expat ;modifications
                     license:lpl1.02 ;original Plan9 code
                     license:zlib))))) ;src/cmd/bzip2
span title='2024-07-17 22:38:07 +0200'>2024-07-17gnu: python-cloud-init: Move files....* gnu/packages/python-web.scm (python-cloud-init)[arguments]: Add phase 'move-files to move data files out of site-packages directory. Change-Id: I1322b990226174283d724539a98f7470221e9058 Ricardo Wurmus 2024-07-16gnu: python-pyowm: Update to 3.3.0....* gnu/packages/python-web.scm (python-pyowm): Update to 3.3.0. [build-system]: Use pyproject build system. [arguments]: Run unit tests. [native-inputs]: Add python-pytest. [propagated-inputs]: Add python-geojson-for-pyowm. Change-Id: Ifde514f971cf3821905d9f1beb491a53e7799325 jgart 2024-07-16gnu: Add gunicorn-next....* gnu/packages/python-xyz.scm (gunicorn-next): New variable. Change-Id: I7a89e77bb0fcdfa620d07600bb06c75a720ce9b8 jgart 2024-07-16gnu: gunicorn: Add bash-minimal to satisfy linter....* gnu/packages/python-web.scm (gunicorn)[inputs]: Add bash-minimal. Change-Id: I4d63f9c0d2c1b02f6e2d701fac9698c57a95223a jgart 2024-07-16gnu: gunicorn: Use pyproject-build-system....* gnu/packages/python-web.scm (gunicorn)[build-system]: Use pyproject-build-system. Change-Id: I52c8ad0169cef33830b90b9ba243ced58d401eb4 jgart 2024-07-13Revert "gnu: python-requests-toolbelt: Update to 1.0.0."...This breaks poetry so reverting. This reverts commit ddb22a10e04c966eaa6ecbc50c3fc75dc3a143c3. jgart 2024-07-13Revert "gnu: python-requests-toolbelt: Use new style."...This breaks poetry so reverting. This reverts commit c0ecad208e305b6cd73a4ab0879e3407b879e1f9. jgart 2024-07-13gnu: python-requests-toolbelt: Use new style....* gnu/packages/python-xyz.scm (python-requests-toolbelt) [arguments]: Use new style. Change-Id: Ifbb305babeff37a34ca8789c3a08e0363e8583bf jgart 2024-07-13gnu: python-requests-toolbelt: Update to 1.0.0....* gnu/packages/python-web.scm (python-requests-toolbelt): Update to 1.0.0. [arguments]: Delete tests that are incompatible with urllib3 >= 2.0. [native-inputs]: Remove python-mock; add python-pyopenssl and python-trustme. Change-Id: I349bd9cef34cdbf7a51612e8b9d5dac59101d1bd Signed-off-by: jgart <jgart@dismail.de> Felix Gruber 2024-07-10gnu: python-requests-next: Update to 2.32.3....* gnu/packages/python-web.scm (python-requests-next): Update to 2.32.3. Change-Id: Iaf2ebe678b4ee6a4d57a3c5273db244d240e2b55 Leo Famulari 2024-07-03gnu: python-websockets: Update to 12.0...* gnu/packages/python-web.scm (python-websockets): Update to 12.0. Change-Id: I6217093bbdfb81b35eb7c8d59ada3f612b7d9511 Leo Famulari 2024-07-03gnu: Add python-urllib3 1.26.17....This is the minimum required version in recent versions of yt-dlp. * gnu/packages/python-web.scm (python-urllib3-next): New variable. Change-Id: Ib57bbe45fd1c9c9fa3872a00f161979762feacf6 Leo Famulari 2024-07-03gnu: Add python-requests 2.31.0....This is the minimum required version in recent versions of yt-dlp. * gnu/packages/python-web.scm (python-requests-next): New variable. Change-Id: I825cb928297cddc2fbbca1ce5acdbf6cff276bbc Leo Famulari 2024-06-17gnu: Add python-wtforms-sqlalchemy....* gnu/packages/python-web.scm (python-wtforms-sqlalchemy): New variable. Change-Id: Ie94c07d055ec42f08db3a18894e7f6184006764f Signed-off-by: jgart <jgart@dismail.de> Ben Sturmfels 2024-06-17gnu: python-wtforms: Update to 3.1.2....* gnu/packages/python-web.scm (python-wtforms): Update to 3.1.2. Change-Id: Id8119d0536d4d2dfa5c81de37013af68489c5fa5 Signed-off-by: jgart <jgart@dismail.de> Ben Sturmfels 2024-05-31gnu: Add python-pybadges....* gnu/packages/python-web.scm (python-pybadges): New variable. Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2024-05-11gnu: python-branca: Update to 0.7.2....* gnu/packages/python-web.scm (python-branca): Update to 0.7.2. [source]: Fetch from GitHub. [build-system]: Use pyproject-build-system. [arguments]<#:test-flags>: Ignore a file and skip one test. <#:phases>: Add phase 'pretend-version. [propagated-inputs]: Remove python-six. [native-inputs]: Add python-numpy, python-setuptools-scm. [description]: Improve it. Change-Id: I0263797b69fc437b2a268b5d03c211d76e2963c3 Vinicius Monego 2024-05-06gnu: python-http-client: Fix test suite....* gnu/packages/python-web.scm (python-http-client)[arguments]: Add a phase to adjust the tests to not be dependant on the current date. Change-Id: I94f512c9b019173f6e15e04791dbfc662fc93c89 Efraim Flashner 2024-05-05gnu: python-omnipath: Update to 1.0.8....* gnu/packages/python-web.scm (python-omnipath): Update to 1.0.8. [arguments]: Disable tests that need internet access. [native-inputs]: Add python-pytest-socket. Change-Id: Ib5856a1a25835d43918d9fe565d0262dded70eed Ricardo Wurmus 2024-05-05gnu: python-jsonpickle: Update to 3.0.4....* gnu/packages/python-web.scm (python-jsonpickle): Update to 3.0.4. [build-system]: Use pyproject-build-system. [arguments]: Use test-flags; add 'pre-check phase. [propagated-inputs]: Add python-importlib-metadata. [native-inputs]: Add python-bson, python-ecdsa, python-feedparser, python-pymongo, python-pytest, python-pytest-benchmark, python-pytest-cov, python-pytest-enabler, python-setuptools, python-setuptools-scm, python-simplejson, python-sqlalchemy, python-ujson, and tzdata-for-tests. Change-Id: I99e41ae2652ce02b090ee2b99a7b850a19b5f353 Ricardo Wurmus 2024-04-30gnu: parfive: Update to 2.1.0....* gnu/packages/python-web.scm (parfive): Update to 2.1.0. Change-Id: I6207150e012c03943d4553854123831d1bba3e55 Sharlatan Hellseher 2024-04-24gnu: python-imap-tools: Enable tests....* gnu/packages/python-web.scm (python-imap-tools): Enable tests. [source]: Swap to git checkout containing tests. [arguments] <#:test-flags>: Exclude tests requiring network connection. [native-inputs]: Add python-pytest. Change-Id: I6173f93307d371952beeef9dbbc8c237023d265b Sharlatan Hellseher 2024-04-24gnu: python-imap-tools: Update to 1.6.0....* gnu/packages/python-web.scm (python-imap-tools): Update to 1.6.0. [source]: Adjust PyPI package name for source distribution as seen in <https://pypi.org/project/imap-tools/#files>. Change-Id: I943edd19526879b7945693e29a21113ac9b6e0b1 Sharlatan Hellseher 2024-04-24gnu: Add python-robotframework-requests....* gnu/packages/python-web.scm (python-robotframework-requests): New variable. Change-Id: I01d814d1a9e20d26e9bfa4a0a77ba91577da2bd8 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Markku Korkeala