aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Robin Templeton <robin@igalia.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages phabricator)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages php)
  #:use-module (gnu packages version-control)
  #:use-module (guix build-system gnu)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages))

(define-public arcanist
  (let ((commit "ceb082ef6b2919d76a90d4a53ca84f5b1e0c2c06")
        (revision "2"))
    (package
      (name "arcanist")
      (version (git-version "0.0.0" revision commit))
      (source (origin
                (method git-fetch)
                (uri (git-reference
                      (url "https://github.com/phacility/arcanist")
                      (commit commit)))
                (file-name (git-file-name name version))
                (sha256
                 (base32
                  "16590nywh3cpm2yq4igw3nfa8g84kwza215mrnqr2k6b2cqzjak3"))))
      (build-system gnu-build-system)
      ;; TODO: Unbundle jsonlint
      (arguments
       '(#:tests? #f
         #:phases
         (modify-phases %standard-phases
           (delete 'configure)
           (delete 'build)
           (replace 'install
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
                      (bin (string-append out "/bin"))
                      (lib (string-append out "/lib/arcanist")))
                 (mkdir-p lib)
                 (copy-recursively "." lib)
                 (mkdir-p bin)
                 (symlink (string-append lib "/bin/arc")
                          (string-append bin "/arc"))
                 (wrap-program (string-append bin "/arc")
                   `("PATH" ":" prefix
                     (,@(map (lambda (i)
                               (string-append (assoc-ref %build-inputs i) "/bin"))
                             '("php" "git" "mercurial" "subversion")))))))))))
      (inputs
       (list bash-minimal php git mercurial subversion))
      (home-page "https://github.com/phacility/arcanist")
      (synopsis "Command-line interface for Phabricator")
      (description
       "Arcanist is the command-line tool for the Phabricator software
development service.  It allows you to interact with Phabricator installs to
send code for review, download patches, transfer files, view status, make API
calls, and various other things.")
      ;; Bundled libraries are expat-licensed.
      (license (list license:asl2.0 license:expat)))))
locale_path = NULL; locale_path_len = 0; - locpath_var = getenv ("LOCPATH"); - if (locpath_var != NULL && locpath_var[0] != '\0') + if (compute_locale_search_path (&locale_path, &locale_path_len) != 0) { - if (__argz_create_sep (locpath_var, ':', - &locale_path, &locale_path_len) != 0 - || __argz_add_sep (&locale_path, &locale_path_len, - _nl_default_locale_path, ':') != 0) - { - __libc_rwlock_unlock (__libc_setlocale_lock); - return NULL; - } + __libc_rwlock_unlock (__libc_setlocale_lock); + return NULL; } if (category == LC_ALL) diff --git a/string/Makefile b/string/Makefile index 8424a61..f925503 100644 --- a/string/Makefile +++ b/string/Makefile @@ -38,7 +38,7 @@ routines := strcat strchr strcmp strcoll strcpy strcspn \ swab strfry memfrob memmem rawmemchr strchrnul \ $(addprefix argz-,append count create ctsep next \ delete extract insert stringify \ - addsep replace) \ + addsep replace suffix) \ envz basename \ strcoll_l strxfrm_l string-inlines memrchr \ xpg-strerror strerror_l diff --git a/string/argz-suffix.c b/string/argz-suffix.c new file mode 100644 index 0000000..505b0f2 --- /dev/null +++ b/string/argz-suffix.c @@ -0,0 +1,58 @@ +/* Copyright (C) 2015 Free Software Foundation, Inc. + This file is part of the GNU C Library. + Contributed by Ludovic Courtès <ludo@gnu.org>. + + The GNU C Library is free software; you can redistribute it and/or + modify it under the terms of the GNU Lesser General Public + License as published by the Free Software Foundation; either + version 2.1 of the License, or (at your option) any later version. + + The GNU C Library is distributed in the hope that it will be useful, + but WITHOUT ANY WARRANTY; without even the implied warranty of + MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU + Lesser General Public License for more details. + + You should have received a copy of the GNU Lesser General Public + License along with the GNU C Library; if not, see + <http://www.gnu.org/licenses/>. */ + +#include <argz.h> +#include <errno.h> +#include <stdlib.h> +#include <string.h> + + +error_t +__argz_suffix_entries (char **argz, size_t *argz_len, const char *suffix) + +{ + size_t suffix_len = strlen (suffix); + size_t count = __argz_count (*argz, *argz_len); + size_t new_argz_len = *argz_len + count * suffix_len; + if (new_argz_len == 0) + return 0; + char *new_argz = malloc (new_argz_len); + + if (new_argz) + { + char *p = new_argz, *entry; + + for (entry = *argz; + entry != NULL; + entry = argz_next (*argz, *argz_len, entry)) + { + p = stpcpy (p, entry); + p = stpcpy (p, suffix); + p++; + } + + free (*argz); + *argz = new_argz; + *argz_len = new_argz_len; + + return 0; + } + else + return ENOMEM; +} +weak_alias (__argz_suffix_entries, argz_suffix_entries) diff --git a/string/argz.h b/string/argz.h index bb62a31..d276a35 100644 --- a/string/argz.h +++ b/string/argz.h @@ -134,6 +134,16 @@ extern error_t argz_replace (char **__restrict __argz, const char *__restrict __str, const char *__restrict __with, unsigned int *__restrict __replace_count); + +/* Suffix each entry of ARGZ & ARGZ_LEN with SUFFIX. Return 0 on success, + and ENOMEN if memory cannot be allocated. */ +extern error_t __argz_suffix_entries (char **__restrict __argz, + size_t *__restrict __argz_len, + const char *__restrict __suffix); +extern error_t argz_suffix_entries (char **__restrict __argz, + size_t *__restrict __argz_len, + const char *__restrict __suffix); + /* Returns the next entry in ARGZ & ARGZ_LEN after ENTRY, or NULL if there are no more. If entry is NULL, then the first entry is returned. This