aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages perl-maths)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system perl)
  #:use-module (gnu packages)
  #:use-module (gnu packages gcc)
  #:use-module (gnu packages gd)
  #:use-module (gnu packages gl)
  #:use-module (gnu packages maths)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages perl-check))

(define-public perl-math-cephes
  (package
    (name "perl-math-cephes")
    (version "0.5305")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "mirror://cpan/authors/id/S/SH/SHLOMIF/Math-Cephes-"
                    version ".tar.gz"))
              (sha256
               (base32
                "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))
              ;; For reproducibility
              (modules '((guix build utils)))
              (snippet
               '(substitute* "libmd/Makefile.PL"
                  (("readdir DIR") "sort readdir DIR")))))
    (build-system perl-build-system)
    (home-page "https://metacpan.org/release/Math-Cephes")
    (synopsis "Perl interface to the Cephes math library")
    (description "The Math::Cephes module provides a Perl interface to over
150 functions of the Cephes math library.")
    (license license:perl-license)))

(define-public perl-math-matrixreal
  (package
    (name "perl-math-matrixreal")
    (version "2.13")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "mirror://cpan/authors/id/L/LE/LETO/Math-MatrixReal-"
                    version ".tar.gz"))
              (sha256
               (base32
                "1cml5wqd99hm398gl8f147ccsck9v179l7a6vqjj4kfkdnja37sg"))))
    (build-system perl-build-system)
    (native-inputs
     (list perl-module-build perl-test-most))
    (home-page "https://metacpan.org/release/Math-MatrixReal")
    (synopsis "Manipulate NxN matrices of real numbers")
    (description "This package provides the @code{Math::MatrixReal} module.
It implements the data type \"matrix of real numbers\" (and consequently also
\"vector of real numbers\").")
    (license license:perl-license)))

;; This is NOT compatible with perl-pdl-2.095
(define-public perl-pdl-2.019
  (package
    (name "perl-pdl")
    (version "2.019")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.cpan.org/modules/by-module/PDL/PDL-" version
                           ".tar.gz"))
       (sha256
        (base32 "1zkp5pm351qjr6sb3xivpxy5vjfl72ns0hb4dx5vpm8xvgp7p92i"))
       (patches
        (search-patches "pdl-2.019-glut-bitmap-fonts.patch"))))
    (build-system perl-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-includes
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "perldl.conf"
              (("WITH_BADVAL => 0") "WITH_BADVAL => 1")
              (("WITH_GD => undef") "WITH_GD => true")
              (("GD_INC => undef")
               (string-append "GD_INC => '" (assoc-ref inputs "gd") "/include'"))
              (("GD_LIB => undef")
               (string-append "GD_LIB => '" (assoc-ref inputs "gd") "/lib'"))
              (("WITH_GSL => undef") "WITH_GSL => true"))))
         (add-before 'check 'prepare-check
           (lambda _
             ;; Set this for official CPAN releases of PDL.
             (setenv "SKIP_KNOWN_PROBLEMS" "1")
             (setenv "HOME" "/tmp"))))))
    (inputs (list gd gsl mesa glu))
    (native-inputs (list perl-devel-checklib
                         perl-extutils-depends
                         perl-extutils-f77
                         gfortran
                         perl-file-which
                         perl-pod-parser
                         perl-test-deep
                         perl-test-exception
                         perl-test-warn))
    (propagated-inputs (list perl-file-map
                             perl-file-which
                             perl-inline
                             perl-inline-c
                             perl-list-moreutils
                             perl-opengl
                             perl-pgplot
                             perl-pod-parser
                             perl-sys-sigaction
                             perl-termreadkey))
    (home-page "https://metacpan.org/release/PDL")
    (synopsis "Perl Data Language")
    (description "This package provides a library and simple REPL for the
Perl Data Language.")
    (license license:perl-license)))
to 0.192....* gnu/packages/maths.scm (metamath): Update to 0.192. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> B. Wilson 2020-08-27gnu: Add libflame....* gnu/packages/maths.scm (libflame): New variable. Efraim Flashner 2020-08-27gnu: lrslib: Update to 7.1....* gnu/packages/maths.scm (lrslib): Update to 7.1. Andreas Enge 2020-08-26gnu: octave: Remove unneeded 'source' field....* gnu/packages/maths.scm (octave)[source]: Remove. It had been unnecessary since b66741edc954f0a17f1ef567e8d612cac87c7b6a. Ludovic Courtès 2020-08-26gnu: netcdf-parallel-openmpi: Allow MPI tests to pass....* gnu/packages/maths.scm (netcdf-parallel-openmpi)[arguments]: Add 'mip-setup' phase. Ludovic Courtès 2020-08-26gnu: hdf5-parallel-openmpi: Update to 1.10.6....* gnu/packages/maths.scm (hdf5-parallel-openmpi): Inherit from HDF5-1.10. Ludovic Courtès 2020-08-26gnu: hdf5: Use 'package/inherit' for variants....* gnu/packages/maths.scm (hdf5-1.10, hdf5-parallel-openmpi): Use 'package/inherit'. Ludovic Courtès 2020-08-26gnu: hdf5: Distinguish the default hdf5 version....* gnu/packages/maths.scm (hdf5): Rename to... (hdf-1.8): ... this. (hdf5-1.10): Adjust accordingly. (hdf5): New variable. Ludovic Courtès 2020-08-16gnu: wxmaxima: Update to 20.06.6....* gnu/packages/maths.scm (wxmaxima): Update to 20.06.6. [arguments]: Add 'patch-doc-path phase. Kei Kebreau 2020-08-16gnu: Add veusz....* gnu/packages/maths.scm (veusz): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Vinicius Monego 2020-08-10gnu: Add clapack....* gnu/packages/maths.scm (clapack): New variable. Ricardo Wurmus 2020-08-04gnu: mcrl2: Update to 202006.0....* gnu/packages/maths.scm (mcrl2): Update to 202006.0. Jan (janneke) Nieuwenhuizen 2020-07-23gnu: Add sleef....* gnu/packages/maths.scm (sleef): New variable. Signed-off-by: Brett Gilio <brettg@gnu.org> Vinicius Monego 2020-07-17gnu: java-junit: Install from pom file....* gnu/packages/java.scm (java-junit)[arguments]: Replace install phase. (java-hamcrest-core)[arguments]: Replace install phase. (java-hamcrest-library)[arguments]: Replace install phase. (java-cisd-jhdf5, java-commons-math3, java-commons-collections4) (java-commons-io, java-commons-exec-1.1, java-commons-exec) (java-commons-lang3, java-commons-codec, java-native-access) (java-native-access-platform, java-hamcrest-all): Change junit and hamcrest jar location accordingly. (java-hamcrest-all): Use old install phase of java-hamcrest-core. * gnu/packages/maths.scm (java-hdf): Change junit and hamcrest jar location accordingly. Julien Lepiller 2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Until now, 'lookup-origin' and thus 'lookup-origin-revision' in (guix swh) would sometimes return #f for these because the ".git" URLs are redirects to the non-".git" URLs. Consequently, 'guix lint -c archival' would keep saying "scheduled Software Heritage archival"; likewise, the fallback download code would fail. * gnu/packages/ada.scm, gnu/packages/admin.scm, gnu/packages/aidc.scm, gnu/packages/algebra.scm, gnu/packages/android.scm, gnu/packages/animation.scm, gnu/packages/arcan.scm, gnu/packages/assembly.scm, gnu/packages/audio.scm, gnu/packages/authentication.scm, gnu/packages/avr.scm, gnu/packages/axoloti.scm, gnu/packages/backup.scm, gnu/packages/bash.scm, gnu/packages/benchmark.scm, gnu/packages/bioconductor.scm, gnu/packages/bioinformatics.scm, gnu/packages/bittorrent.scm, gnu/packages/boost.scm, gnu/packages/build-tools.scm, gnu/packages/c.scm, gnu/packages/calendar.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/chemistry.scm, gnu/packages/chez.scm, gnu/packages/clojure.scm, gnu/packages/code.scm, gnu/packages/compression.scm, gnu/packages/compton.scm, gnu/packages/coq.scm, gnu/packages/cpp.scm, gnu/packages/cran.scm, gnu/packages/crypto.scm, gnu/packages/curl.scm, gnu/packages/databases.scm, gnu/packages/datastructures.scm, gnu/packages/debug.scm, gnu/packages/disk.scm, gnu/packages/distributed.scm, gnu/packages/django.scm, gnu/packages/dlang.scm, gnu/packages/dns.scm, gnu/packages/docker.scm, gnu/packages/education.scm, gnu/packages/efi.scm, gnu/packages/elixir.scm, gnu/packages/emacs-xyz.scm, gnu/packages/embedded.scm, gnu/packages/emulators.scm, gnu/packages/engineering.scm, gnu/packages/erlang.scm, gnu/packages/fabric-management.scm, gnu/packages/file-systems.scm, gnu/packages/finance.scm, gnu/packages/firmware.scm, gnu/packages/flashing-tools.scm, gnu/packages/fonts.scm, gnu/packages/fontutils.scm, gnu/packages/fpga.scm, gnu/packages/game-development.scm, gnu/packages/games.scm, gnu/packages/genealogy.scm, gnu/packages/genimage.scm, gnu/packages/geo.scm, gnu/packages/gimp.scm, gnu/packages/gl.scm, gnu/packages/gnome-xyz.scm, gnu/packages/gnome.scm, gnu/packages/gnuzilla.scm, gnu/packages/golang.scm, gnu/packages/gpodder.scm, gnu/packages/graph.scm, gnu/packages/graphics.scm, gnu/packages/graphviz.scm, gnu/packages/groff.scm, gnu/packages/groovy.scm, gnu/packages/gtk.scm, gnu/packages/guile-xyz.scm, gnu/packages/guile.scm, gnu/packages/hardware.scm, gnu/packages/haskell-apps.scm, gnu/packages/haskell-xyz.scm, gnu/packages/hexedit.scm, gnu/packages/i2p.scm, gnu/packages/ibus.scm, gnu/packages/image-processing.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/ipfs.scm, gnu/packages/java-graphics.scm, gnu/packages/java-maths.scm, gnu/packages/java.scm, gnu/packages/javascript.scm, gnu/packages/jrnl.scm, gnu/packages/julia.scm, gnu/packages/jupyter.scm, gnu/packages/kodi.scm, gnu/packages/language.scm, gnu/packages/lego.scm, gnu/packages/less.scm, gnu/packages/libusb.scm, gnu/packages/linux.scm, gnu/packages/lirc.scm, gnu/packages/lisp-xyz.scm, gnu/packages/llvm.scm, gnu/packages/logging.scm, gnu/packages/lolcode.scm, gnu/packages/lua.scm, gnu/packages/lxde.scm, gnu/packages/lxqt.scm, gnu/packages/machine-learning.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/maths.scm, gnu/packages/maven.scm, gnu/packages/mes.scm, gnu/packages/messaging.scm, gnu/packages/monitoring.scm, gnu/packages/mpd.scm, gnu/packages/music.scm, gnu/packages/networking.scm, gnu/packages/node-xyz.scm, gnu/packages/ocaml.scm, gnu/packages/ocr.scm, gnu/packages/onc-rpc.scm, gnu/packages/opencl.scm, gnu/packages/opencog.scm, gnu/packages/pantheon.scm, gnu/packages/password-utils.scm, gnu/packages/patchutils.scm, gnu/packages/pdf.scm, gnu/packages/perl6.scm, gnu/packages/phabricator.scm, gnu/packages/popt.scm, gnu/packages/printers.scm, gnu/packages/prolog.scm, gnu/packages/protobuf.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/qt.scm, gnu/packages/radio.scm, gnu/packages/rails.scm, gnu/packages/rdf.scm, gnu/packages/rednotebook.scm, gnu/packages/rpc.scm, gnu/packages/rsync.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/security-token.scm, gnu/packages/selinux.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/shellutils.scm, gnu/packages/simh.scm, gnu/packages/sml.scm, gnu/packages/ssh.scm, gnu/packages/statistics.scm, gnu/packages/stenography.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/synergy.scm, gnu/packages/telephony.scm, gnu/packages/terminals.scm, gnu/packages/tex.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-07-11gnu: ruby-asciimath: Update to 2.0.1....* gnu/packages/maths.scm (ruby-asciimath): Update to 2.0.1. [arguments]: Remove. [native-inputs]: Remove bundler, add ruby-nokogiri. Maxim Cournoyer 2020-07-09gnu: qalculate-gtk: Fix typo in description....* gnu/packages/maths.scm (qalculate-gtk)[description]: Fix typo. Tobias Geerinckx-Rice