aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pem)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages perl))

(define-public pem
  (package
    (name "pem")
    (version "0.7.9")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/pem/pem-"
                          version ".tar.gz"))
      (sha256
       (base32
        "03iqcki1lakkck1akdyvljjapgqda3l0rh38id7jhrac9kcxqgg2"))))
    (build-system gnu-build-system)
    (inputs (list perl))
    (home-page "https://www.gnu.org/software/pem/")
    (synopsis "Personal expenses manager")
    (description
     "GNU Pem is a simple tool for tracking personal income and
expenses.  It operates from the command line and it stores its data
in a basic text format in your home directory.  It can easily print
reports of your spending on different expenses via a basic search
feature.")
    (license gpl3+)))
href='/guix/commit/gnu/packages/cybersecurity.scm?id=39033592a819893a067fc699c3c35f3e544c5c99'>gnu: ropgadget: Use HTTPS home page....* gnu/packages/cybersecurity.scm (ropgadget)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2022-01-14gnu: Add blacksmith....* gnu/packages/cybersecurity.scm (blacksmith): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Raghav Gururajan via Guix-patches via 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-10-06gnu: ropgadget: Update to 6.6....* gnu/packages/cybersecurity.scm (ropgadget): Update to 6.6. Tobias Geerinckx-Rice 2021-06-06gnu: Add pwntools....* gnu/packages/cybersecurity.scm (pwntools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> c4droid 2021-02-15gnu: ropgadget: Update to 6.5....* gnu/packages/cybersecurity.scm (ropgadget): Update to 6.5. Tobias Geerinckx-Rice 2020-12-06gnu: ropgadget: Update to 6.4....* gnu/packages/cybersecurity.scm (ropgadget): Update to 6.4. Tobias Geerinckx-Rice 2020-06-02gnu: ropgadget: Update to 6.3....* gnu/packages/cybersecurity.scm (ropgadget): Update to 6.3. Tobias Geerinckx-Rice 2020-03-26gnu: Add ROPgadget....* gnu/packages/cybersecurity.scm: New file. (ropgadget): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Register the file. Jakub Kądziołka