aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages pem)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages perl))

(define-public pem
  (package
    (name "pem")
    (version "0.7.9")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/pem/pem-"
                          version ".tar.gz"))
      (sha256
       (base32
        "03iqcki1lakkck1akdyvljjapgqda3l0rh38id7jhrac9kcxqgg2"))))
    (build-system gnu-build-system)
    (inputs (list perl))
    (home-page "https://www.gnu.org/software/pem/")
    (synopsis "Personal expenses manager")
    (description
     "GNU Pem is a simple tool for tracking personal income and
expenses.  It operates from the command line and it stores its data
in a basic text format in your home directory.  It can easily print
reports of your spending on different expenses via a basic search
feature.")
    (license gpl3+)))
tagingMarius Bakke 2020-11-18gnu: gpgme: Update to 1.15.0....Miguel Ángel Arruga Vivas 2020-11-17gnu: gnupg: Update to 2.2.24....Miguel Ángel Arruga Vivas 2020-11-17gnu: libksba: Update to 1.4.0....Miguel Ángel Arruga Vivas 2020-11-17gnu: libassuan: Update to 2.5.4....Miguel Ángel Arruga Vivas 2020-11-08gnu: libgpg-error: Fix cross-compiling to mips64el-linux....Efraim Flashner 2020-09-08gnu: pinentry: Enable curses fallback....Efraim Flashner 2020-09-03gnu: gnupg: Update to 2.2.23 [security fixes]....Tobias Geerinckx-Rice 2020-08-28gnu: gnupg: Update to 2.2.22....Efraim Flashner 2020-08-28gnu: gpgme: Update to 1.14.0....Mark H Weaver 2020-05-23gnu: guile-gcrypt: Update to 0.3.0....Ludovic Courtès 2020-05-13mailmap: Update entries for Nikita....nikita 2020-04-11gnu: libgcrypt: Fix cross-compilation....Jan (janneke) Nieuwenhuizen 2020-03-30Merge branch 'master' into core-updates...Marius Bakke 2020-03-29gnu: GnuPG: Really use ~/.guix-profile/bin/pinentry by default....Leo Famulari 2020-03-28Revert "gnu: gnupg: Use ~/.guix-profile/bin/pinentry by default."...Leo Famulari 2020-03-27Merge branch 'master' into core-updates...Marius Bakke 2020-03-26gnu: gnupg: Use ~/.guix-profile/bin/pinentry by default....Ludovic Courtès 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-21gnu: gpgme: Fix build....Tobias Geerinckx-Rice 2020-03-21gnu: gnupg: Update to 2.2.20 [security fix]....Tobias Geerinckx-Rice 2020-03-19gnu: gpa: Add phase wrap-program....Brice Waegeneire 2020-03-17gnu: guile-gcrypt: Use the correct Guile version....Marius Bakke 2020-03-16gnu: Default to Guile 3.0....Ludovic Courtès 2020-03-04Merge branch 'master' into core-updatesMarius Bakke 2020-02-23gnu: jetring: Update to 0.29....Efraim Flashner 2020-02-20gnu: guile-gcrypt: Use git-file-name...Jakub Kądziołka 2020-02-20gnu: guile2.0-gcrypt: Don't use guile-2.2....Efraim Flashner 2020-02-20gnu: guile3.0-gcrypt: Fix compilation....Efraim Flashner 2020-02-15gnu: libgpg-error: Update to 1.37....Marius Bakke