aboutsummaryrefslogtreecommitdiff
This patch is required for xmonad to make use of shared libraries.
Without it, xmonad will not work since we do not (by default) use
statically linked Haskell libraries.

index 46a0939..5ad4f8f 100644
--- a/src/XMonad/Core.hs
+++ b/src/XMonad/Core.hs
@@ -664,6 +664,8 @@ compile dirs method =
   where
     ghcArgs = [ "--make"
               , "xmonad.hs"
+              , "-dynamic"
+              , "-fPIC"
               , "-i" -- only look in @lib@
               , "-ilib"
               , "-fforce-recomp"
>Commit message (Expand)Author 2022-05-24gnu: gcc@12: Add missing file....Fixes <https://issues.guix.gnu.org/55616>. Reported by Tim Rakowski <tim.rakowski@gmail.com>. This is a followup to 37e29ccd332f371aacedc71388e805fbc9e947fa. * gnu/packages/patches/gcc-12-strmov-store-file-names.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Ludovic Courtès