aboutsummaryrefslogtreecommitdiff
From e80e73ced69b15662103d0fd6837db4ce6c6eb5b Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@redhat.com>
Date: Mon, 13 Jul 2020 09:20:15 +1000
Subject: [PATCH] nouveau: fixup driver for new X server ABI

---
 src/compat-api.h  | 4 ++++
 src/nouveau_exa.c | 2 +-
 src/nv_driver.c   | 6 +++---
 3 files changed, 8 insertions(+), 4 deletions(-)

diff --git a/src/compat-api.h b/src/compat-api.h
index fde2f4b..8a1fcf9 100644
--- a/src/compat-api.h
+++ b/src/compat-api.h
@@ -102,4 +102,8 @@
 
 #endif
 
+#if ABI_VIDEODRV_VERSION < SET_ABI_VERSION(25, 2)
+#define secondary_dst slave_dst
+#endif
+
 #endif
diff --git a/src/nouveau_exa.c b/src/nouveau_exa.c
index 55df6f8..db3b112 100644
--- a/src/nouveau_exa.c
+++ b/src/nouveau_exa.c
@@ -157,7 +157,7 @@ nouveau_exa_destroy_pixmap(ScreenPtr pScreen, void *priv)
 
 #ifdef NOUVEAU_PIXMAP_SHARING
 static Bool
-nouveau_exa_share_pixmap_backing(PixmapPtr ppix, ScreenPtr slave, void **handle_p)
+nouveau_exa_share_pixmap_backing(PixmapPtr ppix, ScreenPtr secondary, void **handle_p)
 {
 	struct nouveau_bo *bo = nouveau_pixmap_bo(ppix);
 	struct nouveau_pixmap *nvpix = nouveau_pixmap(ppix);
diff --git a/src/nv_driver.c b/src/nv_driver.c
index e72a6b6..f9ab4af 100644
--- a/src/nv_driver.c
+++ b/src/nv_driver.c
@@ -559,16 +559,16 @@ redisplay_dirty(ScreenPtr screen, PixmapDirtyUpdatePtr dirty)
 {
 	RegionRec pixregion;
 
-	PixmapRegionInit(&pixregion, dirty->slave_dst);
+	PixmapRegionInit(&pixregion, dirty->secondary_dst);
 
-	DamageRegionAppend(&dirty->slave_dst->drawable, &pixregion);
+	DamageRegionAppend(&dirty->secondary_dst->drawable, &pixregion);
 #ifdef HAS_DIRTYTRACKING_ROTATION
 	PixmapSyncDirtyHelper(dirty);
 #else
 	PixmapSyncDirtyHelper(dirty, &pixregion);
 #endif
 
-	DamageRegionProcessPending(&dirty->slave_dst->drawable);
+	DamageRegionProcessPending(&dirty->secondary_dst->drawable);
 	RegionUninit(&pixregion);
 }
 
-- 
2.33.1

id=d0ae39390fba3822aed4a498aafcdfa61289448b'>enable opening settings page with certain item immediately in edit modeWojtek Kosior 2021-07-02move parsing of url with targets to misc.jsWojtek Kosior 2021-07-02ignore some special files (emacs automatic backups) when buildingWojtek Kosior 2021-07-01Employ issue trackerWojtek Kosior 2021-06-30fix whitelisting under FirefoxWojtek Kosior 2021-06-30remove trailing whitespaceWojtek Kosior 2021-06-30refactor 3 miscellaneous fnctionalities to a their single own fileWojtek Kosior 2021-06-30emply an sh-based build system; make some changes to blockingWojtek Kosior 2021-06-28Index two new files intended for the previous commit.jahoti 2021-06-28License script-blocking techniques from NoScript in machine-readable format....In-page blocking now works on Firefox, and JavaScript/data- URLs are properly blocked to ensure no JavaScript leaks in through backdoors. Blocking of HTML/XML data: urls should be refined (eventually) to align with current practice for pages in general. Also, script-blocking is now filtered by nonce, making it possible (albeit perhaps not desirable) to inject scripts before the DOM is complete. jahoti 2021-06-26remove mnetion of LGPL from javascript exception to the GPLWojtek Kosior 2021-06-25make it clear "A" license contains text from BSD license with its own copyrightWojtek Kosior 2021-06-25gather all copyright info in 'copyright' fileWojtek Kosior 2021-06-23Fix storage initialization on Icecat 60...This patch fixes storage initialization on Gecko browsers by switching from using a background page to using a list of scripts. It remains a mystery why that should have any effect; the only hint is that browser.runtime.onInstalled does not fire when called from a script loaded in a background page. Signed-off-by: jahoti <jahoti@tilde.team> jahoti 2021-06-21change horizontal line style to light greenNicholas Johnson 2021-06-20add button stylingNicholas Johnson 2021-06-19add import/export functionalityWojtek Kosior 2021-06-18remove unused source filesWojtek Kosior 2021-06-18update Asshole license textWojtek Kosior 2021-06-18when possible inject CSP as http(s) header using webRequest instead of adding...Wojtek Kosior 2021-06-14change licensesWojtek Kosior 2021-05-14react to few bugsWojtek Kosior 2021-05-14support wildcard urls in settingsWojtek Kosior 2021-05-13make extension work under IceCat 60Wojtek Kosior 2021-05-13utilize CSP for blockingWojtek Kosior 2021-05-13only allow a single injection payload for page, rely on script bags for compl...Wojtek Kosior 2021-05-12rename "bundles" to "bags"Wojtek Kosior 2021-05-12use unique hashes when smuggling whitelist settingWojtek Kosior 2021-05-12fix bug when saving page/bundleWojtek Kosior 2021-05-12stop using js modulesWojtek Kosior 2021-05-12remove remnants of LibreJSWojtek Kosior 2021-05-10initial commitWojtek Kosior