aboutsummaryrefslogtreecommitdiff
Fix build flags for ARMv7.

Taken from Debian:
https://salsa.debian.org/multimedia-team/x265/-/blob/master/debian/patches/0001-Fix-arm-flags.patch

From: Sebastian Ramacher <sramacher@debian.org>
Date: Wed, 26 Apr 2017 22:05:06 +0200
Subject: Fix arm* flags

---
 source/CMakeLists.txt | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
--- a/source/CMakeLists.txt
+++ b/source/CMakeLists.txt
@@ -77,7 +77,7 @@ elseif(ARMMATCH GREATER "-1")
         add_definitions(-DX265_ARCH_ARM=1 -DX265_ARCH_ARM64=1 -DHAVE_ARMV6=0)
     else()
         message(STATUS "Detected ARM target processor")
-        add_definitions(-DX265_ARCH_ARM=1 -DX265_ARCH_ARM64=0 -DHAVE_ARMV6=1)
+        add_definitions(-DX265_ARCH_ARM=1)
     endif()
 else()
     message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
@@ -252,10 +252,7 @@ if(GCC)
         else()
             find_package(Neon)
             if(CPU_HAS_NEON)
-                set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=neon -marm -fPIC)
                 add_definitions(-DHAVE_NEON)
-            else()
-                set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=vfp -marm)
             endif()
         endif()
     endif()
* gnu/packages/usb.scm (python-pyusb) <arguments>: Use G-Expressions style instead of quoting. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Jean-Pierre De Jesus DIAZ 2023-09-05gnu: libusb-compat: Specify the absolute file name for libusb....Refine the fix for loading libusb correctly. * gnu/packages/libusb.scm (libusb) [arguments] <configure-flags>: New LIBUSB_1_0_SONAME flag. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> nathan 2023-09-02gnu: libusb-compat: Add libusb to RUNPATH....This avoids the error: teensy_loader_cli: error while loading libusb-1.0.so.0 from libusb-0.1.so.4: libusb-1.0.so.0: cannot open shared object file: No such file or directory e.g. when running teensy_loader_cli, which uses libusb-compat. * gnu/packages/libusb.scm (libusb-compat) [arguments] <configure-flags>: New LDFLAGS variable. Maxim Cournoyer 2023-08-29gnu: Add python-hid....* gnu/packages/libusb.scm (python-hid): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org> Jean-Pierre De Jesus DIAZ 2023-08-26gnu: libmtp: Update to 1.1.21....* gnu/packages/libusb.scm (libmtp): Update to 1.1.21. Signed-off-by: Christopher Baines <mail@cbaines.net> fanquake 2023-07-23gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users. Tobias Geerinckx-Rice 2023-07-20gnu: python-pyusb: Update to 1.2.1....* gnu/packages/libusb.scm (python-pyusb): Update to 1.2.1. [native-inputs]: Add python-setuptools-scm. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Simon South