aboutsummaryrefslogtreecommitdiff
Fix CVE-2008-2149: buffer overflows by limiting the length of the string in sprintf
format string
Closes: #481186 (CVE-2008-2149)
Please note: The WordNet code contains several other occurences of potentially
exploitable functions like strcpy()/strcat()/...  and so even if there are no
known exploits the code needs a full security audit.

--- a/src/wn.c
+++ b/src/wn.c
@@ -206,7 +206,8 @@ static int searchwn(int ac, char *av[])
 		    outsenses += do_search(av[1], optptr->pos, optptr->search,
 					    whichsense, optptr->label);
 	    } else {
-		sprintf(tmpbuf, "wn: invalid search option: %s\n", av[j]);
+		/* Fix CVE-2008-2149: buffer overflows Andreas Tille <tille@debian.org> */
+		sprintf(tmpbuf, "wn: invalid search option: %.200s\n", av[j]);
 		display_message(tmpbuf);
 		errcount++;
 	    }
lect>space:mode:
authorAlex Griffin <a@ajgrf.com>2019-11-21 10:38:42 -0600
committerAlex Griffin <a@ajgrf.com>2019-11-21 10:38:42 -0600
commit15c06ad066ac98bf8ffe1835b59fd5e5db069eb3 (patch)
treec03243dc5e762d8cd0f055d5cfce24ad9a1802e2 /tests/import-utils.scm
parentd20956a401141be890a3498b6fa2b78ff2d96cc0 (diff)
downloadguix-15c06ad066ac98bf8ffe1835b59fd5e5db069eb3.tar.gz
guix-15c06ad066ac98bf8ffe1835b59fd5e5db069eb3.zip
gnu: kmonad: Update to 0.3.0.
* gnu/packages/haskell-apps.scm (kmonad): Update to 0.3.0.
Diffstat (limited to 'tests/import-utils.scm')
0 files changed, 0 insertions, 0 deletions