aboutsummaryrefslogtreecommitdiff
From 2d129502354da4fe39dac13463ea742f8026ab91 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 3 Jan 2023 22:15:09 +0100
Subject: [PATCH] Link libs and fix jnetlib.

---
 WDL/eel2/Makefile    | 2 +-
 WDL/jnetlib/Makefile | 2 +-
 WDL/swell/Makefile   | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/WDL/eel2/Makefile b/WDL/eel2/Makefile
index ac2e41f1..0ffca97a 100644
--- a/WDL/eel2/Makefile
+++ b/WDL/eel2/Makefile
@@ -153,7 +153,7 @@ gen-lex:  # the output of this, lex.nseel.c, is unused because we have a handwri
 	$(CXX) $(CXXFLAGS) -c -o $@ $^
 
 loose_eel: loose_eel.o $(OBJS) $(OBJS2)
-	g++ -o $@ $^ $(CXXFLAGS) $(LFLAGS)
+	g++ -o $@ $^ $(CXXFLAGS) $(LFLAGS) -lGL
 
 clean:
 	-rm -f -- loose_eel loose_eel.o $(OBJS)
diff --git a/WDL/jnetlib/Makefile b/WDL/jnetlib/Makefile
index 10d9fe8a..85570c5a 100644
--- a/WDL/jnetlib/Makefile
+++ b/WDL/jnetlib/Makefile
@@ -7,7 +7,7 @@ CC = gcc
 CPP = g++
 CXX = g++
 
-OBJS = asyncdns.o connection.o httpget.o httpserv.o listen.o util.o sercon.o
+OBJS = asyncdns.o connection.o httpget.o httpserv.o listen.o util.o
 
 jnl.a: ${OBJS}
 	-rm -f jnl.a
diff --git a/WDL/swell/Makefile b/WDL/swell/Makefile
index 9e7e2d87..8e98a543 100644
--- a/WDL/swell/Makefile
+++ b/WDL/swell/Makefile
@@ -167,7 +167,7 @@ libSwell$(DLL_EXT): $(OBJS)
 	$(CXX) -shared -o $@ $(CFLAGS) $(LFLAGS) $^ $(LINKEXTRA)
 
 test: $(OBJS) test.o
-	$(CXX) -o test $(CFLAGS) $(LFLAGS) $^ $(LINKEXTRA)
+	$(CXX) -o test $(CFLAGS) $(LFLAGS) $^ $(LINKEXTRA) -lpthread -ldl $(shell $(PKG_CONFIG) --libs gtk+-3.0 freetype2) -lfontconfig -lGL -lXi -lX11
 
 libSwell.colortheme: swell-gdi-generic.cpp $(SWELL_HEADERS)
 	$(CXX) $(CFLAGS) -o make-theme -DSWELL__MAKE_THEME swell-gdi-generic.cpp -lpthread
-- 
2.38.1

e unused modules. Do not create the now extraneous collection directory. (efi-bootloader-chain): Add PACKAGES and DISK-IMAGE-INSTALLER arguments. Remove handling of the collection directory, now only calling the given installer procedure. * gnu/bootloader/grub.scm (make-grub-efi-netboot-installer): New helper. (make-grub-configuration): New helper based on (grub-configuration-file). Add a GRUB argument, fix indentation, remove previous code retrieving GRUB from CONFIG. (grub-configuration-file): Make use of make-grub-configuration. (grub-efi-configuration-file): New procedure. (grub-cfg): New variable to replace "/boot/grub/grub.cfg". (install-grub-efi-netboot): Remove, splitting logic to... (make-grub-efi-netboot-installer): ... this new helper procedure, as well as to make-grub-efi-netboot, added below. (grub-bootloader): Adjust to use the GRUB-CFG. (grub-efi-bootloader): Likewise. Removed inheritance and declare all fields explicitly. (make-grub-efi-netboot-bootloader): New procedure. (grub-efi-netboot-bootloader): Use it. (grub-efi-netboot-removable-bootloader): New variable. * gnu/packages/bootloaders.scm (make-grub-efi-netboot): New procedure. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Stefan 2022-09-08gnu: bootloader: Report error in menu-entry....* gnu/bootloader.scm (report-menu-entry-error): New procedure. (menu-entry->sexp): Add a call to `report-menu-entry-error'. Co-Authored-By: Julien Lepiller <julien@lepiller.eu> Signed-off-by: Julien Lepiller <julien@lepiller.eu> tiantian 2022-09-08gnu: bootloader: Extend `<menu-entry>' for chain-loader....* gnu/bootloader.scm (<menu-entry>)[chain-loader]: New field. (menu-entry->sexp, sexp->menu-entry): Support chain-loader. * doc/guix.texi (Bootloader Configuration): Document it. Co-Authored-By: Julien Lepiller <julien@lepiller.eu> Signed-off-by: Julien Lepiller <julien@lepiller.eu> tiantian 2022-08-30bootloader: Wrap lines....* gnu/bootloader (<bootloader-configuration>): Wrap lines, no functional change. Mathieu Othacehe 2022-08-30bootloader: Add device-tree-support? option....In some specific cases where the device tree file is already loaded in RAM, it can be preferable that the bootloader does not try to use a device tree from the Linux kernel tree. * gnu/bootloader.scm (<bootloader-configuration>)[device-tree-support?]: New field. * gnu/bootloader/extlinux.scm (extlinux-configuration-file): Add FDTDIR line based on <device-tree-support?> field of <bootloader-configuration>. * doc/guix.texi (Bootloader Configuration)[device-tree-support?]: Add documentation for the new field. Reza Alizadeh Majd 2022-08-28bootloader: Convert device in menu-entry to proper sexp....Previously, menu-entry->sexp didn't try to convert `device` to a proper sexp, which was inserted directly into the boot parameters G-exp, leading to a G-exp input error. Now convert both uuid and file-system-label possibilities to sexps, and add parsing code to sexp->menu-entry. This fixes #57307. * gnu/bootloader.scm (menu-entry->sexp, sexp->menu-entry): Take non-string devices into account. Signed-off-by: Marius Bakke <marius@gnu.org> Josselin Poiret 2022-08-21bootloader: Remove expired export....This follows up on commit 8a0e1bb12b3c22a8c9a2be17492058ca63ec7c5d. * gnu/bootloader.scm: Don't export bootloader-configuration-additional-configuration, which no longer exists. Reported by muradm in #guix. Tobias Geerinckx-Rice 2021-11-17gnu: system: Improve location of some configuration warnings....* gnu/bootloader.scm (%warn-target-field-deprecation): Remove it. * gnu/bootloader.scm (warn-target-field-deprecation): Use define-with-syntax-properties. * gnu/system.scm (ensure-setuid-program-list): Ditto. Also rename the 'location' variable to 'properties'. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Josselin Poiret 2021-08-30bootloader: Report location of the deprecated 'target' field....This is a followup to 2ca982ff41270288913ad6b7d5d9e1cad87b06d9. * gnu/bootloader.scm (warn-target-field-deprecation): New macro. (<bootloader-configuration>)[target]: Add 'sanitize' property. (%warn-target-field-deprecation): New procedure. (bootloader-configuration-target): Define using 'define-deprecated'. (bootloader-configuration-targets): Use '%bootloader-configuration-target' rather than the deprecated one. Ludovic Courtès 2021-08-29gnu: bootloader: Support multiple targets....Fixes <https://issues.guix.gnu.org/40997>. * gnu/bootloader.scm (<bootloader-configuration>): New 'targets' field. (%bootloader-configuration-target): New procedure. (bootloader-configuration-target): Add deprecation warning. (bootloader-configuration-targets): New procedure. * guix/scripts/system.scm (install): Access targets via bootloader-configuration-targets. (perform-action)[bootloader-target]: Remove unused argument and update doc. Access targets via bootloader-configuration-targets and fix indentation. (process-action): Access targets via bootloader-configuration-targets. Do not provide the unused BOOTLOADER-TARGET argument when applying `perform-action'. * guix/scripts/system/reconfigure.scm (install-bootloader-program): Rename DEVICE argument to DEVICES. Adjust doc and comment. Apply `installer' and `disk-installer' for every DEVICES. (install-bootloader): Access targets via bootloader-configuration-targets and rename variable from DEVICE to DEVICES. * gnu/tests/install.scm: Adjust accordingly. * tests/guix-system.sh: Likewise. * gnu/tests/reconfigure.scm (run-install-bootloader-test): Adjust the DEVICES argument so that it is a list. * doc/guix.texi: Update doc. Maxim Cournoyer