aboutsummaryrefslogtreecommitdiff
Description: GCC 11 now enforces that comparison objects be invocable as const.
--- a/Rendering/Label/vtkLabelHierarchy.cxx
+++ b/Rendering/Label/vtkLabelHierarchy.cxx
@@ -525,1 +525,1 @@
-                    const vtkHierarchyNode & b)
+                    const vtkHierarchyNode & b) const
--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
+++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
@@ -66,1 +66,1 @@
-    bool operator () ( const vtkIdType& a, const vtkIdType& b )
+    bool operator () ( const vtkIdType& a, const vtkIdType& b ) const
r>2022-12-17Update NEWS.Marius Bakke 2022-12-02Update NEWS.Ludovic Courtès 2022-11-23NEWS: Update it....* NEWS: Shepherd is already at 0.9.3 now. Jonathan Brielmaier 2022-11-16Update NEWS.Maxim Cournoyer 2022-10-13NEWS: Update it....* NEWS: Add an entry about 'guix shell' --emulate-fhs option. Mathieu Othacehe 2022-10-07Update NEWS....* NEWS: Add new entry for installation script improvements. Maxim Cournoyer 2022-09-28Update NEWS....* NEWS: Add new services for the 1.4.0. Mathieu Othacehe 2022-09-26NEWS: Update it....* NEWS: Add an entry about WSL images. Mathieu Othacehe 2022-09-24Update NEWS.Ludovic Courtès 2022-09-23Update NEWS.Maxim Cournoyer 2022-09-19Update NEWS....* NEWS: Mention Shepherd 0.9.2 upgrade. Mathieu Othacehe 2022-09-16Update NEWS....Entries extracted from: git log 3eadcdc63..version-1.4.0 * NEWS: Update entries for v1.4.0 Mathieu Othacehe 2022-09-15Update NEWS....This covers the commits made between v1.3.0..3eadcdc6^. * NEWS: New entries for the 1.4.0 upcoming release. Maxim Cournoyer 2022-09-14Update NEWS....These news were extracted from the output of: git log --reverse v1.3.0..03eb0b1be2cfedd0d9a66fef0edc53a17f7653a5. * NEWS: Update entries for v1.4.0. Maxim Cournoyer