This patch was copied from Debian.

Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16 
Author: Sophie Brun <sophie@freexian.com>
Last-Update: 2015-12-03
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/tests/vb2_common_tests.c
+++ b/tests/vb2_common_tests.c
@@ -70,6 +70,11 @@ static void test_workbuf(void)
 	/* NOTE: There are several magic numbers below which assume that
 	 * VB2_WORKBUF_ALIGN == 16 */
 
+        /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */
+        if (VB2_WORKBUF_ALIGN != 16) {
+            return;
+        }
+
 	/* Init */
 	vb2_workbuf_init(&wb, p0, 64);
 	TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned");
ws' onchange='this.form.submit();'>mode:
authorAntoine Côté <antoine.cote@posteo.net>2020-12-06 02:59:31 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-07 09:27:04 +0100
commitcbd33c0da1bd2aaf4804ae5a5fe070963dfb80cb (patch)
tree9d50648fc9c51f9e62b97a2ea0f0f5a9658fff79 /ChangeLog
parentf15cc2f4a2a1cdd0e4c9f9b4bec80c7ae84634cc (diff)
downloadguix-cbd33c0da1bd2aaf4804ae5a5fe070963dfb80cb.tar.gz
guix-cbd33c0da1bd2aaf4804ae5a5fe070963dfb80cb.zip
gnu: Add rust-aom-sys-0.2.
* gnu/packages/crates-graphics.scm (rust-aom-sys-0.2): New variable. (rust-aom-sys-0.1): Inherit from rust-aom-sys-0.2. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'ChangeLog')
0 files changed, 0 insertions, 0 deletions