aboutsummaryrefslogtreecommitdiff
From: "Steven M. Schweda" <sms@antinode.info>
Subject: Do not ignore extra fields containing Unix Timestamps
Bug-Debian: https://bugs.debian.org/842993
X-Debian-version: 6.0-21

--- a/process.c
+++ b/process.c
@@ -2914,10 +2914,13 @@
             break;
 
           case EF_IZUNIX2:
-            if (have_new_type_eb == 0) {
-                flags &= ~0x0ff;        /* ignore any previous IZUNIX field */
+            if (have_new_type_eb == 0) {        /* (< 1) */
                 have_new_type_eb = 1;
             }
+            if (have_new_type_eb <= 1) {
+                /* Ignore any prior (EF_IZUNIX/EF_PKUNIX) UID/GID. */
+                flags &= 0x0ff;
+            }
 #ifdef IZ_HAVE_UXUIDGID
             if (have_new_type_eb > 1)
                 break;          /* IZUNIX3 overrides IZUNIX2 e.f. block ! */
@@ -2933,6 +2936,8 @@
             /* new 3rd generation Unix ef */
             have_new_type_eb = 2;
 
+            /* Ignore any prior EF_IZUNIX/EF_PKUNIX/EF_IZUNIX2 UID/GID. */
+            flags &= 0x0ff;
         /*
           Version       1 byte      version of this extra field, currently 1
           UIDSize       1 byte      Size of UID field
@@ -2953,8 +2958,6 @@
                 uid_size = *((EB_HEADSIZE + 1) + ef_buf);
                 gid_size = *((EB_HEADSIZE + uid_size + 2) + ef_buf);
 
-                flags &= ~0x0ff;      /* ignore any previous UNIX field */
-
                 if ( read_ux3_value((EB_HEADSIZE + 2) + ef_buf,
                                     uid_size, &z_uidgid[0])
                     &&
45f91aa13cdc'>gnu: sysbench: Build with mariadb....* gnu/packages/benchmark.scm (sysbench)[arguments]: Remove mysql flag. [inputs]: Remove mysql. Add mariadb:dev. Efraim Flashner 2023-04-21gnu: sysbench: Remove fix-docbook phase....* gnu/packages/benchmark.scm (sysbench) [arguments]: Remove the fix-docbook phase. Maxim Cournoyer 2023-04-21gnu: sysbench: Fix test suite....* gnu/packages/benchmark.scm (sysbench) [arguments]: Patch egrep in the patch-test-runner phase. Maxim Cournoyer 2023-03-31Merge branch 'master' into stagingMaxim Cournoyer 2023-03-31gnu: python-locust: Update to 2.15.1....* gnu/packages/benchmark.scm (python-locust): Update to 2.15.1. [arguments]: Delete relax-requirements phase. Add increase-resource-limits. Update check phase. [propagated-inputs]: Remove python-jinja2. Maxim Cournoyer 2023-03-30services: base: Deprecate 'pam-limits-service' procedure....* doc/guix.texi (Base Services): Replace pam-limits-service with pam-limits-service-type. * gnu/packages/benchmark.scm (python-locust)[description]: Update index anchor to manual. * gnu/services/base.scm (pam-limits-service-type): Set default value. (pam-limits-service): Deprecate procedure. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Bruno Victal 2023-01-08gnu: Add vkmark....* gnu/packages/benchmark.scm (vkmark): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomasz Jeneralczyk 2022-12-11gnu: fio: Update to 3.33....* gnu/packages/benchmark.scm (fio): Update to 3.33. Tobias Geerinckx-Rice 2022-10-22gnu: fio: Update to 3.32....* gnu/packages/benchmark.scm (fio): Update to 3.32. Signed-off-by: Christopher Baines <mail@cbaines.net> Greg Hogan