aboutsummaryrefslogtreecommitdiff
Copied from Debian.

From: Santiago Vila <sanvila@debian.org>
Subject: zipinfo.c: Do not crash when hostver byte is >= 100

--- a/zipinfo.c
+++ b/zipinfo.c
@@ -2114,7 +2114,7 @@
             else
                 attribs[9] = (xattr & UNX_ISVTX)? 'T' : '-';  /* T==undefined */
 
-            sprintf(&attribs[12], "%u.%u", hostver/10, hostver%10);
+            sprintf(&attribs[11], "%2u.%u", hostver/10, hostver%10);
             break;
 
     } /* end switch (hostnum: external attributes format) */
ckages/image-processing.scm?id=ca291e4f73adafd8113e478705051d1737d81e54'>gnu: mia: Build against VTK 9....* gnu/packages/image-processing.scm (mia): Build against VTK 9. [inputs]: Remove vtk-7; add vtk. [source]: Add mia-vtk9.patch. * gnu/packages/patches/mia-vtk9.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Christopher Baines <mail@cbaines.net> Felix Gruber 2022-06-05gnu: vtk@7: Simplify regular expression....* gnu/packages/image-processing.scm (vtk-7)[arguments]: Replace ‘.’ wildcards with literal ‘@’ character matches. Tobias Geerinckx-Rice 2022-06-09gnu: vtk@7: Do not embed running kernel version....* gnu/packages/image-processing.scm (vtk-7)[arguments]: Add 'remove-kernel-version phase. Vagrant Cascadian 2022-05-31gnu: mia: Update to 2.4.7....* gnu/packages/patches/mia-fix-boost-headers.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (mia): Update to 2.4.7. [source]: Apply patch. [configure-flags]: Use the more conventional OFF option value (instead of 0). [inputs]: Use new style. Replace python2-lxml by python-lxml. Replace vtk by vtk-7. [native-inputs]: Use new style. Replace python-2 with python-wrapper. Maxim Cournoyer 2022-05-31gnu: dcmtk: Update to 3.6.7 and build as a shared library....* gnu/packages/image-processing.scm (dcmtk): Update to 3.6.7. [arguments]: New field. Maxim Cournoyer 2022-05-31gnu: Remove vtk-6....* gnu/packages/image-processing.scm (vtk-6): Delete variable. Maxim Cournoyer 2022-05-31gnu: itk-snap: Fix build....* gnu/packages/patches/itk-snap-alt-glibc-compat.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (itk-snap): Apply it. [phases]: Delete trailing #t. [inputs]: Use new style. Replace vtk-6 with vtk-7. Maxim Cournoyer 2022-05-31gnu: Add vtk-7....* gnu/packages/image-processing.scm: (vtk-7): New variable. * gnu/packages/patches/vtk-7-gcc-10-compat.patch: New patch. * gnu/packages/patches/vtk-7-hdf5-compat.patch: Likewise. * gnu/packages/patches/vtk-7-python-compat.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Maxim Cournoyer 2022-04-26gnu: Add bart....* gnu/packages/image-processing.scm (bart): New variable. Ricardo Wurmus 2022-04-01gnu: vtk: Remove input labels....* gnu/packages/image-processing.scm (vtk)[inputs]: Remove labels. Ludovic Courtès 2022-04-01gnu: vtk@6: Depend on Python 2.x, not 3.x....* gnu/packages/image-processing.scm (vtk-6)[native-inputs]: Replace PYTHON with PYTHON-2. Ludovic Courtès 2022-03-22gnu: opencv: Add pkgconfig generation flag....* gnu/packages/image-processing.scm (opencv)[arguments]: Add OPENCV_GENERATE_PKGCONFIG flag. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Blake Shaw