aboutsummaryrefslogtreecommitdiff
Copied from Fedora.

http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow.patch?id=d18f821e

diff --git a/extract.c b/extract.c
index a0a4929..9ef80b3 100644
--- a/extract.c
+++ b/extract.c
@@ -2214,6 +2214,7 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata)
     ulg eb_ucsize;
     uch *eb_ucptr;
     int r;
+    ush method;
 
     if (compr_offset < 4)                /* field is not compressed: */
         return PK_OK;                    /* do nothing and signal OK */
@@ -2223,6 +2224,12 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata)
          eb_size <= (compr_offset + EB_CMPRHEADLEN)))
         return IZ_EF_TRUNC;               /* no compressed data! */
 
+    method = makeword(eb + (EB_HEADSIZE + compr_offset));
+    if ((method == STORED) && (eb_size != compr_offset + EB_CMPRHEADLEN + eb_ucsize))
+        return PK_ERR;            /* compressed & uncompressed
+                                   * should match in STORED
+                                   * method */
+
     if (
 #ifdef INT_16BIT
         (((ulg)(extent)eb_ucsize) != eb_ucsize) ||
d'>system: Mention '--skip-checks' in initrd diagnostics....Ludovic Courtès 2018-07-29linux-initrd: Report only missing modules, not all needed modules....Ludovic Courtès 2018-07-29linux-initrd: Try several file names when looking up modules....Ludovic Courtès 2018-07-29linux-initrd: Improve check of initrd modules....Ludovic Courtès 2018-06-14linux-initrd: Module check correctly handles hyphen vs. underscore....Ludovic Courtès 2018-03-15linux-initrd: Autoload known-module-aliases, again....Mark H Weaver 2018-03-15linux-initrd: Move 'check-device-initrd-modules' elsewhere....Ludovic Courtès 2018-03-07linux-initrd: Factorize 'check-device-initrd-modules'....Ludovic Courtès 2018-03-02guix system: Check for the lack of modules in the initrd....Ludovic Courtès 2017-12-22mapped-devices: 'luks-device-mapping' checks its source device....Ludovic Courtès 2017-12-22mapped-devices: Add 'location' and 'check' fields....Ludovic Courtès 2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès 2017-06-07mapped-devices: Cope with delayed appearance of LUKS source....Mark H Weaver