aboutsummaryrefslogtreecommitdiff
Copied from Fedora.

http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow.patch?id=d18f821e

diff --git a/extract.c b/extract.c
index a0a4929..9ef80b3 100644
--- a/extract.c
+++ b/extract.c
@@ -2214,6 +2214,7 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata)
     ulg eb_ucsize;
     uch *eb_ucptr;
     int r;
+    ush method;
 
     if (compr_offset < 4)                /* field is not compressed: */
         return PK_OK;                    /* do nothing and signal OK */
@@ -2223,6 +2224,12 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata)
          eb_size <= (compr_offset + EB_CMPRHEADLEN)))
         return IZ_EF_TRUNC;               /* no compressed data! */
 
+    method = makeword(eb + (EB_HEADSIZE + compr_offset));
+    if ((method == STORED) && (eb_size != compr_offset + EB_CMPRHEADLEN + eb_ucsize))
+        return PK_ERR;            /* compressed & uncompressed
+                                   * should match in STORED
+                                   * method */
+
     if (
 #ifdef INT_16BIT
         (((ulg)(extent)eb_ucsize) != eb_ucsize) ||
Ricardo Wurmus 2018-04-21gnu: gobject-introspection: Combine duplicate 'arguments' fields....Mark H Weaver 2018-04-10gnu: python-pygobject: Use gcc-7....Mark H Weaver 2018-03-20gnu: itstool: Return #t from all phases....Mark H Weaver 2018-03-18gnu: gobject-introspection: Disable parallel build....Mark H Weaver 2018-03-17gnu: glib: Return #t from all phases....Mark H Weaver 2018-03-17gnu: dbus: Detect failures in the install phase....Mark H Weaver 2018-03-16gnu: glib: Build reproducibly....Ricardo Wurmus 2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver 2018-03-15gnu: gobject-introspection: Update to 1.56.0....Marius Bakke 2018-03-15gnu: glib: Update to 2.56.0....Marius Bakke 2018-03-14Merge branch 'master' into core-updatesRicardo Wurmus 2018-03-08gnu: dbus: Update to 1.12.6....Marius Bakke 2018-03-07gnu: python2-gobject@2: Update to 2.28.7...Mark Meyer 2018-03-07gnu: Use HTTPS on gtkmm.org home pages....Marius Bakke 2018-03-07gnu: glibmm: Update to 2.54.1....Marius Bakke 2018-02-28gnu: Add perl-glib....Alex Vong 2018-02-26gnu: Use HTTPS for supported freedesktop.org home pages....Tobias Geerinckx-Rice