aboutsummaryrefslogtreecommitdiff
From: sms
Subject: Fix CVE-2014-8140: out-of-bounds write issue in test_compr_eb()
Bug-Debian: http://bugs.debian.org/773722

--- a/extract.c
+++ b/extract.c
@@ -2234,10 +2234,17 @@
     if (compr_offset < 4)                /* field is not compressed: */
         return PK_OK;                    /* do nothing and signal OK */
 
+    /* Return no/bad-data error status if any problem is found:
+     *    1. eb_size is too small to hold the uncompressed size
+     *       (eb_ucsize).  (Else extract eb_ucsize.)
+     *    2. eb_ucsize is zero (invalid).  2014-12-04 SMS.
+     *    3. eb_ucsize is positive, but eb_size is too small to hold
+     *       the compressed data header.
+     */
     if ((eb_size < (EB_UCSIZE_P + 4)) ||
-        ((eb_ucsize = makelong(eb+(EB_HEADSIZE+EB_UCSIZE_P))) > 0L &&
-         eb_size <= (compr_offset + EB_CMPRHEADLEN)))
-        return IZ_EF_TRUNC;               /* no compressed data! */
+     ((eb_ucsize = makelong( eb+ (EB_HEADSIZE+ EB_UCSIZE_P))) == 0L) ||
+     ((eb_ucsize > 0L) && (eb_size <= (compr_offset + EB_CMPRHEADLEN))))
+        return IZ_EF_TRUNC;             /* no/bad compressed data! */
 
     if (
 #ifdef INT_16BIT
td>Björn Höfling 2020-05-13mailmap: Update entries for Nikita....nikita 2020-05-08Merge branch 'core-updates'Marius Bakke 2020-05-08gnu: twinkle: Update package definition....Raghav Gururajan 2020-05-08gnu: Add libilbc....Raghav Gururajan 2020-05-08gnu: Add zrtpcpp....Raghav Gururajan 2020-05-02Merge branch 'master' into core-updatesMarius Bakke 2020-05-02gnu: pjproject-jami: Update to 2.10....Jan Wielkiewicz 2020-05-02gnu: telephony: Move Jami and its dependencies to jami.scm....Jan Wielkiewicz 2020-04-23Merge branch 'master' into core-updates...Marius Bakke 2020-04-22gnu: commoncpp: Add support for gnu updater....Efraim Flashner 2020-04-22gnu: osip: Update to 5.1.1....Efraim Flashner 2020-04-22gnu: osip: Add support for gnu updater....Efraim Flashner