aboutsummaryrefslogtreecommitdiff
From: sms
Subject: Fix CVE-2014-8140: out-of-bounds write issue in test_compr_eb()
Bug-Debian: http://bugs.debian.org/773722

--- a/extract.c
+++ b/extract.c
@@ -2234,10 +2234,17 @@
     if (compr_offset < 4)                /* field is not compressed: */
         return PK_OK;                    /* do nothing and signal OK */
 
+    /* Return no/bad-data error status if any problem is found:
+     *    1. eb_size is too small to hold the uncompressed size
+     *       (eb_ucsize).  (Else extract eb_ucsize.)
+     *    2. eb_ucsize is zero (invalid).  2014-12-04 SMS.
+     *    3. eb_ucsize is positive, but eb_size is too small to hold
+     *       the compressed data header.
+     */
     if ((eb_size < (EB_UCSIZE_P + 4)) ||
-        ((eb_ucsize = makelong(eb+(EB_HEADSIZE+EB_UCSIZE_P))) > 0L &&
-         eb_size <= (compr_offset + EB_CMPRHEADLEN)))
-        return IZ_EF_TRUNC;               /* no compressed data! */
+     ((eb_ucsize = makelong( eb+ (EB_HEADSIZE+ EB_UCSIZE_P))) == 0L) ||
+     ((eb_ucsize > 0L) && (eb_size <= (compr_offset + EB_CMPRHEADLEN))))
+        return IZ_EF_TRUNC;             /* no/bad compressed data! */
 
     if (
 #ifdef INT_16BIT
td>tests: Adjust to 'show-manifest-transaction' changes....Ludovic Courtès 2019-11-29tests: Fix race condition in profile locking test....Ludovic Courtès 2019-11-22package: Allow multiple '--manifest' options....Ludovic Courtès 2019-11-08guix: package: lock profiles when processing them....Julien Lepiller 2019-09-26guix package: Add '--list-profiles'....Ludovic Courtès 2019-09-18guix package: "guix package -f FILE" ensures FILE returns a package....Ludovic Courtès 2019-05-26discovery: 'all-modules' returns modules in path order....Robert Vollmert 2019-05-13tests: Fix guix-package.sh....Maxim Cournoyer 2019-05-09ui: Make package outputs searchable....Chris Marusich 2019-02-07profiles: Raise an error for unmatched patterns....Ludovic Courtès 2018-11-11guix package: '--show' errors when asked for a non-existent package....Ludovic Courtès 2018-09-21profiles: 'packages->manifest' now accepts inferior packages....Ludovic Courtès 2018-07-13guix package: Use relative symlinks to generations....Ludovic Courtès