aboutsummaryrefslogtreecommitdiff
Make test work with upstream cbehave
(tinydir bundles a modified version)

diff --git a/tests/file_open_test.c b/tests/file_open_test.c
index 09b856e..92b13ca 100644
--- a/tests/file_open_test.c
+++ b/tests/file_open_test.c
@@ -4,6 +4,11 @@
 #include "cbehave.h"
 #include "util.h"
 
+#define ASSERT(cond, ret) \
+if (!(cond)) {\
+    cbehave_feature_return(__FILE__, __LINE__, ret, _state); \
+    goto _feature_over; \
+}\
 
 FEATURE(file_open, "File open")
 	SCENARIO("Open file in current directory")
@@ -34,4 +39,7 @@ FEATURE(file_open, "File open")
 	SCENARIO_END
 FEATURE_END
 
-CBEHAVE_RUN("File open:", TEST_FEATURE(file_open))
+int main(void) {
+	cbehave_feature _cfeatures[] = {{feature_idx(file_open)}};
+	return cbehave_runner("File open:", _cfeatures);
+}
ored-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: Iccbe644ade396ad27a037db7e0ef1c2a68ef91ce Ludovic Courtès 2023-09-26tests: Assume ‘git’ is always available....* tests/channels.scm (gpg+git-available?): Check for ‘gpg-command’ only. Remove all ‘test-skip’ statements. * tests/derivations.scm: Likewise. * tests/git-authenticate.scm: Likewise. * tests/git.scm: Likewise. * tests/import-git.scm: Likewise. Ludovic Courtès 2022-10-17git: 'update-cached-checkout' returns the commit ID when given a tag....Previously, starting with commit efa578ecaece67366b4b0e2266de7c2faaa4ae54, 'update-cached-checkout' would return the OID of the annotated tag the tag points to. With this change it returns the OID of the commit object in all cases. * guix/git.scm (resolve-reference): In the 'tag' case, call 'tag-target-id' and 'tag-lookup' when OID designates an annotated tag. * tests/git.scm ("update-cached-checkout, tag"): New test. Ludovic Courtès 2022-02-14git: Add 'commit-descendant?'....* guix/git.scm (commit-descendant?): New procedure. * tests/git.scm ("commit-descendant?"): New test. Ludovic Courtès