aboutsummaryrefslogtreecommitdiff
Description: Fix for libpng 1.6
Author: Programmer Nerd <theprogrammernerd@gmail.com>
Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743388#20
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743388
Reviewed-by: Tobias Frost <tobi@debian.org>>
Last-Update: 2016-04-07
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/t4k_loaders.c
+++ b/src/t4k_loaders.c
@@ -1028,12 +1028,9 @@
       {
         png_init_io(png_ptr, fi);
 
-        info_ptr->width = surf->w;
-        info_ptr->height = surf->h;
-        info_ptr->bit_depth = 8;
-        info_ptr->color_type = PNG_COLOR_TYPE_RGB_ALPHA;
-        info_ptr->interlace_type = 1;
-        info_ptr->valid = 0;	/* will be updated by various png_set_FOO() functions */
+	png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8,
+		PNG_COLOR_TYPE_RGB_ALPHA,  PNG_INTERLACE_NONE,
+                PNG_COMPRESSION_TYPE_DEFAULT, PNG_FILTER_TYPE_DEFAULT);
 
         png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
                        PNG_sRGB_INTENT_PERCEPTUAL);
20230323.0. (%ffmpeg-default-configure-flags): Update flags. (pjproject-jami): Update commit. (ffmpeg-jami) [version, source, outputs]: : Delete fields. [arguments]: Delete disable-problematic-tests phase. * gnu/packages/patches/jami-libjami-headers-search.patch: Rebase patch. Maxim Cournoyer 2023-02-07gnu: jami: Update to 20230206.0....* gnu/packages/jami.scm (jami): Update to 20230206.0. (%jami-version): Update version. (%jami-sources): Adjust URI. Streamline snippet. (jami-apply-custom-patches): Use a wildcard to match the top-level directory, which now includes the version. (%ffmpeg-default-configure-flags): Adjust URL in top comment. * gnu/packages/patches/jami-libjami-headers-search.patch: Adjust file names for new tarball layout. Maxim Cournoyer