aboutsummaryrefslogtreecommitdiff
diff --git a/lib/t1lib/parseAFM.c b/lib/t1lib/parseAFM.c
index 6a31d7f..ba64541 100644
--- a/lib/t1lib/parseAFM.c
+++ b/lib/t1lib/parseAFM.c
@@ -199,7 +199,9 @@ static char *token(stream)
     idx = 0;
     
     while (ch != EOF && ch != ' ' && ch != CR  && ch != LF &&
-	   ch != CTRL_Z && ch != '\t' && ch != ':' && ch != ';'){
+	   ch != CTRL_Z && ch != '\t' && ch != ':' && ch != ';'
+     && idx < (MAX_NAME -1))
+    {
       ident[idx++] = ch;
       ch = fgetc(stream);
     } /* while */
@@ -235,7 +237,7 @@ static char *linetoken(stream)
     while ((ch = fgetc(stream)) == ' ' || ch == '\t' ); 
     
     idx = 0;
-    while (ch != EOF && ch != CR  && ch != LF && ch != CTRL_Z) 
+    while (ch != EOF && ch != CR  && ch != LF && ch != CTRL_Z && idx < (MAX_NAME - 1)) 
     {
         ident[idx++] = ch;
         ch = fgetc(stream);
g-tooltip'>* gnu/packages/patches/u-boot-infodocs-target.patch: Delete file. * gnu/packages/patches/u-boot-patman-guix-integration.patch: Delete file. * gnu/local.mk: De-register patches. * gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Refresh. * gnu/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch: Refresh. * gnu/packages/bootloaders.scm (u-boot): Update to 2023.07.02. [native-inputs]: Add python-pyelftools. [source]: Remove patches. (u-boot-tools)[phases]: Update substitution for python3-coverage. Adjust 'patch to catch more openssl incompatibilities. Split lines in 'patch phase. [native-inputs]: Add python-filelock and python-pytest-xdist. (make-u-boot-sunxi64-package): Set SCP environment variable. (u-boot-sifive-unleashed): Update to use opensbi. (u-boot-puma-rk3399)[inputs]: Add arm-trusted-firmware-rk3399 to package-inputs instead of native-inputs. (u-boot-rockpro64-rk3399): Disable CONFIG_SPL_FIT_SIGNATURE in config. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Vagrant Cascadian 2022-12-12gnu: u-boot: Update to 2022.10....* gnu/packages/bootloaders.scm (u-boot): Update to 2022.10. * gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Disable fit_pre_load_data, which depends on openssl. Ricardo Wurmus