aboutsummaryrefslogtreecommitdiff
diff -ru src/part.c b/part.c
--- src/part.c	Thu May 14 06:01:00 2009 -0400
+++ b/part.c 	Thu May 14 06:01:00 2009 -0400
@@ -1767,8 +1767,8 @@
 /* to compute number of partitions */
 {
     INT erg = OK;
-    if (ni<0) return;
-    if (not EMPTYP(S_V_I(vec,ni))) return;
+    if (ni<0) return 0;
+    if (not EMPTYP(S_V_I(vec,ni))) return 0;
     else if (ni<=1) M_I_I(1,S_V_I(vec,ni));
     else {
     
reveal-hidden-html.patch?id=d7942ac12ad51615cd43d3debb8b561a503e8fc0'>icecat-use-older-reveal-hidden-html.patch
AgeCommit message (Expand)Author
2020-05-06gnu: icecat: Update to 68.8.0-guix0-preview1 [security fixes]....Includes fixes for CVE-2020-6831, CVE-2020-12387, CVE-2020-12388, CVE-2020-12389, CVE-2020-12392, CVE-2020-12393, and CVE-2020-12395. * gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update. (icecat-source): Update gnuzilla commit, base version, and hashes. Apply icecat-use-older-reveal-hidden-html.patch. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to new version. * gnu/packages/patches/icecat-use-older-reveal-hidden-html.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Mark H Weaver