aboutsummaryrefslogtreecommitdiff
--- src/bruch.c	2007-12-06 11:30:00.000000000 -0500
+++ b/bruch.c	2013-10-22 08:37:43.000000000 -0400
@@ -975,14 +975,16 @@
     ggterg = ggt_i(S_B_UI(bruch),S_B_OI(bruch));
 
     if (ggterg == S_B_UI(bruch)) {
+        INT tmp = S_B_OI(bruch);
         freeself_bruch(bruch);
-        M_I_I(S_B_OI(bruch) / ggterg,bruch);
+        M_I_I(tmp / ggterg,bruch);
         goto ende;
         }
 
     if (-ggterg == S_B_UI(bruch)) {
+        INT tmp = S_B_OI(bruch);
         freeself_bruch(bruch);
-        M_I_I(- S_B_OI(bruch) / ggterg,bruch);
+        M_I_I(- tmp / ggterg,bruch);
         goto ende;
         }
 
@@ -1032,12 +1034,14 @@
 
     if (S_O_K(S_B_U(bruch)) == INTEGER)
         if (S_B_UI(bruch) == 1) { 
+            INT tmp = S_B_OI(bruch);
             freeself_bruch(bruch);
-            M_I_I(S_B_OI(bruch),bruch); 
+            M_I_I(tmp,bruch); 
             goto ende; }
         else if (S_B_UI(bruch) == -1) { 
+            INT tmp = S_B_OI(bruch);
             freeself_bruch(bruch);
-            M_I_I( - S_B_OI(bruch),bruch); 
+            M_I_I( - tmp,bruch); 
             goto ende; }
     if (NEGP(S_B_O(bruch)) && NEGP(S_B_U(bruch)))
         {
fix]....Ludovic Courtès 2017-08-03activation: Make sure /etc exists....Ludovic Courtès 2017-05-30activation: Change permissions on /root to #o700....Ludovic Courtès 2017-05-18services: user-homes: Do not create home directories marked as no-create....Ludovic Courtès 2017-02-10Merge branch 'master' into core-updatesLudovic Courtès 2017-02-08services: Add 'special-files-service-type'....Ludovic Courtès 2017-02-04activation: Set the right owner for home directories....Ludovic Courtès 2017-02-02Merge branch 'master' into core-updatesLeo Famulari 2017-02-01system: Create home directories once 'file-systems' is up....Ludovic Courtès 2017-01-26utils: Add helper method to make files writable....Marius Bakke 2016-09-06activation: Don't fail if /var/lib exists....Leo Famulari 2016-09-06activation: Allow home directories to be created under /var/lib....David Craven 2016-08-28system: Add 'create-home-directory?' field to <user-account>....Ludovic Courtès 2016-03-24activation: Copy account skeletons silently....Ludovic Courtès 2016-03-20system: Allow account skeletons to be directories....Ludovic Courtès 2015-05-09system: activate-ptrace-attach: Handle kernels without YAMA support....Mark H Weaver 2015-05-05activation: Make user copies of the skeletons writable....Ludovic Courtès 2015-04-12system: Allow users to PTRACE_ATTACH to their own processes....Ludovic Courtès 2015-04-08activation: Remove undeclared user accounts and groups....Ludovic Courtès 2015-03-03system: Add /etc/ssl symlink; set needed variables in /etc/profile....Mark H Weaver 2014-12-13activation: Copy the account skeletons when creating the 'root' account....Ludovic Courtès 2014-12-06activation: Don't create unneeded "/var/guix/gcroots/etc-directory"....Ludovic Courtès 2014-11-11activation: Set the firmware search path....Ludovic Courtès 2014-11-02system: Allow Linux-libre to find our 'modprobe' command....Ludovic Courtès 2014-09-22activation: Ensure existing user accounts have the right settings....Ludovic Courtès 2014-09-12activation: Honor $GUIX_NEW_SYSTEM for use by 'guix system reconfigure'....Ludovic Courtès 2014-09-12activation: Set the permissions of /etc/sudoers to 440....Ludovic Courtès 2014-09-12activation: Make the /bin/sh symlink at activation time....Ludovic Courtès 2014-09-12activation: Make sure /etc/sudoers & co. are regular files....Ludovic Courtès 2014-09-12activation: Remove outdated comment....Ludovic Courtès 2014-09-12activation: Factorize the link-or-copy trick....Ludovic Courtès