aboutsummaryrefslogtreecommitdiff
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 26 Aug 2018 17:24:42 +0200
Subject: [PATCH] snappy: Add O2 flag in CmakeLists.txt.

Use ‘-O2’ optimisation when building with CMake, as is already done when
using the Makefile. This patch was copied verbatim from the Snappy
mailing list[0].

[0]: <snappy-compression@googlegroups.com>

From 903c72fb29b2db07b4abc38a5feb83d88f739d80 Mon Sep 17 00:00:00 2001
From: huangwenjun <huangwenjun-hf@loongson.cn>
Date: Fri, 10 Aug 2018 17:17:35 +0800
Subject: [PATCH] Add O2 optimize flag in CmakeLists.txt.

---
 CMakeLists.txt | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62ecd09..29e0cdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,9 @@ set(CMAKE_CXX_STANDARD 11)
 set(CMAKE_CXX_STANDARD_REQUIRED ON)
 set(CMAKE_CXX_EXTENSIONS OFF)
 
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2")
+SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2")
+
 # BUILD_SHARED_LIBS is a standard CMake variable, but we declare it here to make
 # it prominent in the GUI.
 option(BUILD_SHARED_LIBS "Build shared libraries(DLLs)." OFF)
-- 
2.1.0

tenment.scm (python2-efl): Delete variable. Maxim Cournoyer 2022-05-31gnu: Remove lekha....* gnu/packages/enlightenment.scm (lekha): Delete variable. Maxim Cournoyer 2022-02-13gnu: enlightenment: Update to 0.25.3....* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.3. Efraim Flashner 2022-02-08gnu: enlightenment: Patch dlopen of ddcutil....* gnu/packages/enlightenment.scm (enlightenment)[inputs]: Add ddcutil. [arguments]: Adjust custom 'set-system-actions phase to patch dlopen of libddcutil. Efraim Flashner 2022-02-08gnu: enlightenment: Update to 0.25.2....* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.2. Efraim Flashner 2022-02-08gnu: efl: Build with librsvg-for-system....* gnu/packages/enlightenment.scm (efl)[inputs]: Replace conditional librsvg with librsvg-for-system. [arguments]: Remove configure-flag disabling librsvg support. Efraim Flashner 2022-02-08gnu: efl: Update to 1.26.2....* gnu/packages/enlightenment.scm (efl): Update to 1.26.2. Efraim Flashner 2022-01-19gnu: terminology: Add missing input....* gnu/packages/enlightenment.scm (terminology)[native-inputs]: Add python. Efraim Flashner 2022-01-17gnu: efl: Add python to native inputs....* gnu/packages/enlightenment.scm (efl)[native-inputs]: Add python. Maxim Cournoyer 2022-01-06gnu: evisum: Remove input labels....* gnu/packages/enlightenment.scm (evisum)[native-inputs]: Remove package labels. Efraim Flashner 2022-01-06gnu: evisum: Update to 0.6.0....* gnu/packages/enlightenment.scm (evisum): Update to 0.6.0. Efraim Flashner 2022-01-06gnu: enlightenment: Update to 0.25.1....* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.1. Efraim Flashner 2022-01-06gnu: terminology: Respect #:tests? flag....* gnu/packages/enlightenment.scm (terminology)[arguments]: Adjust custom 'check phase to honor the #:tests? flag. Efraim Flashner 2022-01-06gnu: terminology: Remove input labels....* gnu/packages/enlightenment.scm (terminology)[native-inputs]: Remove package labels. Efraim Flashner 2022-01-06gnu: terminology: Update to 1.12.1....* gnu/packages/enlightenment.scm (terminology): Update to 1.12.1. [source]: Remove trailing #t. [arguments]: Remove trailing #t from phases. Efraim Flashner 2022-01-06gnu: efl: Update to 1.26.1....* gnu/packages/enlightenment.scm (efl): Update to 1.26.1. Efraim Flashner 2021-12-28gnu: ephoto: Update to 1.6.0....* gnu/packages/enlightenment.scm (ephoto): Update to 1.6.0. [build-system]: Switch to meson-build-system. [arguments]: Remove trailing #t from phases. [native-inputs]: Remove check. Efraim Flashner 2021-12-28gnu: enlightenment: Update to 0.25.0....* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.0. [arguments]: Remove unneeded configure-flags. Don't remove phase which isn't part of the build system. Remove trailing #t from phases. [inputs]: Add libexif. * gnu/packages/patches/enlightenment-fix-setuid-path.patch: Refresh patch. Efraim Flashner 2021-12-28gnu: rage: Update to 0.4.0....* gnu/packages/enlightenment.scm (rage): Update to 0.4.0. [arguments]: Remove trailing #t from phases. Efraim Flashner 2021-12-28gnu: efl: Update to 1.26.0....* gnu/packages/enlightenment.scm (efl): Update to 1.26.0. [native-inputs]: Replace check-0.14 with check. [arguments]: Adjust evas-loaders-disabler configure-flag. Remove trailing #t from phases. Efraim Flashner 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès