;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2018 Mathieu Othacehe ;;; Copyright © 2019 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu installer services) #:use-module (guix records) #:use-module (srfi srfi-1) #:export (system-service? system-serv
aboutsummaryrefslogtreecommitdiff
Display configurable login message after successful authentication.

Patch by E. Bavier

--- slim-1.3.6/panel.cpp.orig	1969-12-31 18:00:00.000000000 -0600
+++ slim-1.3.6/panel.cpp	2016-10-17 17:00:07.259649063 -0500
@@ -260,6 +260,7 @@
 
 void Panel::ClosePanel() {
 	XUngrabKeyboard(Dpy, CurrentTime);
+	XClearWindow(Dpy, Root);
 	XUnmapWindow(Dpy, Win);
 	XDestroyWindow(Dpy, Win);
 	XFlush(Dpy);
--- slim-1.3.6/cfg.cpp.orig	2016-10-17 17:08:06.767666139 -0500
+++ slim-1.3.6/cfg.cpp	2016-10-17 17:06:53.115663516 -0500
@@ -52,6 +52,7 @@
 	options.insert(option("lockfile","/var/run/slim.lock"));
 	options.insert(option("logfile","/var/log/slim.log"));
 	options.insert(option("authfile","/var/run/slim.auth"));
+	options.insert(option("login_msg","Logging in..."));
 	options.insert(option("shutdown_msg","The system is halting..."));
 	options.insert(option("reboot_msg","The system is rebooting..."));
 	options.insert(option("sessiondir",""));
--- slim-1.3.6/app.cpp.orig	2016-10-17 17:08:41.731667384 -0500
+++ slim-1.3.6/app.cpp	2016-10-17 17:07:48.415665486 -0500
@@ -520,6 +520,8 @@
 	struct passwd *pw;
 	pid_t pid;
 
+	LoginPanel->Message((char*)cfg->getOption("login_msg").c_str());
+
 #ifdef USE_PAM
 	try{
 		pam.open_session();
tworking) (packages '((specification->package "nss-certs"))) (recommended? #t)) ;; Network connectivity management. (system-service (name (G_ "NetworkManager network connection manager")) (type 'network-management) (snippet '((service network-manager-service-type) (service wpa-supplicant-service-type)))) (system-service (name (G_ "Connman network connection manager")) (type 'network-management) (snippet '((service connman-service-type) (service wpa-supplicant-service-type)))) (system-service (name (G_ "DHCP client (dynamic IP address assignment)")) (type 'network-management) (snippet '((service dhcp-client-service-type))))))) (define (desktop-system-service? service) "Return true if SERVICE is a desktop environment service." (eq? 'desktop (system-service-type service))) (define (networking-system-service? service) "Return true if SERVICE is a desktop environment service." (eq? 'networking (system-service-type service))) (define (system-services->configuration services) "Return the configuration field for SERVICES." (let* ((snippets (append-map system-service-snippet services)) (packages (append-map system-service-packages services)) (desktop? (find desktop-system-service? services)) (base (if desktop? '%desktop-services '%base-services))) (if (null? snippets) `(,@(if (null? packages) '() `((packages (append (list ,@packages) %base-packages)))) (services ,base)) `(,@(if (null? packages) '() `((packages (append (list ,@packages) %base-packages)))) (services (append (list ,@snippets ,@(if desktop? ;; XXX: Assume 'keyboard-layout' is in ;; scope. '((set-xorg-configuration (xorg-configuration (keyboard-layout keyboard-layout)))) '())) ,base))))))