aboutsummaryrefslogtreecommitdiff
Allow the configuration file and theme directory to be specified at run time.

Patch by Eelco Dolstra, from Nixpkgs.
---
 app.cpp | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/app.cpp b/app.cpp
index 237477d..735df9c 100644
--- a/app.cpp
+++ b/app.cpp
@@ -285,7 +285,9 @@ void App::Run()
 	if ( cfg == 0 )
 	{
 		cfg = new Cfg;
-		cfg->readConf(CFGFILE);
+		const char* cfgfile = getenv("SLIM_CFGFILE");
+		if (!cfgfile) cfgfile = CFGFILE;
+		cfg->readConf(cfgfile);
 	}
 	string themebase = "";
 	string themefile = "";
@@ -297,7 +299,9 @@ void App::Run()
 	}
 	else
 	{
-		themebase = string(THEMESDIR) + "/";
+		const char* themesdir = getenv("SLIM_THEMESDIR");
+		if (!themesdir) themesdir = THEMESDIR;
+		themebase = string(themesdir) + "/";
 		themeName = cfg->getOption("current_theme");
 		string::size_type pos;
 		if ((pos = themeName.find(",")) != string::npos)
-- 
2.39.2

¨s 2019-08-26ci: Try hard to build package replacements....Ludovic Courtès 2019-08-14gnu: mingw: Add x86_64 support....Carl Dong 2019-07-06ci: 'channel-build-system' honors the target system....Ludovic Courtès 2019-03-13Remove traces of "GuixSD"....Ludovic Courtès 2019-01-21ci: Skip system tests on armhf-linux....Ludovic Courtès 2019-01-20ci: Use a valid 'current-guix'....Ludovic Courtès 2019-01-06hydra: Compute jobs in an inferior....Ludovic Courtès 2019-01-06hydra: Move job definitions to (gnu ci)....Ludovic Courtès