aboutsummaryrefslogtreecommitdiff
ROMAN_HUNDREDS, ROMAN_TENS and ROMAN_ONES seem to use syntax, that is not
recognized (any longer?) by flex, so let's expand their definitions.

Index: spl-1.2.1/include/roman_numbers.metaflex
===================================================================
--- spl-1.2.1.orig/include/roman_numbers.metaflex
+++ spl-1.2.1/include/roman_numbers.metaflex
@@ -1,5 +1,5 @@
 ROMAN_THOUSANDS m+
-ROMAN_HUNDREDS  (c(d|m)|dc{0,3}|c{1,3})
-ROMAN_TENS      (x(l|c)|lx{0,3}|x{1,3})
-ROMAN_ONES      (i(v|x)|vi{0,3}|i{1,3})
+ROMAN_HUNDREDS  (c(d|m|c?c?)|dc?c?c?)
+ROMAN_TENS      (x(l|c|x?x?)|lx?x?x?)
+ROMAN_ONES      (i(v|x|i?i?)|vi?i?i?)
 ROMAN_NUMBER    {ROMAN_ONES}|{ROMAN_TENS}{ROMAN_ONES}?|{ROMAN_HUNDREDS}{ROMAN_TENS}?{ROMAN_ONES}?|{ROMAN_THOUSANDS}{ROMAN_HUNDREDS}?{ROMAN_TENS}?{ROMAN_ONES}?
h?id=5cf9a03b7a86de9b7cc696fe4e45a650a4196b99'>gnu: rust: Bootstrap with rust-1.54.0....* gnu/packages/rust.scm (rust-1.39): Rename to rust-bootstrap. Update to 1.54.0. [source]: Update snippet to new version. Replace mrustc patch for 1.39.0 with patch for 1.54.0. [inputs]: Remove libssh2. Replace llvm-9 with llvm. Add gcc-9. [arguments]: Adjust custom 'setup-mrustc-sources to also create file with rust version. Adjust custom 'patch-makefiles phase to changes in mrustc's build steps. Adjust custom 'build phase to follow mrustc's build steps for rust-1.54. (rust-1.40): Replace post-bootstrapped rust-1.40 with 1.55. [arguments]: Add custom 'set-linker-locale-to-utf8 phase. Adjust custom 'build phase. Remove custom 'neuter-tidy phase. [inputs]: Replace llvm-9 with llvm. (rust-1.41, rust-1.42, rust-1.43, rust-1.44, rust-1.45, rust-1.46, rust-1.47, rust-1.48, rust-1.49, rust-1.50, rust-1.51, rust-1.52, rust-1.53): Remove variables. * gnu/packages/patches/rust-1.39.0-src.patch: Remove file. * gnu/packages/patches/rust-1.54.0-src.patch: Add file. * gnu/local.mk (dist_patch_DATA): Register changes. Efraim Flashner