aboutsummaryrefslogtreecommitdiff
From a5ecd1b2302d0def2f6f8349747022a615a9f017 Mon Sep 17 00:00:00 2001
From: Tamas K Lengyel <tamas@tklengyel.com>
Date: Tue, 26 May 2020 13:27:50 -0600
Subject: [PATCH] Don't limit to email with @gmail.com

---
 go/sendgmail/main.go | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/go/sendgmail/main.go b/go/sendgmail/main.go
index b35ef23..405aa1b 100644
--- a/go/sendgmail/main.go
+++ b/go/sendgmail/main.go
@@ -30,7 +30,6 @@ import (
 	"log"
 	"net/smtp"
 	"os"
-	"strings"
 
 	"golang.org/x/oauth2"
 	googleOAuth2 "golang.org/x/oauth2/google"
@@ -52,9 +51,6 @@ func init() {
 
 func main() {
 	flag.Parse()
-	if atDomain := "@gmail.com"; !strings.HasSuffix(sender, atDomain) {
-		log.Fatalf("-sender must specify an %v email address.", atDomain)
-	}
 	config := getConfig()
 	tokenPath := fmt.Sprintf("%v/.sendgmail.%v.json", os.Getenv("HOME"), sender)
 	if setUp {
-- 
2.32.0

175ace879301cd81b83c8cc89'>gnu: tor: Update to 0.4.1.6....* gnu/packages/tor.scm (tor): Update to 0.4.1.6. Tobias Geerinckx-Rice 2019-08-20gnu: tor: Update to 0.4.1.5....* gnu/packages/tor.scm (tor): Update to 0.4.1.5. Tobias Geerinckx-Rice 2019-08-13gnu: onionshare: Upgrade to 2.1....* gnu/packages/tor.scm (onionshare): Upgrade to 2.1. [arguments]: Rename "tests" phase to "check". Set home directory for tests. Remove reference to closed upstream bug. [inputs]: Add python-pycrypto and python-pysocks. [license]: Remove bsd-3 license; relevant file no longer present. Eric Bavier 2019-07-22gnu: zstd: Move libraries to separate outputs....* gnu/packages/compression.scm (zstd)[outputs]: New field. [arguments]: Add phase 'adjust-libary-locations'. Pass LIBDIR and INCLUDEDIR in <#:make-flags>. * gnu/packages/backup.scm (borg)[inputs]: Change ZSTD to ZSTD:LIB. * gnu/packages/sync.scm (casync)[inputs]: Likewise. * gnu/packages/tor.scm (tor)[inputs]: Likewise. * gnu/packages/linux.scm (btrfs-progs)[inputs]: Likewise. Add ZSTD:STATIC. Marius Bakke 2019-05-05gnu: tor: Remove explicit hardening flags....* gnu/packages/tor.scm (tor)[arguments]: Remove #:configure-flags that merely confirm the defaults. Tobias Geerinckx-Rice 2019-05-03gnu: tor: Update to 0.4.0.5....* gnu/packages/tor.scm (tor): Update to 0.4.0.5. Tobias Geerinckx-Rice