aboutsummaryrefslogtreecommitdiff
From 854490dc4a8a6a661b4750730c3ff749519f6e36 Mon Sep 17 00:00:00 2001
From: Philip McGrath <philip@philipmcgrath.com>
Date: Sun, 14 Nov 2021 10:14:24 -0500
Subject: [PATCH] sendgmail: accept and ignore a "-gsuite" flag

Accepting a "-gsuite" flag provides compatability with
https://github.com/Flameeyes/gmail-oauth2-tools/commit/eabb456
so users do not have to change their scripts or config files.

Full hash of original: eabb45608ff4ce04045ff4ea92d05450e789ac81

Related to https://github.com/google/gmail-oauth2-tools/pull/17
---
 go/sendgmail/main.go | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/go/sendgmail/main.go b/go/sendgmail/main.go
index 405aa1b..5cfd0c1 100644
--- a/go/sendgmail/main.go
+++ b/go/sendgmail/main.go
@@ -40,6 +40,7 @@ var (
 	setUp  bool
 	dummyF string
 	dummyI bool
+	gsuite bool
 )
 
 func init() {
@@ -47,6 +48,7 @@ func init() {
 	flag.BoolVar(&setUp, "setup", false, "If true, sendgmail sets up the sender's OAuth2 token and then exits.")
 	flag.StringVar(&dummyF, "f", "", "Dummy flag for compatibility with sendmail.")
 	flag.BoolVar(&dummyI, "i", true, "Dummy flag for compatibility with sendmail.")
+	flag.BoolVar(&gsuite, "gsuite", true, "Dummy flag for compatibility with other forks of sendgmail.")
 }
 
 func main() {
-- 
2.32.0

urtès <ludo@gnu.org> Jean-Pierre De Jesus DIAZ 2023-09-05gnu: libusb-compat: Specify the absolute file name for libusb....Refine the fix for loading libusb correctly. * gnu/packages/libusb.scm (libusb) [arguments] <configure-flags>: New LIBUSB_1_0_SONAME flag. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> nathan 2023-09-02gnu: libusb-compat: Add libusb to RUNPATH....This avoids the error: teensy_loader_cli: error while loading libusb-1.0.so.0 from libusb-0.1.so.4: libusb-1.0.so.0: cannot open shared object file: No such file or directory e.g. when running teensy_loader_cli, which uses libusb-compat. * gnu/packages/libusb.scm (libusb-compat) [arguments] <configure-flags>: New LDFLAGS variable. Maxim Cournoyer 2023-08-29gnu: Add python-hid....* gnu/packages/libusb.scm (python-hid): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org> Jean-Pierre De Jesus DIAZ