aboutsummaryrefslogtreecommitdiff
From 6d512b5c4d774a9853b51dae464a10cea7e3423a Mon Sep 17 00:00:00 2001
From: Peter Rustler <peter.rustler@basyskom.com>
Date: Mon, 7 Dec 2015 11:40:05 +0000
Subject: [PATCH] Add support for new webkit version 4.0 to build system

Add new configure value for option --with-webkit.
Now you can add 4.0 as value to --with-webkit.
Default is still 3.0.

https://bugzilla.gnome.org/show_bug.cgi?id=759171
---
 configure.ac | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index 2313c093..3d5d4823 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,12 +77,12 @@ dnl ==============================WebKit=======================================
 m4_define([webkit_default], [3.0])
 
 AC_ARG_WITH([webkit],
-            [AC_HELP_STRING([--with-webkit=@<:@3.0/1.0@:>@],
+            [AC_HELP_STRING([--with-webkit=@<:@4.0/3.0/1.0@:>@],
                             [Select the Webkit backend, default=3.0])],
 	    [],
             [with_webkit=webkit_default])
 
-dnl=== support both 1.0 and 3.0 (default 3.0) ==
+dnl=== support all 1.0, 3.0 and 4.0 (default 3.0) ==
 AS_CASE([$with_webkit],
 	[3.0], [
 		WEBKIT_PC=webkitgtk-3.0
@@ -90,6 +90,12 @@ AS_CASE([$with_webkit],
 		AC_CHECK_LIB(webkitgtk-3.0, JSContextGroupCreate,,
 	                AC_CHECK_LIB(javascriptcoregtk-3.0, JSContextGroupCreate,WEBKIT_PC=javascriptcoregtk-3.0)) 
 	],
+	[4.0], [
+		WEBKIT_PC=webkitgtk-4.0
+		SEED_GTK_VERSION=-gtk4
+		AC_CHECK_LIB(webkitgtk-4.0, JSContextGroupCreate,,
+	                AC_CHECK_LIB(javascriptcoregtk-4.0, JSContextGroupCreate,WEBKIT_PC=javascriptcoregtk-4.0))
+	],
 	[1.0], [
 		AC_CHECK_LIB(webkitgtk-1.0, JSContextGroupCreate,WEBKIT_PC=webkitgtk-1.0,
 	                AC_CHECK_LIB(javascriptcoregtk-1.0, JSContextGroupCreate,WEBKIT_PC=javascriptcoregtk-1.0, 
-- 
GitLab

lass='msg-avail'>...* po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add it. * doc/local.mk: Add pt_BR cookbook. Julien Lepiller 2022-01-09nls: Update translations....* po/doc/guix-cookbook.fi.po: New file. * po/doc/guix-manual.fi.po: New file. * po/doc/local.mk: Add them. * doc/local.mk: Add them. * po/guix/fi.po: New file. * po/guix/LINGUAS: Add it. Julien Lepiller 2021-11-06nls: Update translations....* po/doc/guix-cookbook.es.po: New file. * po/doc/local.mk: Add 'es' cookbook. * doc/local.mk: Add 'es' cookbook. Julien Lepiller 2021-08-04nls: Update translations....* po/doc/guix-cookbook.ru.po: New file. * po/doc/guix-cookbook.sk.po: New file. * po/*/*.po: Update translations. * doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk. (info_TEXINFOS): Add Russian and Slovak cookbooks. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po files. Julien Lepiller 2021-05-03nls: Remove the doc-po-update target....As discussed with Julien Lepiller on IRC, updating the PO files is not useful. This change removes the target and associated rules that allowed updating them. This has the benefit of not having the PO files updated automatically when generating the .pot files, which was causing spurious changes under the po sub-directory. * po/doc/local.mk (make-update-po-files-rule): Remove function and its uses. (doc-po-update): Remove target. Maxim Cournoyer 2021-04-30build: Correct a mistake in the guix-manual.pot rule....This is a follow-up to commit 0d353b06ec. * po/doc/local.mk: Fix function name in comment. (%D%/guix-manual.pot): Refer to *all* the prerequisites via the $^ special variable rather than $<, which only refers to the first one. Reported-by: Julien Lepiller <julien@lepiller.eu> Maxim Cournoyer 2021-04-29build: Make doc-po-update and doc-pot-update targets idempotent....It used to be that the running the doc-po-update and doc-pot-update targets would redo the same work on every run. This change splits the problem in smaller chunks and specifies build dependencies in a way that outputs only get rebuilt when their inputs changed. * po/doc/local.mk (DOC_PO_FILES): Harmonize escapes. (POT_OPTIONS): Re-indent uniformly. (doc-po-update-%, doc-po-update-cookbook-%): Re-implement with... (make-update-po-files-rule): ... this new function. (TMP_POT_FILES): Remove variable. (%D%/%.pot, %D%/guix-manual.pot): New pattern rules. (doc-pot-update, doc-po-update): Adjust prerequisites accordingly. Maxim Cournoyer 2021-04-29build: Build the guix.pot-update and contributing.pot-update targets only once....* po/doc/local.mk (doc-pot-update): Fix an issue where guix.pot-update an contributing.pot-update were built twice. Maxim Cournoyer 2021-04-18nls: Fix Chinese cookbook inclusion....* po/doc/local.mk: zh_Hans is for the cookbook, not the manual. Julien Lepiller 2021-04-18nls: Add Chinese (Traditional) translation....* po/doc/guix-cookbook.zh_Hans.po: New file. * doc/local.mk (info_TEXINFOS): Add it. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add it. Julien Lepiller 2021-04-18nls: Add Korean translation....* po/doc/guix-cookbook.ko.po: New file. * po/doc/guix-manual.ko.po: New file. * doc/local.mk (info_TEXINFOS): Add them. * po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them. * po/guix/ko.po: New file. * po/guix/LINGUAS: Add 'ko'. * po/packages/ko.po: New file. * po/packages/LINGUAS: Add 'ko'. Julien Lepiller 2021-04-18nls: Add Italian translation....* po/doc/guix-manual.it.po: New file. * po/doc/local.mk (DOC_PO_FILES): Add it. * doc/local.mk (info_TEXINFOS): Add it. * po/guix/it.po: New file. * po/guix/LINGUAS: Add 'it'. Julien Lepiller 2021-04-18nls: Add Persian translation....* po/packages/fa.po: New file. * po/packages/LINGUAS: Add 'fa'. * po/doc/guix-cookbook.fa.po: New file. * po/doc/guix-manual.fa.po: New file. * po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them. * doc/local.mk (info_TEXINFOS): Add them. Julien Lepiller 2021-04-18nls: Add Slovak translation....* po/packages/sk.po: New file. * po/packages/LINGUAS: Add 'sk'. * po/doc/guix-manual.sk.po: New file. * doc/local.mk (info_TEXINFOS): Add it. * po/doc/local.mk (DOC_PO_FILES): Add it. Julien Lepiller 2021-04-18nls: Add Portuguese (Brazil) translation of the manual.Julien Lepiller 2021-04-18nls: Add French translation of the cookbook.Julien Lepiller 2020-09-29nls: Fix documentation pot generation....* po/doc/local.mk: Fix POT_OPTIONS to properly assign copyright and define the proper license. Julien Lepiller 2020-03-06doc: Fix build of German Cookbook translation....This is a follow-up to f98e83a17fa30587520e858231ec9c61f3624ecd. See <https://lists.gnu.org/archive/html/guix-devel/2020-03/msg00095.html>. Reported there by Vagrant Cascadian <vagrant@debian.org>. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Use correct file name. (doc-po-update-cookbook-%): Use correct PO file name. Florian Pelz