#!/bin/sh # GNU Guix --- Functional package management for GNU # Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès # # This file is part of GNU Guix. # # GNU Guix is free software; you can redistribute it and/or modify it # under the terms of the GNU General Public License as published by # the Free Software Foundation; either version 3 of the License, or (at # your option) any later version. # # GNU Guix is distributed in the hope that it will be useful, but # WITHOUT ANY WARRANTY; without even the implied warranty of # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the # GNU General Public License for more details. # # You should have received a copy of the GNU General Public License # along with GNU Guix. If not, see . # Usage: ./test-env COMMAND ARG... # # Run the daemon in the build directory, and run COMMAND within # `pre-inst-env'. This is used to run unit tests with the just-built # daemon, unless `--disable-daemon' was passed at configure time. # Make sur
aboutsummaryrefslogtreecommitdiff
This patch disables the use of non-free code distributed with SDCC by
removing

  - The "--disable-non-free" option to "configure" and the build logic
    it controls;

  - All references to the "device/non-free" source directory and the
    corresponding "non-free" installation directory; and

  - The "--use-non-free" and "--no-warn-non-free" compiler options and
    references to them in build scripts and compiler output.

It also updates SDCC's documentation to reflect these changes and to
remove instructions that encourage the use of SDCC with non-free
software.

diff --git a/Makefile.common.in b/Makefile.common.in
index 8469079..174ed91 100644
--- a/Makefile.common.in
+++ b/Makefile.common.in
@@ -78,7 +78,6 @@ OPT_DISABLE_PACKIHX     = @OPT_DISABLE_PACKIHX@
 OPT_DISABLE_SDBINUTILS  = @OPT_DISABLE_SDBINUTILS@
 OPT_DISABLE_SDCPP       = @OPT_DISABLE_SDCPP@
 OPT_DISABLE_UCSIM       = @OPT_DISABLE_UCSIM@
-OPT_DISABLE_NON_FREE    = @OPT_DISABLE_NON_FREE@
 
 SLIB                    = $(top_builddir)/support/util
 
diff --git a/Makefile.in b/Makefile.in
index 3287e30..69511e1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -104,9 +104,6 @@ endif
 ifeq ($(OPT_DISABLE_DEVICE_LIB), 0)
 TARGETS        += sdcc-device-lib
 PKGS           += device/lib
-ifeq ($(OPT_DISABLE_NON_FREE), 0)
-PKGS           += device/non-free/lib
-endif
 endif
 
 ifeq ($(OPT_DISABLE_PACKIHX), 0)
@@ -127,9 +124,6 @@ endif
 TARGETS        += sdcc-libs sdcc-cc sdcc-device-inc sdcc-as sdcc-ld sdcc-scripts
 
 PKGS           += $(SDCC_LIBS) src device/include
-ifeq ($(OPT_DISABLE_NON_FREE), 0)
-PKGS           += device/non-free/include
-endif
 PKGS           += $(SDCC_AS) sdas/linksrc $(SDCC_SCRIPTS)
 
 PORTS           = $(shell cat ports.build)
@@ -167,21 +161,12 @@ sdcc-sdbinutils:
 
 sdcc-device-inc:
 	$(MAKE) -C device/include
-ifeq ($(OPT_DISABLE_NON_FREE), 0)
-	$(MAKE) -C device/non-free/include
-endif
 
 sdcc-device-lib: sdcc-cc sdcc-as sdcc-ld $(SDCC_BINUTILS)
 	$(MAKE) -C device/lib
-ifeq ($(OPT_DISABLE_NON_FREE), 0)
-	$(MAKE) -C device/non-free/lib
-endif
 
 sdcc-device-tini:
 	$(MAKE) -C device/include
-ifeq ($(OPT_DISABLE_NON_FREE), 0)
-	$(MAKE) -C device/non-free/include
-endif
 	$(MAKE) -C device/lib model-ds390 model-ds400
 
 # doc depends on latex and latex2html
diff --git a/configure b/configure
index b509c84..c7ce7fc 100755
--- a/config