aboutsummaryrefslogtreecommitdiff
From 8110ebd55d5bf659cd40dab2df59d80dafdb367a Mon Sep 17 00:00:00 2001
From: Kevin Layer <layer@franz.com>
Date: Mon, 10 Feb 2014 11:10:42 -0800
Subject: [PATCH 2/2] fix bugs in rfe12668 implementation

The previous commit added :embed and :keygen but they were already
there.  Resolve this issue.

Change-Id: Ieb962a12880394e67d973835945005446833fab7
---
 aserve/htmlgen/htmlgen.cl | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/aserve/htmlgen/htmlgen.cl b/aserve/htmlgen/htmlgen.cl
index 0c0d6e8..f77d6de 100644
--- a/aserve/htmlgen/htmlgen.cl
+++ b/aserve/htmlgen/htmlgen.cl
@@ -658,7 +658,6 @@
 (def-std-html :dt        t nil)
 
 (def-std-html :em        t nil)
-(def-std-html :embed     t nil)
 
 (def-std-html :fieldset        t nil)
 (def-std-html :font        t nil)
@@ -685,7 +684,6 @@
 (def-std-html :isindex    nil nil)
 
 (def-std-html :kbd  	t nil)
-(def-std-html :keygen  	nil nil)
 
 (def-std-html :label  	t nil)
 (def-std-html :layer  	t nil)
@@ -782,5 +780,5 @@
 (def-std-html :menuitem	 	t nil)
 (def-std-html :details	 	t nil)
 (def-std-html :datalist	 	t nil)
-(def-std-html :keygen	 	t nil)
+(def-std-html :keygen	 	nil nil)
 (def-std-html :output	 	t nil)
-- 
2.25.1

nd): Use xorg-wrapper. Andy Wingo 2017-02-19gnu: Remove xf86-video-modesetting....This is part of xorg-server since version 1.17: https://cgit.freedesktop.org/xorg/xserver/commit/?id=35dc7c75150733dbcef8a18b6796f49a7c48ebee * gnu/packages/xorg.scm (xf86-video-modesetting): Remove variable. * gnu/services/xorg.scm (xorg-configuration-file, %default-xorg-modules): Adjust accordingly. Marius Bakke 2016-10-06services: xorg: Add ATI video driver to the default modules....* gnu/services/xorg.scm (%default-xorg-modules): Add xf86-video-ati. Signed-off-by: 宋文武 <iyzsong@gmail.com> 8p8c 2016-09-10system: Use 'file-append' to denote file names....* gnu/services/avahi.scm, gnu/services/base.scm, gnu/services/databases.scm, gnu/services/dbus.scm, gnu/services/desktop.scm, gnu/services/dict.scm, gnu/services/mail.scm, gnu/services/networking.scm, gnu/services/sddm.scm, gnu/services/spice.scm, gnu/services/ssh.scm, gnu/services/web.scm, gnu/services/xorg.scm, gnu/system.scm: Replace the #~(string-append #$pkg "/bin/foo") idiom with (file-append pkg "/bin/foo"). Ludovic Courtès 2016-09-06services: Export initrc....* gnu/services/xorg.scm (define-module): Export initrc. David Craven 2016-09-01gnu: slim: Move to display-managers.scm....* gnu/packages/display-managers.scm: New file. * gnu/packages/slim.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/services/xorg.scm: Likewise. Marius Bakke 2016-07-21services: Export *-service-type and *-configuration....This allows users to use 'modify-services' and similar constructs for all these service types. * gnu/services/avahi.scm: export avahi-configuration. * gnu/services/base.scm: export gpm-configuration and rngd-configuration. * gnu/services/databases.scm: export *-service-type and *-configuration. * gnu/services/dbus.scm: export dbus-configuration. * gnu/services/dict.scm: export dicod-service-type. * gnu/services/lirc.scm: export lirc-configuration and lirc-service-type. * gnu/services/mail.scm: export dovecot-service-type. * gnu/services/web.scm: export nginx-configuration and nginx-service-type. * gnu/services/xorg.scm: export screen-locker and screen-locker?. * gnu/services/ssh.scm: export lsh-configuration and lsh-service-type. * gnu/services/desktop.scm: export *-service, *-service-type and *-configuration. * gnu/services/networking.scm: export *-configuration and *-service-type. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Tomáš Čech 2016-07-12gnu: Switch to 'with-imported-modules'....* gnu/services.scm (directory-union): Use 'with-imported-modules' instead of the '#:modules' argument of 'computed-file'. * gnu/services/base.scm (udev-rules-union): Likewise. * gnu/services/dbus.scm (system-service-directory): Likewise. * gnu/services/desktop.scm (wrapped-dbus-service): (polkit-directory): Likewise. * gnu/services/networking.scm (tor-configuration->torrc): Likewise. * gnu/services/xorg.scm (xorg-configuration-directory): Likewise. * gnu/system/install.scm (self-contained-tarball): Likewise. * gnu/system/linux-container.scm (container-script): Likewise. * gnu/system/linux-initrd.scm (expression->initrd): Likewise, and remove #:modules parameter. (flat-linux-module-directory): Use 'with-imported-modules'. (base-initrd): Likewise. * gnu/system/locale.scm (locale-directory): Likewise. * gnu/system/shadow.scm (default-skeletons): Likewise. * gnu/system/vm.scm (expression->derivation-in-linux-vm): Likewise. * gnu/tests/base.scm (run-basic-test): Likewise. * gnu/tests/install.scm (run-install): Likewise. * doc/guix.texi (Initial RAM Disk): Update 'expression->initrd' documentation. Ludovic Courtès