aboutsummaryrefslogtreecommitdiff
diff --git a/Cargo.toml b/Cargo.toml
index 57924f1..0c59727 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -43,11 +43,6 @@ bench = false
 version = "0.4"
 optional = true
 
-[dependencies.blas-src]
-version = "0.6.1"
-optional = true
-default-features = false
-
 [dependencies.cblas-sys]
 version = "0.1.4"
 optional = true
@@ -92,7 +87,7 @@ version = "0.9"
 default-features = false
 
 [features]
-blas = ["cblas-sys", "blas-src"]
+blas = ["cblas-sys"]
 docs = ["approx", "serde", "rayon"]
 serde-1 = ["serde"]
 test = ["test-blas-openblas-sys"]
cm (cuirass-log-rotations): Add the remote server log when it is used. Ludovic Courtès 2022-12-07services: cuirass-remote-worker: Rotate logs....* gnu/services/cuirass.scm (cuirass-remote-worker-log-rotations): New procedure. (cuirass-remote-worker-service-type): Use it. Ludovic Courtès 2022-12-02records: 'match-record' checks fields at macro-expansion time....This allows 'match-record' to be more efficient (field offsets are computed at compilation time) and to report unknown fields at macro-expansion time. * guix/records.scm (map-fields): New macro. (define-record-type*)[rtd-identifier]: New procedure. Define TYPE as a macro and use a separate identifier for the RTD. (lookup-field, match-record-inner): New macros. (match-record): Rewrite in terms of 'match-error-inner'. * tests/records.scm ("match-record, simple") ("match-record, unknown field"): New tests. * gnu/services/cuirass.scm (cuirass-shepherd-service): Rename 'log-file' local variable to 'main-log-file'. * gnu/services/getmail.scm (serialize-getmail-configuration-file): Move after <getmail-configuration-file> definition. Ludovic Courtès 2022-08-01services: rottlog: More convenient default options for <log-rotation>....* gnu/services/admin.scm (%default-log-rotation-options): New variable. (%default-rotations): Use it. * gnu/services/cuirass.scm (cuirass-log-rotations): Likewise. * doc/guix.texi (Log Rotation): Adjust accordingly. Ludovic Courtès 2022-02-17services: cuirass: Also rotate the web log....* gnu/services/cuirass.scm (cuirass-log-rotations): Add the web log to the list of rotated files. Maxim Cournoyer