aboutsummaryrefslogtreecommitdiff
Fix CVE-2017-8779:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8779

Patch copied from the bug reporter's 3rd-party repository:

https://github.com/guidovranken/rpcbomb/blob/master/rpcbind_patch.txt

diff --git a/src/rpcb_svc_com.c b/src/rpcb_svc_com.c
index 5862c26..e11f61b 100644
--- a/src/rpcb_svc_com.c
+++ b/src/rpcb_svc_com.c
@@ -48,6 +48,7 @@
 #include <rpc/rpc.h>
 #include <rpc/rpcb_prot.h>
 #include <rpc/svc_dg.h>
+#include <rpc/rpc_com.h>
 #include <netconfig.h>
 #include <errno.h>
 #include <syslog.h>
@@ -432,7 +433,7 @@ rpcbproc_taddr2uaddr_com(void *arg, struct svc_req *rqstp /*__unused*/,
 static bool_t
 xdr_encap_parms(XDR *xdrs, struct encap_parms *epp)
 {
-	return (xdr_bytes(xdrs, &(epp->args), (u_int *) &(epp->arglen), ~0));
+	return (xdr_bytes(xdrs, &(epp->args), (u_int *) &(epp->arglen), RPC_MAXDATASIZE));
 }
 
 /*
91b5026a0defd'>nls: Update translations....Julien Lepiller 2022-11-04nls: Update translations....Julien Lepiller 2022-10-06nls: Update translations.Julien Lepiller 2022-09-04nls: Update translations.Julien Lepiller 2022-08-10nls: Update translations....Julien Lepiller 2022-07-09nls: Update translations....Julien Lepiller 2022-06-04nls: Update translations....Julien Lepiller 2022-05-01nls: Update translations....Julien Lepiller 2022-04-02nls: Update translations....Julien Lepiller 2022-03-01nls: Update translations....Julien Lepiller 2022-02-04nls: Update translations....Julien Lepiller 2022-01-09nls: Update translations....Julien Lepiller 2021-12-04nls: Update translations.Julien Lepiller 2021-11-06nls: Update translations....Julien Lepiller 2021-10-17nls: Update translations.Julien Lepiller 2021-09-02nls: Update translations....Julien Lepiller 2021-08-04nls: Update translations....Julien Lepiller 2021-05-10nls: Update translations.Maxim Cournoyer 2021-04-18nls: Update 'de' translations.Julien Lepiller