aboutsummaryrefslogtreecommitdiff
This patch adds a header file that is present in the ripperx git and needed
for inclusion, but missing in the distribution tarball.

diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h
--- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h	1970-01-01 01:00:00.000000000 +0100
+++ ripperx-2.8.0/src/gtk_cpp_workaround.h	2015-07-24 21:09:16.548476337 +0200
@@ -0,0 +1,39 @@
+#ifndef gtk_cpp_workaround_h
+#define gtk_cpp_workaround_h
+#ifdef __cplusplus
+//proto is wrong, override here for C++
+namespace 
+{
+  
+inline void gtk_table_attach (GtkTable *table,
+		       GtkWidget *child,
+		       guint left_attach,
+		       guint right_attach,
+		       guint top_attach,
+		       guint bottom_attach,
+		       //GtkAttachOptions xoptions,
+		       //GtkAttachOptions yoptions,
+		       guint xoptions, guint yoptions,
+		       guint xpadding,
+		       guint ypadding
+		       ) 
+{
+  gtk_table_attach(table,
+		   child,
+		   left_attach,
+		   right_attach,
+		   top_attach,
+		   bottom_attach,
+		   (GtkAttachOptions)xoptions, 
+		   (GtkAttachOptions)yoptions,
+		   xpadding,
+		   ypadding
+		   );
+  
+    };
+
+
+}
+
+#endif
+#endif
n title='2020-01-16 19:20:21 +0100'>2020-01-16gnu: ldb: Downgrade to 1.5.6....Marius Bakke 2019-12-24gnu: samba: Update to 4.11.4....Tobias Geerinckx-Rice 2019-12-24gnu: tevent: Update to 0.10.2....Tobias Geerinckx-Rice 2019-12-24gnu: talloc: Update to 2.3.1....Tobias Geerinckx-Rice 2019-12-24gnu: cifs-utils: Update phase style....Tobias Geerinckx-Rice 2019-12-24gnu: cifs-utils: Update to 6.10....Tobias Geerinckx-Rice 2019-11-13gnu: iniparser: Don't use unstable tarball....Efraim Flashner 2019-11-01gnu: samba: Update to 4.11.2....Tobias Geerinckx-Rice 2019-09-24Merge branch 'master' into core-updatesLudovic Courtès 2019-09-19gnu: samba: Update to 4.11.0....Rutger Helling 2019-09-06Merge branch 'master' into core-updatesMark H Weaver 2019-09-05gnu: samba: Update to 4.10.8 [fixes CVE-2019-10197]....Marius Bakke 2019-09-05gnu: tevent: Update to 0.10.1....Marius Bakke 2019-09-05gnu: talloc: Update to 2.3.0....Marius Bakke 2019-08-13Merge branch 'master' into core-updatesMarius Bakke 2019-08-04gnu: samba: Update to 4.10.6....Marius Bakke 2019-07-12gnu: samba: Provide 'rpcgen'....Marius Bakke 2019-06-20gnu: samba: Update to 4.10.5 [fixes CVE-2019-12435, CVE-2019-12436]....Marius Bakke