aboutsummaryrefslogtreecommitdiff
This patch is to make sure that `libncurses' is among the `NEEDED'
dependencies of `libreadline.so' and `libhistory.so'.

Failing to do that, applications linking against Readline are
forced to explicitly link against libncurses as well; in addition,
this trick doesn't work when using GNU ld's `--as-needed'.

--- shlib/Makefile.in	2009-01-06 18:03:22.000000000 +0100
+++ shlib/Makefile.in	2009-07-27 14:43:25.000000000 +0200
@@ -84,7 +84,7 @@ SHOBJ_LDFLAGS = @SHOBJ_LDFLAGS@
 SHOBJ_XLDFLAGS = @SHOBJ_XLDFLAGS@
 SHOBJ_LIBS = @SHOBJ_LIBS@
 
-SHLIB_XLDFLAGS = @LDFLAGS@ @SHLIB_XLDFLAGS@
+SHLIB_XLDFLAGS = @LDFLAGS@ @SHLIB_XLDFLAGS@ -lncurses
 SHLIB_LIBS = @SHLIB_LIBS@
 
 SHLIB_DOT = @SHLIB_DOT@
hen cross-compiling. Smalltalk still fails to cross-compile though. * gnu/packages/smalltalk.scm (smalltalk)[arguments]{phases}<#:fix-libc>: Also search for "cross-libc" instead of only "libc" in 'inputs'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Maxime Devos 2021-06-04gnu: smalltalk: Move 'zip' from 'inputs' to 'native-inputs'....The 'zip' package is not in the references of 'smalltalk'. As such, it probably should be a native input, not a regular input. This can be confirmed by trying to cross-compile the 'smalltalk' package, without this commit. The configure script will ask to install InfoZIP. * gnu/packages/smalltalk.scm (smalltalk)[inputs]{zip}: Move to ... (smalltalk)[native-inputs]{zip} ... here. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Maxime Devos 2021-06-04gnu: smalltalk: Use 'inputs' in phases instead of '%build-inputs'....In build phases, the former is preferred. * gnu/packages/smalltalk.scm (smalltalk)[arguments]<#:phases>{fix-libc}: Use 'inputs' argument instead of '%build-inputs'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Maxime Devos 2021-01-05gnu: smalltalk: Update to version 3.2.91....* gnu/packages/smalltalk.scm (smalltalk): Update to 3.2.91. Co-Authored-By: Holger Peters <holger.peters@posteo.de> Miguel Ángel Arruga Vivas 2021-01-05gnu: smalltalk: Fix integer multiplication overflow....* gnu/local.mk (dist_patch_DATA): Add Smalltalk patch. * gnu/packages/patches/smalltalk-multiplication-overflow.patch: Patch from upstream commit 72ada189aba0283c551ead16635c1983968080b8. * gnu/packages/smalltalk.scm (smalltalk): Use patch and link with gmp and lightning libraries instead of the included source. Miguel Ángel Arruga Vivas