aboutsummaryrefslogtreecommitdiff
The moc executable loops through headers on CPLUS_INCLUDE_PATH and stumbles
on the GCC internal _GLIBCXX_VISIBILITY macro.  Tell it to ignore it as it is
not supposed to be looking there to begin with.

Upstream report: https://bugreports.qt.io/browse/QTBUG-83160

diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp
--- a/src/tools/moc/main.cpp
+++ b/src/tools/moc/main.cpp
@@ -188,6 +188,7 @@ int runMoc(int argc, char **argv)
     dummyVariadicFunctionMacro.arguments += Symbol(0, PP_IDENTIFIER, "__VA_ARGS__");
     pp.macros["__attribute__"] = dummyVariadicFunctionMacro;
     pp.macros["__declspec"] = dummyVariadicFunctionMacro;
+    pp.macros["_GLIBCXX_VISIBILITY"] = dummyVariadicFunctionMacro;
 
     QString filename;
     QString output;
th> 2021-11-11gnu: diffutils: Fix signal processing....diffutils has a race condition in its signal processing code which is easy to trigger on powerpc64le-linux. More often than not, it causes the ‘colors’ test to fail and therefore the build of the package fails as well. Add the patch proposed in Debian bug 922552 which fixes the problem. * gnu/packages/patches/diffutils-fix-signal-processing.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (diffutils)[source]: Use it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Thiago Jung Bauermann