aboutsummaryrefslogtreecommitdiff
Fix test failure of test_XXX caused by upgrade of gpgme from 1.6.0 to
1.8.0:

======================================================================
FAIL: test_encrypt_to_signonly (tests.test_encrypt_decrypt.EncryptDecryptTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/guix-build-python2-pygpgme-0.3.drv-0/pygpgme-0.3/tests/test_encrypt_decrypt.py", line 185, in test_encrypt_to_signonly
    self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_UNKNOWN)
AssertionError: 7 != 0

----------------------------------------------------------------------

Patch copied from the Debian package pygpgme-0.3-1.2:

https://sources.debian.net/src/pygpgme/0.3-1.2/debian/patches/0005-Fix-test-failures-with-pinentry.patch/

From: "Dr. Tobias Quathamer" <toddy@debian.org>
Date: Thu, 24 Nov 2016 12:20:54 +0100
Subject: Fix test failures with pinentry

---
 tests/test_encrypt_decrypt.py | 5 +++--
 tests/test_passphrase.py      | 2 ++
 2 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/tests/test_encrypt_decrypt.py b/tests/test_encrypt_decrypt.py
index 21ae83e..05707e1 100644
--- a/tests/test_encrypt_decrypt.py
+++ b/tests/test_encrypt_decrypt.py
@@ -132,6 +132,7 @@ class EncryptDecryptTestCase(GpgHomeTestCase):
             os.write(fd, b'Symmetric passphrase\n')
         ctx = gpgme.Context()
         ctx.armor = True
+        ctx.pinentry_mode = gpgme.PINENTRY_MODE_LOOPBACK
         ctx.passphrase_cb = passphrase
         ctx.encrypt(None, 0, plaintext, ciphertext)
         self.assertTrue(
@@ -182,8 +183,8 @@ class EncryptDecryptTestCase(GpgHomeTestCase):
             ctx.encrypt([recipient], gpgme.ENCRYPT_ALWAYS_TRUST,
                         plaintext, ciphertext)
         except gpgme.GpgmeError as exc:
-            self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_UNKNOWN)
-            self.assertEqual(exc.args[1], gpgme.ERR_GENERAL)
+            self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_GPGME)
+            self.assertEqual(exc.args[1], gpgme.ERR_UNUSABLE_PUBKEY)
         else:
             self.fail('gpgme.GpgmeError not raised')
 
diff --git a/tests/test_passphrase.py b/tests/test_passphrase.py
index 35b3c59..05e6811 100644
--- a/tests/test_passphrase.py
+++ b/tests/test_passphrase.py
@@ -34,6 +34,7 @@ class PassphraseTestCase(GpgHomeTestCase):
         ctx = gpgme.Context()
         key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
         ctx.signers = [key]
+        ctx.pinentry_mode = gpgme.PINENTRY_MODE_LOOPBACK
         plaintext = BytesIO(b'Hello World\n')
         signature = BytesIO()
 
@@ -55,6 +56,7 @@ class PassphraseTestCase(GpgHomeTestCase):
         ctx = gpgme.Context()
         key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
         ctx.signers = [key]
+        ctx.pinentry_mode = gpgme.PINENTRY_MODE_LOOPBACK
         ctx.passphrase_cb = self.passphrase_cb
         plaintext = BytesIO(b'Hello World\n')
         signature = BytesIO()
x/commit/gnu/packages/pciutils.scm?id=07bc32b4ceba1a25c545d8db7260f96b4a02dce7'>gnu: hwdata: Remove unused gzip native input....Brendan Tildesley 2022-03-22gnu: hwdata: Set #:target #f....Brendan Tildesley 2022-02-26gnu: Add hwdata....Brendan Tildesley 2022-01-10gnu: pciutils: Fix the conditional for the kmod input....Maxim Cournoyer 2021-12-13gnu: Simplify package inputs....Ludovic Courtès 2020-12-09gnu: pciutils: Fix compilation error on GNU/Hurd....Ludovic Courtès 2020-07-25gnu: pciutils: Update to 3.7.0....Marius Bakke 2020-03-26gnu: pciutils: Build fixes for the Hurd....Jan Nieuwenhuizen 2020-02-03gnu: pciutils: Update to 3.6.4....Marius Bakke 2020-01-24gnu: pciutils: Update to 3.6.3....Marius Bakke 2019-12-16gnu: pciutils: Fix cross-compilation....Mathieu Othacehe 2019-03-01gnu: pciutils: Update to 3.6.2....Marius Bakke 2018-07-13gnu: pciutils: Update to 3.6.1....Marius Bakke 2018-03-23gnu: pciutils: Use invoke....Mark H Weaver 2018-02-20Merge branch 'master' into stagingMarius Bakke 2018-02-20gnu: pciutils: Update to 3.5.6....Tobias Geerinckx-Rice 2018-02-19gnu: pciutils: Use HTTPS home page....Tobias Geerinckx-Rice 2017-07-10gnu: pciutils: Tweak description....Ludovic Courtès 2017-07-10gnu: pciutils: Move 'pci.ids.gz' to 'share/hwdata'....Ludovic Courtès 2017-07-10gnu: pciutils: Update to 3.5.5....Ludovic Courtès 2017-02-27gnu: pciutils: Update to 3.5.4....Marius Bakke 2016-11-30gnu: pciutils: Update to 3.5.2....Ludovic Courtès