aboutsummaryrefslogtreecommitdiff
From 16fbc38f13e435b4e3e1a37d706e64e05bad4691 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Tue, 10 Nov 2015 23:09:24 -0500
Subject: [PATCH] patch build to use setuptools

---
 setup.py | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index c6d57a6..27bf260 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,12 @@
 # http://opensource.org/licenses/BSD-3-Clause
 import os
 import sys
-from distutils.core import setup
+
+try:
+    from setuptools import setup
+except ImportError:
+    from distutils.core import setup
+
 # a simple import wouldn't work if we moved towards a package with __init__
 from _version import __version__
 
-- 
2.6.2

vice): Likewise. * gnu/services/dict.scm (dicod-shepherd-service): Likewise. * gnu/services/networking.scm (openntpd-shepherd-service): Likewise. (tor-shepherd-service): Likewise. * gnu/services/ssh.scm (openssh-shepherd-service): Likewise. * gnu/services/web.scm (nginx-shepherd-service): Likewise. * gnu/services/xorg.scm (gdm-shepherd-service): Likewise. * gnu/tests/base.scm (run-basic-test)["nscd configuration action"]: New test. * doc/guix.texi (Services): Document it. Ludovic Courtès 2022-11-17tests: lightdm: Use set-xorg-configuration to set keyboard layout....This is to validate that it works, when the login manager service type is properly specified. * gnu/tests/lightdm.scm (%lightdm-os): Use set-xorg-configuration. Maxim Cournoyer 2022-11-17tests: root-unmount: Wait for the first QEMU process to finish....There was a tiny possibility that the first QEMU process would still be running by the time we launch the second one. * gnu/build/marionette.scm (marionette-pid): Export. * gnu/tests/base.scm (run-root-unmount-test)[test]: Add 'waitpid' call. Ludovic Courtès 2022-10-07tests: xvnc: Do not use specification->package in OS definition....Doing so would cause the extra package dependencies to not be correctly registered as dependencies, which would lead to a silent failure when attempting to load or byte compile the module at the time guix build itself (e.g., when running 'guix pull'). * gnu/tests/vnc.scm (%xvnc-os) [packages]: Turn the the specification->package declaration into a list of package objects. Maxim Cournoyer 2022-10-07Revert "Revert "services: Add xvnc-service-type.""...This reverts commit 0c4966160054bc50e6ab3a4ac9c9a6a1826ab5a0. The fix appears in the subsequent commit, for clarity. Maxim Cournoyer 2022-10-07Revert "services: Add xvnc-service-type."...This reverts commit 1c528a95cb92b7808e6603d7956185005583629f. This broke 'guix pull', for (yet) unknown reasons. Maxim Cournoyer 2022-10-07services: Add xvnc-service-type....* gnu/services/vnc.scm: New file. * gnu/tests/vnc.scm: Likewise. * gnu/local.mk: Register them. Maxim Cournoyer 2022-10-07marionette: Make marionette-screen-text private....It has only one user, which is better suited for wait-for-screen-text anyway. * gnu/tests/base.scm (run-basic-test): Refactor to use wait-for-screen-text instead of marionette-screen-text. Maxim Cournoyer 2022-09-30tests: install: Fix iso-image-installer test....This is a follow-up of: 45eac6cdf5c8d9d7b0c564b105c790d2d2007799. It fixes the following error: + mkfs.ext4 -L my-root /dev/vda2 sh: line 12: mkfs.ext4: command not found * gnu/tests/install.scm (%test-iso-image-installer): Add e2fsprogs to the appended packages. Mathieu Othacehe 2022-09-26tests: telephony: Add missing import to fix jami tests....* gnu/tests/telephony.scm (run-jami-test): Add a missing (ice-9 match) import directive. Co-authored-by: Olivier Dion <olivier.dion@polymtl.ca> Maxim Cournoyer 2022-09-24services: Add wsdd service....* doc/guix.texi: Add documentation for wsdd service. * gnu/services/samba.scm (<wsdd-configuration>): New record. (wsdd-service-type): New variable. (wsdd-shepherd-services): New procedure. * gnu/tests/samba.scm (%wsdd-os): Add variable. (run-wsdd-test): New procedure. (%test-wsdd): New variable. Signed-off-by: Lars-Dominik Braun <lars@6xq.net> Simon Streit 2022-09-24services: Add samba service....* gnu/services/samba.scm: New file. * gnu/tests/samba.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add them. * po/guix/POTFILES.in Add 'gnu/services/samba.scm'. * doc/guix.texi: Document it. Signed-off-by: Lars-Dominik Braun <lars@6xq.net> Simon Streit 2022-09-24Revert "tests: telephony: Add extra packages to %jami-os for debugging."...This reverts commit 829c19142e62efa7ba9715fc682b4be959830b2e, as it broke 'guix pull'. Maxim Cournoyer 2022-09-23tests: jami-provisioning: Fix test derivation name....* gnu/tests/telephony.scm (run-jami-test): Fix test derivation name. Maxim Cournoyer 2022-09-23tests: telephony: Add extra packages to %jami-os for debugging....* gnu/tests/telephony.scm (make-jami-os): Add libjami:debug, gdb, guile, guile-ac-d-bus, guile-readline, guile-fibers, screen and strace. (run-jami-test)<jami service actions, ban/unban contacts>: Add (ice-9 match), for lambda-match (worked without it but needed when manually testing). Maxim Cournoyer