aboutsummaryrefslogtreecommitdiff
Always provide the same date and time in 'Py_GetBuildInfo'.
This is the information shown at the REPL and in 'sys.version'.
We cannot pass it in CPPFLAGS due to whitespace in the DATE string.

--- a/Modules/getbuildinfo.c
+++ b/Modules/getbuildinfo.c
@@ -4,6 +4,10 @@
 #include <stdio.h>
 #endif
 
+/* Deterministic date and time.  */
+#define DATE "Jan  1 1970"
+#define TIME "00:00:01"
+
 #ifndef DATE
 #ifdef __DATE__
 #define DATE __DATE__
class='list nowrap'>AgeCommit message (Expand)Author 2023-04-05gnu: openjdk9: Add patches to fix build....* gnu/packages/patches/openjdk-9-pointer-comparison.patch, gnu/packages/patches/openjdk-9-setsignalhandler.patch: New files. * gnu/local.mk (dist_patch_DATA): Register patches. * gnu/packages/java.scm (openjdk9)[origin]: Use patches. Andreas Enge