aboutsummaryrefslogtreecommitdiff
This patch allows the build process to use the provided dependencies instead
of adding their source as CMake sub-directories (in which case "make install"
would install googletest's and googlebenchmark's libraries and headers).

diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1cba55..627550f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,7 +36,7 @@ MACRO(PTHREADPOOL_TARGET_ENABLE_CXX11 target)
 ENDMACRO()
 
 # ---[ Download deps
-IF(NOT DEFINED FXDIV_SOURCE_DIR)
+IF(FALSE)
   MESSAGE(STATUS "Downloading FXdiv to ${CMAKE_BINARY_DIR}/FXdiv-source (define FXDIV_SOURCE_DIR to avoid it)")
   CONFIGURE_FILE(cmake/DownloadFXdiv.cmake "${CMAKE_BINARY_DIR}/FXdiv-download/CMakeLists.txt")
   EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -46,7 +46,7 @@ IF(NOT DEFINED FXDIV_SOURCE_DIR)
   SET(FXDIV_SOURCE_DIR "${CMAKE_BINARY_DIR}/FXdiv-source" CACHE STRING "FXdiv source directory")
 ENDIF()
 
-IF(PTHREADPOOL_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
+IF(FALSE)
   MESSAGE(STATUS "Downloading Google Test to ${CMAKE_BINARY_DIR}/googletest-source (define GOOGLETEST_SOURCE_DIR to avoid it)")
   CONFIGURE_FILE(cmake/DownloadGoogleTest.cmake "${CMAKE_BINARY_DIR}/googletest-download/CMakeLists.txt")
   EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -56,7 +56,7 @@ IF(PTHREADPOOL_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
   SET(GOOGLETEST_SOURCE_DIR "${CMAKE_BINARY_DIR}/googletest-source" CACHE STRING "Google Test source directory")
 ENDIF()
 
-IF(PTHREADPOOL_BUILD_BENCHMARKS AND NOT DEFINED GOOGLEBENCHMARK_SOURCE_DIR)
+IF(FALSE)
   MESSAGE(STATUS "Downloading Google Benchmark to ${CMAKE_BINARY_DIR}/googlebenchmark-source (define GOOGLEBENCHMARK_SOURCE_DIR to avoid it)")
   CONFIGURE_FILE(cmake/DownloadGoogleBenchmark.cmake "${CMAKE_BINARY_DIR}/googlebenchmark-download/CMakeLists.txt")
   EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -150,27 +150,18 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
 ENDIF()
 
 # ---[ Configure FXdiv
-IF(NOT TARGET fxdiv)
+IF(FALSE)
   SET(FXDIV_BUILD_TESTS OFF CACHE BOOL "")
   SET(FXDIV_BUILD_BENCHMARKS OFF CACHE BOOL "")
   ADD_SUBDIRECTORY(
     "${FXDIV_SOURCE_DIR}"
     "${CMAKE_BINARY_DIR}/FXdiv")
 ENDIF()
-TARGET_LINK_LIBRARIES(pthreadpool PRIVATE fxdiv)
-
 INSTALL(TARGETS pthreadpool
   LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
   ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
 
 IF(PTHREADPOOL_BUILD_TESTS)
-  # ---[ Build google test
-  IF(NOT TARGET gtest)
-    SET(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-    ADD_SUBDIRECTORY(
-      "${GOOGLETEST_SOURCE_DIR}"
-      "${CMAKE_BINARY_DIR}/googletest")
-  ENDIF()
 
   ADD_EXECUTABLE(pthreadpool-test test/pthreadpool.cc)
   SET_TARGET_PROPERTIES(pthreadpool-test PROPERTIES
@@ -188,14 +179,6 @@ IF(PTHREADPOOL_BUILD_TESTS)
 ENDIF()
 
 IF(PTHREADPOOL_BUILD_BENCHMARKS)
-  # ---[ Build google benchmark
-  IF(NOT TARGET benchmark)
-    SET(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "")
-    ADD_SUBDIRECTORY(
-      "${GOOGLEBENCHMARK_SOURCE_DIR}"
-      "${CMAKE_BINARY_DIR}/googlebenchmark")
-  ENDIF()
-
   ADD_EXECUTABLE(latency-bench bench/latency.cc)
   SET_TARGET_PROPERTIES(latency-bench PROPERTIES
     CXX_STANDARD 11
, dicollecte-french-dictionary, define-french-dictionary, hunspell-dict-fr-{classique, moderne, réforme, toutes-variantes}, hunspell-dict-pl, hunspell-dict-de, hunspell-dict-hu): Remove variables. * gnu/packages/hunspell.scm (hunspell, dicollecte-french-dictionary, define-french-dictionary, hunspell-dict-fr-{classique, moderne, réforme, toutes-variantes}, hunspell-dict-pl, hunspell-dict-de, hunspell-dict-hu, aspell-word-list, define-word-list-dictionary, hunspell-dict-{en, en-au, en-gb, en-gb-ize, en-us}): Add variables. (hunspell-dictionary): Explicitly declare upstream libreoffice version to prevent circular dependency. * gnu/packages/ebook.scm, gnu/packages/enchant.scm, gnu/packages/freedesktop.scm, gnu/packages/gnuzilla.scm, gnu/packages/kde-frameworks.scm, gnu/packages/messaging.scm, gnu/packages/scribus.scm, gnu/packages/task-management.scm, gnu/packages/telegram.scm, gnu/packages/tex.scm, gnu/packages/text-editors.scm, gnu/packages/video.scm: Adjust module imports. Brian Cully 2022-09-29gnu: qtwayland: Rename to qtwayland-5....Automated via: git grep -l qtwayland | xargs sed 's/\qtwayland\b/\0-5/g' -i git checkout NEWS Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Hilton Chain 2022-09-28gnu: telegram: Remove unused variables....* gnu/packages/telegram.scm (lib-rlottie-for-telegram-desktop) (lib-waylandshells-for-telegram-desktop,libtgvoip-for-telegram-desktop): Remove variables. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-28gnu: telegram-desktop: Sort inputs alphabetically....* gnu/packages/telegram.scm (telegram-desktop)[inputs]: Sort inputs alphabetically. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-28gnu: telegram-desktop: Update to 4.2.2....* gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch. * gnu/packages/telegram.scm (tgcalls-for-telegram-desktop) (codegen-for-telegram-desktop,lib-base-for-telegram-desktop) (lib-crl-for-telegram-desktop,lib-lottie-for-telegram-desktop) (lib-qr-for-telegram-desktop,lib-rpl-for-telegram-desktop) (lib-spellcheck-for-telegram-desktop,lib-storage-for-telegram-desktop) (lib-tl-for-telegram-desktop,lib-ui-for-telegram-desktop) (lib-webrtc-for-telegram-desktop,lib-webview-for-telegram-desktop) (cmake-helpers-for-telegram-desktop): Bump to submodule checkout. (rlottie-for-telegram-desktop): Bump to submodule checkout. [snippet]: Switch off werror. [arguments]: Inherit from rlottie. (telegram-desktop): Update to 4.2.2. [patches]: Add telegram-desktop-allow-disable-libtgvoip.patch. [arguments]<#:configure-flags>: Unbundle rlottie. <#:phases>: Adjusted accordingly. [native-inputs]: Add clang-toolchain. Remove cmake-shared, extra-cmake-modules and qttools-5. [inputs]: Add abseil-cpp-cxxstd17, kcoreaddons, libdispatch, libvpx, wayland, webkitgtk. Remove catch2, kwayland, libdbusmenu-qt, libtgvoip-for-telegram-desktop, libx11, materialdecoration and qt5ct. [propagated-inputs]: Remove dconf. [license]: Adjust accordingly. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-28gnu: Remove libvpx-for-telegram-desktop....* gnu/packages/telegram.scm (libvpx-for-telegram-desktop): Remove variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-28gnu: webrtc-for-telegram-desktop: Sort inputs alphabetically....* gnu/packages/telegram.scm (webrtc-for-telegram-desktop)[inputs]: Sort inputs alphabetically. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-28gnu: webrtc-for-telegram-desktop: Update to 621f3da5....* gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to 621f3da5. [patches]: Add webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch. [snippet]: Unbundle libvpx and openh264. [native-inputs]: Remove perl. [inputs]: Replace pipewire with pipewire-0.3. Add abseil-cpp-cxxstd17, libdrm, libglvnd, libvpx, libxfixes, mesa, openh264. Remove alsa-lib, libx11 and pulseaudio. [arguments]<#:phases>: Adjust accordingly. [license]: Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-21gnu: telegram-desktop: Use API ID from Snap builds....* gnu/packages/telegram.scm (telegram-desktop)[#:configure-flags]: Use API ID from Telegram's official Snap builds. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-21gnu: telegram-desktop: Use modern package style....* gnu/packages/telegram.scm (%telegram-version) (cmake-helpers-for-telegram-desktop, codegen-for-telegram-desktop) (lib-base-for-telegram-desktop, lib-crl-for-telegram-desktop) (lib-lottie-for-telegram-desktop, lib-qr-for-telegram-desktop) (lib-rlottie-for-telegram-desktop,lib-rpl-for-telegram-desktop) (lib-spellcheck-for-telegram-desktop, lib-storage-for-telegram-desktop) (lib-tl-for-telegram-desktop, lib-ui-for-telegram-desktop) (lib-waylandshells-for-telegram-desktop, lib-webrtc-for-telegram-desktop) (lib-webview-for-telegram-desktop, tgcalls-for-telegram-desktop): New variables. (telegram-desktop)[arguments]: Convert to list of G-Expressions. <#:phases>: Inline cmake-helpers-for-telegram-desktop, codegen-for-telegram-desktop, lib-base-for-telegram-desktop, lib-crl-for-telegram-desktop, lib-lottie-for-telegram-desktop, lib-qr-for-telegram-desktop, lib-rlottie-for-telegram-desktop, lib-rpl-for-telegram-desktop, lib-spellcheck-for-telegram-desktop, lib-storage-for-telegram-desktop, lib-tl-for-telegram-desktop, lib-ui-for-telegram-desktop, lib-waylandshells-for-telegram-desktop, lib-webrtc-for-telegram-desktop, lib-webview-for-telegram-desktop, and tgcalls-for-telegram-desktop. [native-inputs]: Remove cmake-helpers. Drop labels. [inputs]: Remove codegen-source, lib-base-source, lib-crl-source, lib-lottie-source, lib-qr-source, lib-rlottie-source, lib-rpl-source, lib-spellcheck-source, lib-storage-source, lib-tl-source, lib-ui-source, lib-waylandshells-source, lib-webrtc-source, lib-webview-source and tgcalls-source. Drop labels. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-21gnu: webrtc-for-telegram-desktop: Use modern package style....* gnu/packages/telegram.scm (libvpx-for-telegram-desktop) (libyuv-for-telegram-desktop): New variables. (webrtc-for-telegram-desktop)[arguments]: Convert to list of G-Expressions. Inline libvpx-for-telegram-desktop and libyuv-for-telegram-desktop. [inputs]: Remove libvpx and libyuv. Drop labels. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-21gnu: telegram-desktop: Delete trailing #t....* gnu/packages/telegram.scm (telegram-desktop)[source]: Delete trailing #t. [arguments]<#:phases>: Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-21gnu: webrtc-for-telegram-desktop: Delete trailing #t....* gnu/packages/telegram.scm (webrtc-for-telegram-desktop)[source]: Delete trailing #t. [arguments]<#:phases>: Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Hilton Chain 2022-09-15gnu: catch-framework2: Rename variable to catch2....Automated with: git grep -l catch-framework2 | xargs sed 's/catch-framework2/catch2/g' -i Maxim Cournoyer 2022-08-14gnu: rnnoise: Unhide and rename variable....* gnu/packages/xiph.scm (xiph-rnnoise): Rename to… (rnnoise): …this. Adjust all users. [properties]: Remove HIDDEN? property as it is no longer ambiguous. Tobias Geerinckx-Rice