aboutsummaryrefslogtreecommitdiff
Use 'uname -m', which in practice returns the processor architecture.

--- psm-3.3/buildflags.mak~	2014-08-20 21:00:18.000000000 +0100
+++ psm-3.3/buildflags.mak	2017-10-22 12:02:12.855291447 +0100
@@ -38,7 +38,7 @@
 endif
 
 export os ?= $(shell uname -s | tr '[A-Z]' '[a-z]')
-export arch := $(shell uname -p | sed -e 's,\(i[456]86\|athlon$$\),i386,')
+export arch := $(shell uname -m | sed -e 's,\(i[456]86\|athlon$$\),i386,')
 
 CC ?= gcc
 
2gnu: boinc-client: Update to 7.22.2....* gnu/packages/distributed.scm (boinc-client): Update to 7.22.2. Tobias Geerinckx-Rice 2023-07-02gnu: boinc-server: Remove input labels....* gnu/packages/distributed.scm (boinc-server)[inputs, propagated-inputs]: Remove input labels. Tobias Geerinckx-Rice 2023-07-02gnu: boinc-server: Use G-expressions....* gnu/packages/distributed.scm (boinc-server)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-07-02gnu: boinc-client: Use G-expressions....* gnu/packages/distributed.scm (boinc-client)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2023-05-02gnu: boinc-client, boinc-server: Update to 7.22.0....* gnu/packages/distributed.scm (boinc-client): Update to 7.22.0. Eric Bavier 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-07-02gnu: boinc-client, boinc-server: Update to 7.16.17....* gnu/packages/distributed.scm (boinc-client): Update to 7.16.17. (boinc-server): Run the test suite. Tobias Geerinckx-Rice