aboutsummaryrefslogtreecommitdiff
Fix CVE-2017-16844:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16844
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876511

Patch copied from Debian procmail package 3.22-26:

http://http.debian.net/debian/pool/main/p/procmail/procmail_3.22-26.debian.tar.xz

From: Santiago Vila <sanvila@debian.org>
Subject: Fix heap-based buffer overflow in loadbuf()
Bug-Debian: http://bugs.debian.org/876511
X-Debian-version: 3.22-26

--- a/src/formisc.c
+++ b/src/formisc.c
@@ -103,7 +103,7 @@
 }
 							    /* append to buf */
 void loadbuf(text,len)const char*const text;const size_t len;
-{ if(buffilled+len>buflen)			  /* buf can't hold the text */
+{ while(buffilled+len>buflen)			  /* buf can't hold the text */
      buf=realloc(buf,buflen+=Bsize);
   tmemmove(buf+buffilled,text,len);buffilled+=len;
 }
on>
authorLeo Famulari <leo@famulari.name>2021-02-22 13:25:16 -0500
committerLeo Famulari <leo@famulari.name>2021-02-22 13:26:14 -0500
commita821818fb78bc352aef81a5f8d162729de3e5c8a (patch)
tree46c8cf068c99b1e9f314321dda739e8022bc106b
parentad06c29b37924ecf5eb3bd440c7456cad6415c3b (diff)
downloadguix-a821818fb78bc352aef81a5f8d162729de3e5c8a.tar.gz
guix-a821818fb78bc352aef81a5f8d162729de3e5c8a.zip
gnu: python-sane: Correct the license.
This is a followup to commit f500905ce1baf85a2407c5ccde148ee6c2ea2584. * gnu/packages/python-xyz.scm (python-sane)[license]: Describe the license.
Diffstat
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e42cbc561c..072cc3db53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23928,7 +23928,9 @@ restores the original state after the string is printed.")
(synopsis "Python interface to the SANE scanner")
(description "This package provides Python interface to the SANE scanner
and frame grabber interface.")
- (license license:expat)))
+ (license (license:non-copyleft
+ ;; Yet another variant of the X/MIT license.
+ "https://github.com/python-pillow/Sane/blob/master/COPYING"))))
(define-public python-screenkey
(package