aboutsummaryrefslogtreecommitdiff
https://sources.debian.org/data/main/p/plib/1.8.5-8/debian/patches/04_CVE-2011-4620.diff

--- a/src/util/ulError.cxx
+++ b/src/util/ulError.cxx
@@ -39,7 +39,7 @@
 {
   va_list argp;
   va_start ( argp, fmt ) ;
-  vsprintf ( _ulErrorBuffer, fmt, argp ) ;
+  vsnprintf ( _ulErrorBuffer, sizeof(_ulErrorBuffer), fmt, argp ) ;
   va_end ( argp ) ;
  
   if ( _ulErrorCB )
ggable-search.patch?id=d461dd81cd688ddd63892204a19b3456810352e8'>perl-module-pluggable-search.patch
AgeCommit message (Expand)Author